Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030898
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-09-23 13:122015-09-26 17:09
ReportermaiteView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision7246aca9460a
ProjectionnoneETAnoneTarget Version3.0PR15Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-09-23
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
Triggers an Emergency PackNo
Summary

0030898: Payment registered for child organization not found in Payment selector when running "add transaction" from Match Statement

DescriptionPayment registered for child organization not found in Payment selector when running "add transaction" from Match Statement
Steps To Reproduce1. Access financial account "Cuenta de Banco", go to Payment Method tab and disable "automatic deposit" for IN flow and Transferencia payment method
2. Access Payment In window and register new document for "España Norte" organization using Transferencia payment method. Add any line and process (NOT deposit)
3. Access "Cuenta de Banco" financial account, go to Reconciliation tab and rectivate las reconciliation
4. Run "Match statement" process, unmatch any line and press "+" button to add transaction
5. Open "Payment" selector and realize that you can not find previously created payment
Proposed SolutionProblem is in "Payment Selector Transaction for Parameter Window" reference. If you check "HQL where" clause you can see that function " AD_ISORGINCLUDED(@inpadOrgId@, e.organization.id,e.client.id)<>-1" is used liked this. However parameters for this function should be:
" AD_ISORGINCLUDED(e.organization.id,@inpadOrgId@, e.client.id)<>-1"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00309163.0PR15Q3.2 closedAtulOpenbravo Payment registered for child organization not found in Payment selector when running "add transaction" from Match Statement 
depends on backport 00309173.0PR15Q2.6 closedAtulOpenbravo Payment registered for child organization not found in Payment selector when running "add transaction" from Match Statement 
caused by feature request 00293903.0PR14Q4 closedSandrahuguet Reconciliation refactor project 

-  Notes
(0080596)
AtulOpenbravo (developer)
2015-09-24 03:09

Test Plan
- Access financial account "Cuenta de Banco", go to Payment Method tab and disable "automatic deposit" for IN flow and Transferencia payment method.
- Access Payment In window and register new document for "España Norte" organization using Transferencia payment method. Add any line and process (NOT deposit).
- Access "Cuenta de Banco" financial account, go to Reconciliation tab and rectivate last reconciliation record.
- Run "Match statement" process, unmatch any line and press "+" button to add transaction.
- Open "Payment" selector and check that you can find and select previously created payment.
(0080609)
vmromanos (developer)
2015-09-24 12:52

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8627 [^]
(0080613)
hgbot (developer)
2015-09-24 13:09

Repository: erp/devel/pi
Changeset: 7246aca9460a91451d33fce86d53ecc44b654195
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Sep 24 06:09:02 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/7246aca9460a91451d33fce86d53ecc44b654195 [^]

Fixes Issue 30898:Payment registered for child organization not found in
Payment selector when running "add transaction" from Match Statement

Parameters passed to AD_IsOrgIncluded in correct order.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/OBUISEL_SELECTOR.xml
---
(0080619)
vmromanos (developer)
2015-09-24 13:14

Code review + testing OK
(0080652)
hudsonbot (developer)
2015-09-26 17:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c198449f8f58 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-09-23 13:12 maite New Issue
2015-09-23 13:12 maite Assigned To => Triage Finance
2015-09-23 13:12 maite Modules => Core
2015-09-23 13:12 maite Triggers an Emergency Pack => No
2015-09-23 13:14 maite Issue Monitored: networkb
2015-09-24 03:03 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2015-09-24 03:03 AtulOpenbravo Status new => scheduled
2015-09-24 03:09 AtulOpenbravo Note Added: 0080596
2015-09-24 11:09 vmromanos Relationship added caused by 0029390
2015-09-24 11:11 vmromanos Review Assigned To => vmromanos
2015-09-24 11:11 vmromanos Regression level => Production - Confirmed Stable
2015-09-24 11:11 vmromanos Regression date => 2014-09-23
2015-09-24 11:11 vmromanos Regression introduced in release => 3.0PR14Q4
2015-09-24 11:11 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
2015-09-24 11:12 vmromanos Status scheduled => acknowledged
2015-09-24 11:12 vmromanos Status acknowledged => scheduled
2015-09-24 12:52 vmromanos Note Added: 0080609
2015-09-24 13:09 hgbot Checkin
2015-09-24 13:09 hgbot Note Added: 0080613
2015-09-24 13:09 hgbot Status scheduled => resolved
2015-09-24 13:09 hgbot Resolution open => fixed
2015-09-24 13:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7246aca9460a91451d33fce86d53ecc44b654195 [^]
2015-09-24 13:14 vmromanos Note Added: 0080619
2015-09-24 13:14 vmromanos Status resolved => closed
2015-09-26 17:09 hudsonbot Checkin
2015-09-26 17:09 hudsonbot Note Added: 0080652


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker