Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030297
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-07-02 09:462015-08-20 23:16
ReporterngarciaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revision22f85795e81f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-08-24
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/976a64153145b468099f13d78289ad45b4fb06c7 [^]
Triggers an Emergency PackNo
Summary

0030297: Reference with Search parent reference (old selector) is not working under some circumstances

DescriptionReference with Search parent reference (old selector) is not working under some circumstances
Steps To ReproduceAs system admin role:
   Add Name in Display Field field (Defined Selector tab) for the Product reference
As group admin role:
   Create a Sales Order
   Add a line, select one product in the Product selector and check the following error is shown (Developers tools):
      Uncaught TypeError: Cannot read property 'replace' of undefined
   As a consequence, the callout is not launched
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00303163.0PR15Q3 closedalostale Reference with Search parent reference (old selector) is not working under some circumstances 
depends on backport 00303173.0PR15Q2.3 closedalostale Reference with Search parent reference (old selector) is not working under some circumstances 
caused by defect 00274693.0PR14Q4 closedshankarb Unexpected behavior in OBUISEL_Selector reference when the Display Field is set 
related to defect 0030362 acknowledgedplatform selector display field in-homogeneous behavior in grid and drop down 
causes defect 0030403 closedcaristu Unexpected behavior in grid view with OBUISEL_Selector reference when the Display Field is set 

-  Notes
(0078659)
alostale (developer)
2015-07-06 11:17

Fix tested with Search and OBUISEL_Selector references having display field for property in the main entity and in a referenced one.

It has also been tested issue 0027469 is not reproducible after the fix.
(0078664)
hgbot (developer)
2015-07-06 11:21

Repository: erp/devel/pi
Changeset: 22f85795e81fcad7a6c4c5465ba60d582c69919b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jul 06 11:20:55 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/22f85795e81fcad7a6c4c5465ba60d582c69919b [^]

fixed bug 30297: selectors with display field property fail

  They failed in case the display field property was not in the main property but
  in a referenced one. In this case, the property was tried to be obtained from the
  record object in an incorrect manner (path to the referred entity was removed).

  The fix preserves path to referred entity and checks for not null value before
  doing replacements in the string.

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0078681)
AugustoMauch (developer)
2015-07-06 16:39

Code reviewed and verified in pi@adc2491ee60b
(0079471)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-07-02 09:46 ngarcia New Issue
2015-07-02 09:46 ngarcia Assigned To => platform
2015-07-02 09:46 ngarcia Modules => Core
2015-07-02 09:46 ngarcia Triggers an Emergency Pack => No
2015-07-02 09:49 ngarcia Issue Monitored: networkb
2015-07-03 09:42 ngarcia Relationship added caused by 0027469
2015-07-06 11:13 alostale Regression level => Production - Confirmed Stable
2015-07-06 11:13 alostale Regression date => 2014-08-24
2015-07-06 11:13 alostale Regression introduced in release => 3.0PR14Q4
2015-07-06 11:13 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/976a64153145b468099f13d78289ad45b4fb06c7 [^]
2015-07-06 11:13 alostale Priority high => immediate
2015-07-06 11:13 alostale Assigned To platform => alostale
2015-07-06 11:13 alostale Status new => scheduled
2015-07-06 11:17 alostale Note Added: 0078659
2015-07-06 11:21 hgbot Checkin
2015-07-06 11:21 hgbot Note Added: 0078664
2015-07-06 11:21 hgbot Status scheduled => resolved
2015-07-06 11:21 hgbot Resolution open => fixed
2015-07-06 11:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/22f85795e81fcad7a6c4c5465ba60d582c69919b [^]
2015-07-06 11:22 alostale Review Assigned To => AugustoMauch
2015-07-06 16:39 AugustoMauch Note Added: 0078681
2015-07-06 16:39 AugustoMauch Status resolved => closed
2015-07-06 16:39 AugustoMauch Fixed in Version => 3.0PR15Q4
2015-07-15 08:50 alostale Relationship added related to 0030362
2015-07-22 10:10 alostale Relationship added causes 0030403
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079471


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker