Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030296
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2015-06-29 13:082015-07-07 09:44
ReporteregoitzView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q2.3
StatusclosedFix in branchFixed in SCM revision201080ae3edc
ProjectionnoneETAnoneTarget Version3.0PR15Q2.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030296: In saved views with multiple criteria in one field, the uuid value is shown in the column header when filtering sometimes

DescriptionWhen filtering on a FK column with two values, and then on a next column filtering a different FK for a unique value, the value shown on the last column is the uuid
Steps To ReproduceSteps to reproduce:
1. Go to Sales Order window
2. In grid view, filter business partner form the drop-down by "==Hoteles Buenas Noches, S.A. or
==Restaurantes Luna Llena, S.A." and Payment method "==Transferencia"
3. Save view as "test"
4. Reopen sales order window and apply the saved view "test" -> payment method filter shows its
identifier ==A97CFD2AFC234B59BB0A72189BD8FC2A instead of ==Transferencia, making subsequent
filtering actions fail.


Notes:
- If you filter business partner by just one value, behavior is always ok
- If you move the column business partner after the column with a single filter, behavior seems to be OK
too, however if business partner (or the column with several values selected from the drop down) is
before payment method, behavior is wrong.
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00302743.0PR15Q4 closedcaristu In saved views with multiple criteria in one field, the uuid value is shown in the column header when filtering sometimes 

-  Notes
(0078611)
hgbot (developer)
2015-07-02 09:51

Repository: erp/backports/3.0PR15Q2.3
Changeset: 201080ae3edce57c5f2a2538aca07eadc7905a26
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Jul 01 12:43:26 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/201080ae3edce57c5f2a2538aca07eadc7905a26 [^]

Fixes issue 30296: uuid appear in saved views with multiple criteria on a field

When a view is saved while any of its filters are currently using the 'id' filter type, the id and identifier of the selected options are stored in a cache. If we have multiple criteria on one field, an internal loop is executed to retrieve all the criterias in the getFKFilterAuxiliaryCache function.

The problem was that this internal loop was using the same variable as the external one to insert those criterias into the cache. This caused that the subsequent filters for next fields were not being handled properly as the condition of the external loop was not being fulfilled anymore due to the increment done in the internal loop.

This has been solved just using a new variable (j) in the internal loop.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0078696)
alostale (developer)
2015-07-07 09:44

code reviewed

tested:
* Saved view
* Default saved view
* Direct link

- Issue History
Date Modified Username Field Change
2015-07-01 12:27 caristu Type defect => backport
2015-07-01 12:27 caristu Target Version => 3.0PR15Q2.3
2015-07-01 12:39 caristu Summary The uuid value is shown in the column header when filtering. => In saved views with multiple criteria in one field, the uuid value is shown in the column header when filtering sometimes
2015-07-02 09:05 alostale Tag Attached: Approved
2015-07-02 09:50 caristu Issue Monitored: alostale
2015-07-02 09:50 caristu Review Assigned To => alostale
2015-07-02 09:51 hgbot Checkin
2015-07-02 09:51 hgbot Note Added: 0078611
2015-07-02 09:51 hgbot Status scheduled => resolved
2015-07-02 09:51 hgbot Resolution open => fixed
2015-07-02 09:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/201080ae3edce57c5f2a2538aca07eadc7905a26 [^]
2015-07-07 09:37 alostale Severity major => minor
2015-07-07 09:44 alostale Note Added: 0078696
2015-07-07 09:44 alostale Status resolved => closed
2015-07-07 09:44 alostale Fixed in Version => 3.0PR15Q2.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker