Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030232
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementcriticalalways2015-06-23 13:302015-08-20 23:16
ReportermaiteView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionfb92cb9bd2eb
ProjectionnoneETAnoneTarget Version3.0PR15Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030232: Costing record not referencing any inventory transaction is created when processing Landed Cost document, under some circumstanc

DescriptionCosting record not referencing any inventory transaction is created when processing Landed Cost document, under some circumstances
Steps To Reproduce1. Create new product named "cost". Access Price tab and define price=2 for Bebidas Alegres pricelist
2. Register new Goods Receipt with:
  2.1 Line1: Product cost, unit=2, bin=0.0.0
  2.2 Line2: Product cost, unit=1, bin=1.0.0
Complete it and do not execute Costing Background.
3. Register Goods Shipment. Add line with 2 unit of product cost and bin 0.0.0
Complete it and do not execute Costing Background.
4. Void previous Goods Shipment.
5. Access Process Request window and run "Costing background". Realize that cost has been calculated for your product
6. Create new Landed Cost type referencing any gl item
7. Register new Landed Cost document.
  7.1 Access Cost tab and register new cost referencing previous Landed Cost type and setting amount=5 and currency EUR
  7.2 Access Cost tab and register new cost referencing previous Landed Cost type and setting amount=55 and currency MXN
  7.3 Access Receipt tab and select previous goods receipt
  7.4 Process landed cost document
8. Access Product | Costing tab and realize that cost has been recalculated but also new register has been added not referencing any inventory transaction, which is wrong

Repeat the same steps but running "Costing Background" process after complete each transaction (steps 2, 3 and 4) and realize Product | Costing records are created correctly.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0078623)
aferraz (developer)
2015-07-02 11:57

Test plan:

Follow the steps to reproduce and realize in both cases Product | Costing records are created correctly, with no records with inventory transaction empty.
(0078674)
psanjuan (manager)
2015-07-06 13:50
edited on: 2015-07-06 13:52

Verified it is working OK.
In both cases product transactions are calculated OK, same us average product cost.

(0078675)
hgbot (developer)
2015-07-06 13:56

Repository: erp/devel/pi
Changeset: fb92cb9bd2eb4a675e406427959197435267dbf3
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Jul 03 11:08:17 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fb92cb9bd2eb4a675e406427959197435267dbf3 [^]

Fixes issue 30232: Costing record not referencing transaction

getRelatedTransactions method in AverageCostAdjustment.java was creating an HQL query with a wrong parenthesis. Because of that Order By clause did not appear in the query, what was causing wrong Costing entries.
Also, when this error happens, current costing will be updated with the new cost, instead of creating a new costing with a null transaction.

---
M src/org/openbravo/costing/AverageCostAdjustment.java
---
(0079473)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-06-23 13:30 maite New Issue
2015-06-23 13:30 maite Assigned To => Triage Finance
2015-06-23 13:30 maite Modules => Core
2015-06-23 13:30 maite Triggers an Emergency Pack => No
2015-06-23 13:30 maite Issue Monitored: networkb
2015-07-01 12:00 aferraz Assigned To Triage Finance => aferraz
2015-07-01 14:20 aferraz Steps to Reproduce Updated View Revisions
2015-07-01 15:02 aferraz Steps to Reproduce Updated View Revisions
2015-07-02 11:48 aferraz Steps to Reproduce Updated View Revisions
2015-07-02 11:57 aferraz Note Added: 0078623
2015-07-06 12:14 vmromanos Status new => scheduled
2015-07-06 13:50 psanjuan Note Added: 0078674
2015-07-06 13:52 psanjuan Note Edited: 0078674 View Revisions
2015-07-06 13:56 hgbot Checkin
2015-07-06 13:56 hgbot Note Added: 0078675
2015-07-06 13:56 hgbot Status scheduled => resolved
2015-07-06 13:56 hgbot Resolution open => fixed
2015-07-06 13:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fb92cb9bd2eb4a675e406427959197435267dbf3 [^]
2015-07-06 13:56 vmromanos Review Assigned To => vmromanos
2015-07-06 13:56 vmromanos Status resolved => closed
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079473


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker