Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030204
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. PlatformmajorN/A2015-06-18 14:132015-08-20 23:16
ReporteralostaleView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revision5bdafea397d7
ProjectionnoneETAnoneTarget Version3.0PR15Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030204: prevent unpaged datsource request from manual sources

DescriptionStarting from 3.0PR14Q3, unpaged requests to datasource are logged as warning if coming from manual sources and completely prevented if they come from a grid.

By default they should be prevented even if coming from manual sources, and only optionally allow them
Steps To Reproduce-
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00266833.0PR14Q3 closedalostale prevent unpaged datasource requests 
related to feature request 0032039 closedcaristu Add generic mechanism to have multiple cached preferences 
related to defect 0034499 closedcaristu [clustering] CachedPreference feature is not supported on clustered environments 

-  Notes
(0079041)
hgbot (developer)
2015-07-23 12:26

Repository: erp/devel/pi
Changeset: c1e9aa2553bf20bc4ac092b3f711709e23c0ae3b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jul 23 12:25:24 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c1e9aa2553bf20bc4ac092b3f711709e23c0ae3b [^]

Related to issue 30204: applied correct format to DefaultJsonDataService

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0079148)
hgbot (developer)
2015-07-31 14:07

Repository: erp/devel/pi
Changeset: 5bdafea397d73e01e0841273db10a717791d0bc0
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jul 31 14:04:15 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5bdafea397d73e01e0841273db10a717791d0bc0 [^]

fixes issue 30204: prevent unpaged datasource request from manual sources


Now the unpaged datasource requests are controlled by the OBJSON_AllowUnpagedDatasourceManualRequest preference. If it is set to N (default) is not possible to perform these kind of requests. They can be enabled by setting this preference to Y.
In order to have a better performance on the datasource when requesting for the preference value, the value of the preference is being cached by the UnpagedRequestCachedPreference class

---
M modules/org.openbravo.service.json/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonConstants.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonRestServlet.java
M src-test/src/org/openbravo/test/AllWebserviceTests.java
M src/org/openbravo/erpCommon/businessUtility/Preferences.java
A modules/org.openbravo.client.application/src/org/openbravo/client/application/event/PreferenceEventHandler.java
A modules/org.openbravo.service.json/src-db/database/sourcedata/AD_PREFERENCE.xml
A modules/org.openbravo.service.json/src-db/database/sourcedata/AD_REF_LIST.xml
A modules/org.openbravo.service.json/src/org/openbravo/service/json/UnpagedRequestCachedPreference.java
A src-test/src/org/openbravo/test/datasource/TestAllowUnpagedDatasourcePreference.java
---
(0079150)
hgbot (developer)
2015-07-31 14:35

Repository: erp/devel/pi
Changeset: 22df813f4077182b8176caa40f8f4789fd530916
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jul 31 14:34:39 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/22df813f4077182b8176caa40f8f4789fd530916 [^]

Related to issue 30204: added missing copyright information

---
M src-test/src/org/openbravo/test/datasource/TestAllowUnpagedDatasourcePreference.java
M src/org/openbravo/erpCommon/businessUtility/Preferences.java
---
(0079151)
hgbot (developer)
2015-07-31 16:05

Repository: erp/devel/pi
Changeset: 842c4192a953bc52fa794617cd3091dd2b62141b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jul 31 16:03:50 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/842c4192a953bc52fa794617cd3091dd2b62141b [^]

related to issue 30204: fix for test case

---
M src-test/src/org/openbravo/test/datasource/TestAllowUnpagedDatasourcePreference.java
---
(0079153)
hgbot (developer)
2015-07-31 18:12

Repository: erp/devel/pi
Changeset: 903256a107c370a52ca07f9da1c112a54f9e6060
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jul 31 18:11:35 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/903256a107c370a52ca07f9da1c112a54f9e6060 [^]

Related to issue 30204: show the error messages properly when using oracle

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0079168)
hgbot (developer)
2015-08-04 09:28

Repository: erp/devel/pi
Changeset: 20073455885a52705c40247e064e2daf126cfe43
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 04 09:28:00 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/20073455885a52705c40247e064e2daf126cfe43 [^]

Related to issue 30204: code review improvements

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/event/PreferenceEventHandler.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/UnpagedRequestCachedPreference.java
M src-test/src/org/openbravo/test/datasource/TestAllowUnpagedDatasourcePreference.java
---
(0079169)
hgbot (developer)
2015-08-04 11:13

Repository: erp/devel/pi
Changeset: a36c4e3eb5b0d7457bdc1b38faed026b8c595215
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 04 11:12:28 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a36c4e3eb5b0d7457bdc1b38faed026b8c595215 [^]

Related to issue 30204: fix for test case

---
M src-test/src/org/openbravo/test/datasource/TestAllowUnpagedDatasourcePreference.java
---
(0079180)
hgbot (developer)
2015-08-04 12:33

Repository: erp/devel/pi
Changeset: 753c241b006723174da172eac9073decfbda9de9
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 04 12:32:31 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/753c241b006723174da172eac9073decfbda9de9 [^]

Related to issue 30204: fix for test case

The problem was that default client and organization are null by default, now a check is done to avoid this problem.

---
M src-test/src/org/openbravo/test/datasource/TestAllowUnpagedDatasourcePreference.java
---
(0079188)
hgbot (developer)
2015-08-04 15:37

Repository: erp/devel/pi
Changeset: d7fa3edf098c2cffa164bd0d30792467e4c5d61f
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 04 15:36:02 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d7fa3edf098c2cffa164bd0d30792467e4c5d61f [^]

Related to issue 30204: new fix for test case

The test case was not working properly when there were not modules in in development status

---
M src-test/src/org/openbravo/test/datasource/TestAllowUnpagedDatasourcePreference.java
R modules/org.openbravo.service.json/src-db/database/sourcedata/AD_PREFERENCE.xml
---
(0079240)
alostale (developer)
2015-08-07 08:45

code reviewed

tested with manual datasources and json ws (later ones are allowed)
(0079505)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079513)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079514)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079515)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079516)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079517)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079518)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079520)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079524)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-06-18 14:13 alostale New Issue
2015-06-18 14:13 alostale Assigned To => platform
2015-06-18 14:13 alostale Modules => Core
2015-06-18 14:13 alostale Triggers an Emergency Pack => No
2015-06-18 14:13 alostale Relationship added has duplicate 0026683
2015-06-18 14:13 alostale Status new => acknowledged
2015-07-22 09:42 alostale Assigned To platform => caristu
2015-07-22 09:42 alostale Tag Attached: Performance
2015-07-22 09:43 alostale Relationship replaced related to 0026683
2015-07-23 12:26 hgbot Checkin
2015-07-23 12:26 hgbot Note Added: 0079041
2015-07-31 14:07 caristu Review Assigned To => alostale
2015-07-31 14:07 caristu Issue Monitored: alostale
2015-07-31 14:07 hgbot Checkin
2015-07-31 14:07 hgbot Note Added: 0079148
2015-07-31 14:07 hgbot Status acknowledged => resolved
2015-07-31 14:07 hgbot Resolution open => fixed
2015-07-31 14:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5bdafea397d73e01e0841273db10a717791d0bc0 [^]
2015-07-31 14:35 hgbot Checkin
2015-07-31 14:35 hgbot Note Added: 0079150
2015-07-31 16:05 hgbot Checkin
2015-07-31 16:05 hgbot Note Added: 0079151
2015-07-31 18:12 hgbot Checkin
2015-07-31 18:12 hgbot Note Added: 0079153
2015-08-04 09:28 hgbot Checkin
2015-08-04 09:28 hgbot Note Added: 0079168
2015-08-04 11:13 hgbot Checkin
2015-08-04 11:13 hgbot Note Added: 0079169
2015-08-04 12:33 hgbot Checkin
2015-08-04 12:33 hgbot Note Added: 0079180
2015-08-04 15:37 hgbot Checkin
2015-08-04 15:37 hgbot Note Added: 0079188
2015-08-06 09:54 alostale Relationship added causes 0030505
2015-08-06 09:55 alostale Relationship deleted causes 0030505
2015-08-07 08:45 alostale Note Added: 0079240
2015-08-07 08:45 alostale Status resolved => closed
2015-08-07 08:45 alostale Fixed in Version => 3.0PR15Q4
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079505
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079513
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079514
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079515
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079516
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079517
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079518
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079520
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079524
2016-01-28 12:54 caristu Relationship added related to 0032039
2016-11-14 17:07 caristu Relationship added related to 0034499


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker