Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030132
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-06-09 11:072015-06-15 15:41
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision4b256593c263
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030132: Warehouse and Storage Bins - Storage Bin - Product Transactions tab does not show any record after filtering

DescriptionWarehouse and Storage Bins - Storage Bin - Product Transactions tab does not show any record after filtering. If there are more than 75 records and you enter a filter, it will work. If then, you add a second filter, no records will be shown
Steps To ReproduceAs group admin role:
   Go to Warehouse and Storage Bins window and select España Región Norte
   Go to Storage Bin tab and select Rn-0-0-0
   Go to Product Transactions tab and check there are more than 100 records
   Filter by 'Limonada 0,5L' Product (select it from the drop down list) and check the records have been filtered
   Check there exists at least one record with Movement Type = Vendor Receipts
   Filter by 'Vendor Receipts' Movement Type (select it from the drop down list) and check the following message appears
      "The applied filter resulted in 0 results"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0078228)
hgbot (developer)
2015-06-12 10:50

Repository: erp/devel/pi
Changeset: 4b256593c263fb89e428c57a360fb9478cbae86a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jun 12 10:32:21 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4b256593c263fb89e428c57a360fb9478cbae86a [^]

Fixes issue 30132: Product Transactions tab not showing records after filtering

The problem happened on the client filtering. In this case, the id of the property that references the parent tab is included in the criteria (using the convertCriteria function of the OBViewGrid class).
For those tabs which does not have any property (column) marked as link to parent, the parent property was not being requested to the datasource and when applying the criteria on the local filter the value for the parent property in every record was undefined. That was the reason why the filtering was not returning any record.
Now if the tab does not have any property set as link to parent, we look for the property pointing to the parent tab and include it in the selected properties returned by the datasource.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
---
(0078259)
hudsonbot (developer)
2015-06-12 16:59

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ebf462f93acf [^]
Maturity status: Test
(0078274)
hgbot (developer)
2015-06-15 09:19

Repository: erp/devel/pi
Changeset: b8767fc628fdf66ae34b0b51168249d73cfbad80
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jun 15 09:18:59 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b8767fc628fdf66ae34b0b51168249d73cfbad80 [^]

Related to issue 30132: Updated condition to use the same as OBViewTab

Updated the condition to use the same as OBViewTab in getParentProperty() method, to retrieve the parent property when the parent tab and the child tab use the same table

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewGridComponent.java
---
(0078281)
alostale (developer)
2015-06-15 09:53

code reviewed + tested
(0078298)
hudsonbot (developer)
2015-06-15 15:41

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2203c2fd4e17 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-06-09 11:07 ngarcia New Issue
2015-06-09 11:07 ngarcia Assigned To => platform
2015-06-09 11:07 ngarcia Modules => Core
2015-06-09 11:07 ngarcia Triggers an Emergency Pack => No
2015-06-09 11:08 ngarcia Issue Monitored: networkb
2015-06-10 17:42 alostale Assigned To platform => caristu
2015-06-10 17:42 alostale Status new => acknowledged
2015-06-12 10:49 caristu Review Assigned To => alostale
2015-06-12 10:49 caristu Issue Monitored: alostale
2015-06-12 10:50 hgbot Checkin
2015-06-12 10:50 hgbot Note Added: 0078228
2015-06-12 10:50 hgbot Status acknowledged => resolved
2015-06-12 10:50 hgbot Resolution open => fixed
2015-06-12 10:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4b256593c263fb89e428c57a360fb9478cbae86a [^]
2015-06-12 16:59 hudsonbot Checkin
2015-06-12 16:59 hudsonbot Note Added: 0078259
2015-06-15 09:19 hgbot Checkin
2015-06-15 09:20 hgbot Note Added: 0078274
2015-06-15 09:53 alostale Note Added: 0078281
2015-06-15 09:53 alostale Status resolved => closed
2015-06-15 09:54 alostale Fixed in Version => 3.0PR15Q3
2015-06-15 15:41 hudsonbot Checkin
2015-06-15 15:41 hudsonbot Note Added: 0078298


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker