Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030112
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformtrivialalways2015-06-05 10:442015-06-10 15:42
ReporterairaceburuView Statuspublic 
Assigned ToNaroaIriarte 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision3ee5b64b9eab
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2012-04-02
Regression introduced in release3.0MP12
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/588bdc741142 [^]
Triggers an Emergency PackNo
Summary

0030112: When trying to save a data package with wrong java package the trigger shows a wrong ad_message

DescriptionWhen trying to save a data package with wrong java package the trigger shows a wrong ad_message '@20102@' -> "Saving failed. Cannot delete/change line with generated Invoice".

This happens when the java package of the module is not contained in the java package of the data package.

Also the trigger (ad_package_jp_trg) has a duplicated where condition:

   WHERE M.AD_MODULE_ID = new.AD_MODULE_ID
      AND instr(upper(new.javapackage), upper(M.javapackage)) = 1
      AND instr(upper(new.javapackage), upper(M.javapackage)) = 1;
Steps To ReproduceCreate a module

Create a data package whose java package does not contain the module java package
Proposed SolutionChange the ad_message code

Remove the repeated clause
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0012599 closednaiaramartinez Find and fix all RAISE_APPLICATION_ERROR with first parameter not being -20000 

-  Notes
(0078145)
hgbot (developer)
2015-06-08 12:59

Repository: erp/devel/pi
Changeset: 3ee5b64b9eab7fa476daec24dac96ae0d3636b2b
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Mon Jun 08 12:58:32 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3ee5b64b9eab7fa476daec24dac96ae0d3636b2b [^]

Fixed issue 30112: The message shown trying to save a datapackage isn't correct

The problem was that the message associated to the label "20102" was not correct in this case.
To fix this, a new message has been added to AD_MESSAGE, and now, the message
'The java package of the Data Package must be within the java package of its module.' is
shown when the java package of the module is not contained in the java package of the data
package.
Also, the duplicated where clause has been removed from the trigger.

This fix has been tested with postgres and also with oracle.

---
M src-db/database/model/triggers/AD_PACKAGE_JP_TRG.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0078149)
hudsonbot (developer)
2015-06-08 22:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/eea55936e896 [^]
Maturity status: Test
(0078182)
alostale (developer)
2015-06-10 15:42

code reviewed + tested

- Issue History
Date Modified Username Field Change
2015-06-05 10:44 airaceburu New Issue
2015-06-05 10:44 airaceburu Assigned To => platform
2015-06-05 10:44 airaceburu Modules => Core
2015-06-05 10:44 airaceburu Regression level => Production - Confirmed Stable
2015-06-05 10:44 airaceburu Regression date => 2012-04-02
2015-06-05 10:44 airaceburu Regression introduced in release => 3.0MP12
2015-06-05 10:44 airaceburu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/588bdc741142 [^]
2015-06-05 10:44 airaceburu Triggers an Emergency Pack => No
2015-06-05 10:45 airaceburu Relationship added caused by 0012599
2015-06-05 12:00 alostale Status new => scheduled
2015-06-05 12:00 alostale Assigned To platform => NaroaIriarte
2015-06-05 12:00 alostale Priority normal => immediate
2015-06-08 12:59 hgbot Checkin
2015-06-08 12:59 hgbot Note Added: 0078145
2015-06-08 12:59 hgbot Status scheduled => resolved
2015-06-08 12:59 hgbot Resolution open => fixed
2015-06-08 12:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3ee5b64b9eab7fa476daec24dac96ae0d3636b2b [^]
2015-06-08 13:01 NaroaIriarte Issue Monitored: alostale
2015-06-08 13:02 NaroaIriarte Review Assigned To => alostale
2015-06-08 22:24 hudsonbot Checkin
2015-06-08 22:24 hudsonbot Note Added: 0078149
2015-06-10 15:42 alostale Note Added: 0078182
2015-06-10 15:42 alostale Status resolved => closed
2015-06-10 15:42 alostale Fixed in Version => 3.0PR15Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker