Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030095
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-06-04 13:592015-06-18 18:32
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionno change requiredFixed in Version
StatusclosedFix in branchFixed in SCM revision195dff675189
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2015-05-28
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/aed0c66779e9442c6c92010951125f28179c0e1e [^]
Triggers an Emergency PackNo
Summary

0030095: BP current balance not properly updated when generating credit from Payment In/Out

DescriptionBusiness Partner current balance not properly updated when generating credit from Payment In/Out
Steps To ReproduceAs F&B Admin:

- Go to Client window.
  Move to Dimensions tab.
  Set "Show in Header" = Y for "AR Receipt" document, "Bus.Partner" dimension

- Login/Logout

- Go to Business Partner window and check current balance amount.

- Create a Payment In from "Alimentos y Supermercados" and amount = 20.
  Click on Add Details.
  Uncheck any record in Order/Invoice grid.
  Select "Process Received Payment(s) and Deposit" and "Leave the credit to be used later".
  Click on Done.

- Go to Business Partner window and realize the current balance amount has not been updated.

- The same happens if the flow is done from Payment Out.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00300983.0PR15Q2.2 closedaferraz BP current balance not properly updated when generating credit from Payment In 
depends on backport 00300993.0PR15Q1.5 closedaferraz BP current balance not properly updated when generating credit from Payment In 
caused by defect 0030007 closedaferraz Payment schedule amount incorrectly calculated when adding a payment from reconcile window to a sales order 
related to defect 00301663.0PR15Q3 closedaferraz Wrong order payment plan with isinvoicepaid feature 
blocks defect 00300773.0PR15Q4 closedaferraz Customer Balance not working properly with multicurrency credit 

-  Notes
(0078095)
aferraz (developer)
2015-06-04 17:58
edited on: 2015-06-04 18:18

Test plan:

As F&B Admin:

- Go to Client window.
  Move to Dimensions tab.
  Set "Show in Header" = Y for "AR Receipt" document, "Bus.Partner" dimension

- Login/Logout

- Go to Business Partner window and check current balance amount.

- Create a Payment In from "Alimentos y Supermercados" and amount = 20.
  Click on Add Details.
  Uncheck any record in Order/Invoice grid.
  Select "Process Received Payment(s) and Deposit" and "Leave the credit to be used later".
  Click on Done.

- Go to Business Partner window and realize the current balance amount has been properly updated.

- Create another Payment In from "Alimentos y Supermercados" and amount = 0.
  Click on Add Details.
  Select previous created credit in Credit To Use grid.
  Uncheck any record in Order/Invoice grid.
  Select "Process Received Payment(s) and Deposit" and "Refund amount to customer".
  Click on Done.

- Go to Business Partner window and realize the current balance amount has been properly updated.

- Repeat the same flow for Payment Out window.

(0078154)
hgbot (developer)
2015-06-09 13:10

Repository: erp/devel/pi
Changeset: 195dff67518973e72ac3a2bcbd255d132a9959f3
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Jun 04 17:47:14 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/195dff67518973e72ac3a2bcbd255d132a9959f3 [^]

Fixes issue 30095: BP current balance not properly updated

Change condition in FIN_PaymentProcess to take into account when the paymend does not have order nor invoice related (when it only has a g/l item, when we are genereting credit or when we are refunding amount).

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
---
(0078157)
vmromanos (developer)
2015-06-09 13:12

Code review + testing OK
(0078176)
hudsonbot (developer)
2015-06-10 15:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ec9a491fe07d [^]
Maturity status: Test
(0078365)
hgbot (developer)
2015-06-18 12:21

Repository: erp/devel/pi
Changeset: d5704e432670782dbc0bfd157e37f1a426bdd3af
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Jun 17 13:49:30 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d5704e432670782dbc0bfd157e37f1a426bdd3af [^]

Related to issue 30095: Backout changeset 195dff675189

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
---
(0078367)
aferraz (developer)
2015-06-18 12:25

Backout done and issue rejected as is not longer reproducible since this other backout: https://code.openbravo.com/erp/devel/pi/rev/56e313660729ba9148ad01703190a43a604ae231 [^]
(0078381)
hudsonbot (developer)
2015-06-18 18:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/42df4e2c6b02 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-06-04 13:59 aferraz New Issue
2015-06-04 13:59 aferraz Assigned To => aferraz
2015-06-04 13:59 aferraz Modules => Core
2015-06-04 13:59 aferraz Regression level => Packaging and release
2015-06-04 13:59 aferraz Regression date => 2015-05-28
2015-06-04 13:59 aferraz Regression introduced in release => main
2015-06-04 13:59 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/aed0c66779e9442c6c92010951125f28179c0e1e [^]
2015-06-04 13:59 aferraz Triggers an Emergency Pack => No
2015-06-04 14:00 aferraz Relationship added caused by 0030007
2015-06-04 14:14 aferraz Relationship added blocks 0030077
2015-06-04 16:39 aferraz Status new => scheduled
2015-06-04 17:26 aferraz Severity critical => major
2015-06-04 17:58 aferraz Note Added: 0078095
2015-06-04 18:18 aferraz Note Edited: 0078095 View Revisions
2015-06-04 18:40 aferraz Summary BP current balance not properly updated when generating credit from Payment In => BP current balance not properly updated when generating credit from Payment In/Out
2015-06-04 18:40 aferraz Description Updated View Revisions
2015-06-04 18:40 aferraz Steps to Reproduce Updated View Revisions
2015-06-09 13:10 hgbot Checkin
2015-06-09 13:10 hgbot Note Added: 0078154
2015-06-09 13:10 hgbot Status scheduled => resolved
2015-06-09 13:10 hgbot Resolution open => fixed
2015-06-09 13:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/195dff67518973e72ac3a2bcbd255d132a9959f3 [^]
2015-06-09 13:12 vmromanos Review Assigned To => vmromanos
2015-06-09 13:12 vmromanos Note Added: 0078157
2015-06-09 13:12 vmromanos Status resolved => closed
2015-06-10 15:15 hudsonbot Checkin
2015-06-10 15:15 hudsonbot Note Added: 0078176
2015-06-17 14:42 aferraz Status closed => new
2015-06-17 14:42 aferraz Resolution fixed => open
2015-06-17 14:47 aferraz Relationship added related to 0030166
2015-06-18 12:21 hgbot Checkin
2015-06-18 12:21 hgbot Note Added: 0078365
2015-06-18 12:25 aferraz Review Assigned To vmromanos => aferraz
2015-06-18 12:25 aferraz Note Added: 0078367
2015-06-18 12:25 aferraz Status new => closed
2015-06-18 12:25 aferraz Resolution open => no change required
2015-06-18 18:32 hudsonbot Checkin
2015-06-18 18:32 hudsonbot Note Added: 0078381


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker