Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030060
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-06-01 13:172015-06-18 18:32
ReporterpsanjuanView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionee157fef9c33
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-04-14
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/402d7bca3f774737bf194cb7cbe41d2454a69326 [^]
Triggers an Emergency PackNo
Summary

0030060: Select Payments Pick&Edit window is not working properly

DescriptionSelect Payments Pick&Edit window is not working properly as once a payment in USD is selected the currency of that payment changes to EUR and rest of USD currency payments change USD currency to 100 (Currency ID)

In any case once any payment is selected, USD currency payments change USD currency to 100 (Currency ID)
Steps To ReproduceInstall Remittance module attached and apply Remittance dataset to F&B España in the enterprise module management window.

Navigate to payment method window and create a new one with below setup:
Name "Payment Out Remittance Multicurrency"
Payment Out Allowed = Yes
Make Payments in multiple currencies = Yes
Execution type = Automatic
Execution Process = In remittance
Deferred=Yes

Go to Remittance type window and create a new one with below setup:
Name = Payment Out Remittance Multicurrency
Payment method = Payment Out Remittance Multicurrency
Posting allowed = Yes

Go to Financial Account window and search by "Cuenta de Banco", go to Payment Method tab and select there "Payment Out Remittance Multicurrency" payment method.

Go to price list and create a new one (purchase) in USD.
Price List version valid from 01-01-2014, price List schema = Esquema de tarificación.

Go to "Product Price" tab and select a product (i.e. Agua sin Gas 1L), and enter 100.00 as unit price/list price

Go to BP window and create a new vendor/supplier named i.e Vendor USA. Go to Vendor/Creditor tab and enter below setup:
Purchase price List: Purchase price list in USD
PO Payment Method: Payment Out Remittance Multicurrency
PO Payment Terms: Treinta días
PO Financial Account = Cuenta de Banco

Go to Location tab and enter United States country address.

Navigate to Purchase Invoice window.
Create a new record for F&B España with below setup:
Business Partner: Vendor USA 2
Invoice Date = Accounting Date = 21-05-2015
 Go to lines and create one line with below setup:
Agua sin Gas 1L, 150 units.
Complete and Post the invoice. (Purchase Invoice 100000654)
Total Gross Amount = 15000.00 USD

Navigate to Purchase Invoice window.
Select purchase invoice 1000000654
Click on Add Payment button and enter below data:
Payment Date = 30-06-2015
Edit 20-07-2015 expected date line, and change Amount field to 1000.00, therefore Actual Payment field changes to 10000.00 USD
Select Process Made Payment option in ""Action Regarding Document"" field
Press Done. Created Payment 1000356

Navigate to Remittance window
Create a new one by entering below data:
Remittance Type = Payment Out Remittance Multicurrency
Transaction date = Expected date = 30/06/2015
Name = Payment Out Remittance 1 Multicurrency
Save
Click on Select Payments button. Remove by default filter in the ""Select Payments"" window

Select any payment there and realize that USD payments currency column changes to "100".

See image attached.
TagsNo tags attached.
Attached Filespng file icon issue_30060.png [^] (76,978 bytes) 2015-06-01 13:19


? file icon org.openbravo.module.remittance-3.2.25.obx [^] (327,474 bytes) 2015-06-01 13:20
diff file icon 30060.diff [^] (1,173 bytes) 2015-06-03 13:22 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029940 closedalostale Selector Reference field changes to Id in editable P&E when adding new rows 
related to defect 0029381 closedplatform Wrong value returned by the FIC in Manage Reservation P&E 
depends on backport 00300903.0PR15Q2.2 closedcaristu Select Payments Pick&Edit window is not working properly 
depends on backport 00300913.0PR15Q1.5 closedcaristu Select Payments Pick&Edit window is not working properly 
caused by feature request 00262673.0PR14Q3 closedshankarb Re-implement combos (table and tableDir) to use datasources 
related to defect 00301893.0PR15Q3 closedcaristu Values are overwritten under some circumstances in Modify Payment Plan 

-  Notes
(0077943)
psanjuan (manager)
2015-06-01 13:27

We have verified that this problem is not shown in PR14Q3.4
(0078018)
alostale (developer)
2015-06-03 13:22

attached possible solution
(0078165)
hgbot (developer)
2015-06-09 18:15

Repository: erp/devel/pi
Changeset: ee157fef9c33de60041b07dca8c11dbe1bf2eb96
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jun 09 18:14:54 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ee157fef9c33de60041b07dca8c11dbe1bf2eb96 [^]

Fixes issue 30060: Select Payments Pick&Edit window is not working properly

When selecting a record in a P&E grid, the request done to the FIC was not using the correct mode. Now, when selecting a record, the request is properly done using the EDIT mode.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0078178)
hudsonbot (developer)
2015-06-10 15:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ec9a491fe07d [^]
Maturity status: Test
(0078286)
alostale (developer)
2015-06-15 10:17

Reopening.

While testing related issue 0029940 found:
1. Modify Payment plan
2. Add row -> OK
3. Add new row -> Payment method in previous row is set as blank

Note this only occurs if step 3 is done without editing line created in step 2.
(0078297)
hgbot (developer)
2015-06-15 14:04

Repository: erp/devel/pi
Changeset: a830aa4122da68e0e1a4f8f3febf3bda23641d38
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jun 15 14:02:42 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a830aa4122da68e0e1a4f8f3febf3bda23641d38 [^]

Related to issue 30060: displayed value should be set in fk fields

When the default value of a foreign key field in a new record does not exist already in the grid data, the display value can not be recovered in the setEditValue() method.
In order to ensure the display value is updated to reflect the new edit-value for this field, the display value is now explicitly set.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0078301)
hgbot (developer)
2015-06-15 18:47

Repository: erp/devel/pi
Changeset: 7e18f8ff4719dc46813c2882a4965caf156429a5
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jun 15 18:46:44 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7e18f8ff4719dc46813c2882a4965caf156429a5 [^]

Related to issue 30060: removed already existing condition

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0078311)
hudsonbot (developer)
2015-06-16 00:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/fa5bbdf39822 [^]
Maturity status: Test
(0078321)
hgbot (developer)
2015-06-16 17:26

Repository: erp/devel/pi
Changeset: 64044c3a9e2fa201e927f31c00c9c7237633de44
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jun 16 17:25:19 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/64044c3a9e2fa201e927f31c00c9c7237633de44 [^]

Related to issue 30060: send null ROW_ID when selecting a record in P&E

Send null ROW_ID to avoid the edit values be overriden by the FIC response

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0078331)
hudsonbot (developer)
2015-06-16 20:00

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4d0d9dff6c15 [^]
Maturity status: Test
(0078359)
alostale (developer)
2015-06-18 08:45

code reviewed

tested steps explained in this issue and also related ones
(0078376)
hudsonbot (developer)
2015-06-18 18:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/42df4e2c6b02 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-06-01 13:17 psanjuan New Issue
2015-06-01 13:17 psanjuan Assigned To => platform
2015-06-01 13:17 psanjuan Modules => Core
2015-06-01 13:17 psanjuan Triggers an Emergency Pack => No
2015-06-01 13:19 psanjuan File Added: issue_30060.png
2015-06-01 13:20 psanjuan File Added: org.openbravo.module.remittance-3.2.25.obx
2015-06-01 13:22 psanjuan Regression level => Pre packaging ( pi )
2015-06-01 13:24 psanjuan Description Updated View Revisions
2015-06-01 13:27 psanjuan Note Added: 0077943
2015-06-03 09:45 alostale Relationship added related to 0029940
2015-06-03 10:36 alostale Relationship added related to 0029381
2015-06-03 13:12 alostale Assigned To platform => caristu
2015-06-03 13:12 alostale Status new => acknowledged
2015-06-03 13:22 alostale File Added: 30060.diff
2015-06-03 13:22 alostale Note Added: 0078018
2015-06-04 09:25 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/402d7bca3f774737bf194cb7cbe41d2454a69326 [^]
2015-06-04 12:50 caristu Regression date => 2014-04-14
2015-06-04 12:50 caristu Regression introduced in release => 3.0PR14Q3
2015-06-04 12:51 caristu Regression level Pre packaging ( pi ) => Production - Confirmed Stable
2015-06-04 13:06 caristu Status acknowledged => scheduled
2015-06-04 13:27 alostale Severity major => minor
2015-06-09 18:15 hgbot Checkin
2015-06-09 18:15 hgbot Note Added: 0078165
2015-06-09 18:15 hgbot Status scheduled => resolved
2015-06-09 18:15 hgbot Resolution open => fixed
2015-06-09 18:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ee157fef9c33de60041b07dca8c11dbe1bf2eb96 [^]
2015-06-09 18:17 caristu Review Assigned To => alostale
2015-06-09 18:18 caristu Issue Monitored: alostale
2015-06-10 09:28 dmitry_mezentsev Relationship added caused by 0026267
2015-06-10 15:15 hudsonbot Checkin
2015-06-10 15:15 hudsonbot Note Added: 0078178
2015-06-15 10:17 alostale Note Added: 0078286
2015-06-15 10:17 alostale Status resolved => new
2015-06-15 10:17 alostale Resolution fixed => open
2015-06-15 14:04 hgbot Checkin
2015-06-15 14:04 hgbot Note Added: 0078297
2015-06-15 18:47 hgbot Checkin
2015-06-15 18:47 hgbot Note Added: 0078301
2015-06-16 00:37 hudsonbot Checkin
2015-06-16 00:37 hudsonbot Note Added: 0078311
2015-06-16 13:15 caristu Relationship added related to 0030189
2015-06-16 17:22 caristu Status new => scheduled
2015-06-16 17:26 hgbot Checkin
2015-06-16 17:26 hgbot Note Added: 0078321
2015-06-16 17:27 caristu Status scheduled => resolved
2015-06-16 17:27 caristu Resolution open => fixed
2015-06-16 17:39 hgbot Checkin
2015-06-16 17:39 hgbot Note Added: 0078322
2015-06-16 17:43 caristu Note Deleted: 0078322
2015-06-16 20:00 hudsonbot Checkin
2015-06-16 20:00 hudsonbot Note Added: 0078331
2015-06-18 08:45 alostale Note Added: 0078359
2015-06-18 08:45 alostale Status resolved => closed
2015-06-18 08:45 alostale Fixed in Version => 3.0PR15Q3
2015-06-18 18:32 hudsonbot Checkin
2015-06-18 18:32 hudsonbot Note Added: 0078376


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker