Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029978
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-05-22 12:072015-08-20 23:15
ReporterjecharriView Statuspublic 
Assigned ToNaroaIriarte 
PriorityhighResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revisionf6dcfa9328cf
ProjectionnoneETAnoneTarget Version3.0PR15Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029978: Not possible to use tree reference selector in a pick and execute window grid

DescriptionNot possible to use tree reference selectors in a pick and execute window grid. The problem is that that kind of selectors were not created to work in a pick list window.
Steps To Reproduce-Define a reference which type is "Tree Reference" and "Ad_org" table as tree reference
-Go to "windows, tabs and fields"
-Select window "Create Purchase Order Lines"
-Go to tab "Lines" and finally select "Organization field"
-Do it visible and change the reference of the column for previously created "Tree reference"

After that, in the ERP as admin:
-Go to purchase order window
-Create a header
-Press in "Create lines button"
-You should see the pick and edit with previously changed reference
TagsNo tags attached.
Attached Filesdiff file icon issue29978.diff [^] (3,888 bytes) 2015-06-24 16:46 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0030323 acknowledgedplatform Openbravo ERP tree reference cannot be used in as parameter in process definition 
related to feature request 0029949 closedjecharri Retail Modules Add the possibility to define a list with cross channel warehouses 
related to defect 0030812 closedNaroaIriarte Openbravo ERP Multiple filtering not allowed using tree reference selector in a pick and execute window grid. 

-  Notes
(0078642)
hgbot (developer)
2015-07-03 17:46

Repository: erp/devel/pi
Changeset: f6dcfa9328cfc74f837a32c7a227ce049bdcff97
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed Jun 24 16:56:47 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f6dcfa9328cfc74f837a32c7a227ce049bdcff97 [^]

Fixed issue 29978: Enable tree reference selectors in Pick & Exectute windows.

It was not possible to use tree reference selectors in the pick & execute windows.

To enable this the "ob-formitem-tree-filter.js" has been changed.
Before, there was a function which copied the functions from the view grid, the problem was that this
doesn't exist for the Pick and Execute windows.

Now, it takes into account the pick and execute windows, this has been done by a
condition which checks if "paramWindow" is true, which means that is a pick and execute window.

A new function has been developed too, for granting the correct behavior of this new functionality.
This function, copies some functions from the grid of the pick and execute windows.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-tree-filter.js
---
(0078688)
alostale (developer)
2015-07-07 08:58

Code reviewed.

Tested: working fine having a tree reference within a grid for a parameter window, but it is still not possible to use tree reference as a parameter in a process definition window, reported as a design defect 0030323.
(0079454)
hudsonbot (developer)
2015-08-20 23:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-05-22 12:07 jecharri New Issue
2015-05-22 12:07 jecharri Assigned To => platform
2015-05-22 12:07 jecharri Web browser => Google Chrome
2015-05-22 12:07 jecharri Modules => Core
2015-05-22 12:07 jecharri Triggers an Emergency Pack => No
2015-05-22 12:11 jecharri Web browser Google Chrome => Google Chrome
2015-05-22 12:11 jecharri Summary Not possible to use tree reference selectors in a pick list window => Not possible to use tree reference selectors in a pick and execute window
2015-05-22 12:11 jecharri Description Updated View Revisions
2015-06-18 07:50 alostale Status new => scheduled
2015-06-18 07:50 alostale Assigned To platform => NaroaIriarte
2015-06-18 07:54 alostale Web browser Google Chrome => Google Chrome
2015-06-18 07:54 alostale Target Version => 3.0PR15Q4
2015-06-22 13:04 jecharri Web browser Google Chrome => Google Chrome
2015-06-22 13:04 jecharri Steps to Reproduce Updated View Revisions
2015-06-22 13:05 jecharri Web browser Google Chrome => Google Chrome
2015-06-22 13:05 jecharri Steps to Reproduce Updated View Revisions
2015-06-24 10:14 NaroaIriarte Issue Monitored: alostale
2015-06-24 10:15 NaroaIriarte Review Assigned To => alostale
2015-06-24 10:15 NaroaIriarte Web browser Google Chrome => Google Chrome
2015-06-24 16:46 NaroaIriarte File Added: issue29978.diff
2015-06-24 18:22 jecharri Note Added: 0078495
2015-06-24 18:34 jecharri Note Deleted: 0078495
2015-06-25 16:29 jecharri Relationship added related to 0029949
2015-07-03 17:46 hgbot Checkin
2015-07-03 17:46 hgbot Note Added: 0078642
2015-07-03 17:46 hgbot Status scheduled => resolved
2015-07-03 17:46 hgbot Resolution open => fixed
2015-07-03 17:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f6dcfa9328cfc74f837a32c7a227ce049bdcff97 [^]
2015-07-07 08:47 alostale Web browser Google Chrome => Google Chrome
2015-07-07 08:47 alostale Summary Not possible to use tree reference selectors in a pick and execute window => Not possible to use tree reference selector in a pick and execute window grid
2015-07-07 08:47 alostale Description Updated View Revisions
2015-07-07 08:54 alostale Relationship added related to 0030323
2015-07-07 08:58 alostale Note Added: 0078688
2015-07-07 08:58 alostale Status resolved => closed
2015-07-07 08:58 alostale Fixed in Version => 3.0PR15Q4
2015-08-20 23:15 hudsonbot Checkin
2015-08-20 23:15 hudsonbot Note Added: 0079454
2015-09-11 10:31 umartirena Relationship added related to 0030812


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker