Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029888
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 04. Warehouse managementmajoralways2015-05-13 12:042015-05-18 11:08
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q1.4
StatusclosedFix in branchFixed in SCM revision29047546bcdb
ProjectionnoneETAnoneTarget Version3.0PR15Q1.4
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029888: [Cost Adjutments] - Error in Price Correction Background if Costing Background has not been executed

Description[Cost Adjutments] - Error in Price Correction Background if Costing Background has not been executed
Steps To ReproduceAs QA Testing Admin:

- Create a Product with name Test for Spain organization
Add a Purchase price list version with 100 unit/list price

- Create a Purchase Order with Test product and quantity 5. Book it.

- Create a Purchase Invoice, creating lines from the created order. Change the unit price to 105. Complete it.

- Create a Goods Receipt, creating lines from the created invoice. Complete it.

- Go to Process Request window and run Price Correction Background process. Realize in Process Monitor, the status of the process is Error.

The problem is that if Costing Background process has not been executed, the transaction does not have the cost calculated, and when executing the Price Correction Background a null pointer exception will be raised.
Proposed SolutionAdd in processPriceDifference method in PriceDifferenceProcess class, a restriction to ensure the transactions have the cost calculated.
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00298613.0PR15Q3 closedaferraz [Cost Adjutments] - Error in Price Correction Background if Costing Background has not been executed 

-  Notes
(0077516)
hgbot (developer)
2015-05-18 11:07

Repository: erp/backports/3.0PR15Q1.4
Changeset: 29047546bcdb7ffac2de510a4dfbdd47308fbe8d
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu May 14 17:23:03 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q1.4/rev/29047546bcdb7ffac2de510a4dfbdd47308fbe8d [^]

Fixes issue 29890 & Fixes issue 29888: Error in Price Correction Background

IsCostCalculated will not be considered to set CheckPriceDifference flag, when completing an invoice.
Instead, when running Price Correction Background, transactions will be filtered by IsCostCalculated to avoid calculate price differences in transactions where cost has not been calculated.

---
M src-db/database/model/functions/C_INVOICE_POST.xml
M src/org/openbravo/costing/PriceDifferenceProcess.java
---
(0077518)
umartirena (developer)
2015-05-18 11:08

Code Review + Testing OK

- Issue History
Date Modified Username Field Change
2015-05-14 16:56 aferraz Type defect => backport
2015-05-14 16:56 aferraz Target Version 3.0PR15Q3 => 3.0PR15Q1.4
2015-05-15 13:21 dmitry_mezentsev Tag Attached: Approved
2015-05-18 08:52 aferraz Summary [Cost Adjutments] - Error in Price Correction Background if Consting Background has not been executed => [Cost Adjutments] - Error in Price Correction Background if Costing Background has not been executed
2015-05-18 08:52 aferraz Description Updated View Revisions
2015-05-18 11:07 hgbot Checkin
2015-05-18 11:07 hgbot Note Added: 0077516
2015-05-18 11:07 hgbot Status scheduled => resolved
2015-05-18 11:07 hgbot Resolution open => fixed
2015-05-18 11:07 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/14775af5b6a0ac9017cb674f11c04a873c4dec07 [^] => http://code.openbravo.com/erp/backports/3.0PR15Q1.4/rev/29047546bcdb7ffac2de510a4dfbdd47308fbe8d [^]
2015-05-18 11:08 umartirena Review Assigned To => umartirena
2015-05-18 11:08 umartirena Note Added: 0077518
2015-05-18 11:08 umartirena Status resolved => closed
2015-05-18 11:08 umartirena Fixed in Version => 3.0PR15Q1.4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker