Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029876
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementmajoralways2015-03-12 13:242015-05-14 10:49
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q1.4
StatusclosedFix in branchFixed in SCM revisionef112441fbf6
ProjectionnoneETAnoneTarget Version3.0PR15Q1.4
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029876: It's not possible to post a Simple G/L Journal setted as multi-general ledger

DescriptionIt's not possible to post a Simple G/L Journal record setted as multi-general ledger
Steps To ReproduceCreate a Simple G/L Journal record:
 Organization: F&B EspaƱa, S.A
 General Ledger: empty
 Multi-General Ledger: true

Create a line:
 GL Item: Capital social
 Debit: 100

Create another line:
 GL Item: Capital social
 Credit: 100

Complete it. Post it. "Account could not be found" error is shown.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0029257 closedaferraz It's not possible to post a Simple G/L Journal setted as multi-general ledger 

-  Notes
(0077427)
hgbot (developer)
2015-05-14 10:45

Repository: erp/backports/3.0PR15Q1.4
Changeset: ef112441fbf64e545decc895768f24d9986933f7
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Mar 17 11:56:11 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q1.4/rev/ef112441fbf64e545decc895768f24d9986933f7 [^]

Fixes issue 29876: Avoid error when posting a multi-general ledger G/L Journal

General Ledger will be taken from G/L Item instead from Simple G/L Journal when it is marked as multi-general ledger, because in this case General Ledger from Simple G/L Journal will be empty

---
M src/org/openbravo/erpCommon/ad_forms/DocGLJournal_data.xsql
---
(0077428)
umartirena (developer)
2015-05-14 10:49

Code Review + Testing OK

- Issue History
Date Modified Username Field Change
2015-05-13 17:53 aferraz Type defect => backport
2015-05-13 17:53 aferraz Target Version => 3.0PR15Q1.4
2015-05-14 10:45 hgbot Checkin
2015-05-14 10:45 hgbot Note Added: 0077427
2015-05-14 10:45 hgbot Status scheduled => resolved
2015-05-14 10:45 hgbot Resolution open => fixed
2015-05-14 10:45 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/b9ec4f6b4ca3fa2870e774f75d4ee7df372e8ee6 [^] => http://code.openbravo.com/erp/backports/3.0PR15Q1.4/rev/ef112441fbf64e545decc895768f24d9986933f7 [^]
2015-05-14 10:49 umartirena Note Added: 0077428
2015-05-14 10:49 umartirena Status resolved => closed
2015-05-14 10:49 umartirena Fixed in Version => 3.0PR15Q1.4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker