Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029849
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2015-05-12 12:052015-05-21 09:19
ReporteregoitzView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisiond142537185dc
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029849: Not possible to overwrite the result of a callout from your own callout using a requestdispatcher an a decorator

Description-Not possible to overwrite the result of a callout from your own callout using a requestdispatcher an a decorator.
Steps To Reproduce-Using the attachemed modules change the partner of a sales order.
TagsNo tags attached.
Attached Filesgz file icon callout.tar.gz [^] (19,056 bytes) 2015-05-12 12:05

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0027244 closedalostale Tomcat 7 is not supported 
related to design defect 0032189 closedinigosanchez Make the callouts extensible 
related to defect 0036192 closedplatform Not possible to overwrite the result of a callout from your own callout using a requestdispatcher an a decorator in Tomcat 7 

-  Notes
(0077381)
hgbot (developer)
2015-05-13 13:52

Repository: erp/devel/pi
Changeset: d142537185dc7a9164b96d860f4529c027dc6afa
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed May 13 13:50:58 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d142537185dc7a9164b96d860f4529c027dc6afa [^]

fixed bug 29849: RequestDispatcher.include deletes context from current thread

  This code:

     RequestDispatcher dispatcher = request.getRequestDispatcher(url);
     dispatcher.include(wrappedRequest, response)

  deletes context OBContext and RequestContext.

  The problem is caused because the way Tomcat internally manages it. By definition
  RequestDispatcher.include should not execute the Request filters (only the include
  ones) but they were executed causing this issue. They were executed because
  of the manner the special attribute to get the dispatch type is obtained, as
  the wrappedRequest now extends javax.servlet.http.HttpServletRequestWrapper it
  is managed differently than before when this was not the case, now type was always
  "Request" even when it should be "Include".

  The fix consists on managing getAttribute from request differently when they are
  special Tomcat internal attributes getting them from the request instead of from
  the delegate.

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/RequestContext.java
---
(0077456)
hudsonbot (developer)
2015-05-14 17:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3375171dd310 [^]
Maturity status: Test
(0077608)
AugustoMauch (developer)
2015-05-21 09:19

Code reviewed and verified in pi@d142537185dc

- Issue History
Date Modified Username Field Change
2015-05-12 12:05 egoitz New Issue
2015-05-12 12:05 egoitz Assigned To => platform
2015-05-12 12:05 egoitz File Added: callout.tar.gz
2015-05-12 12:05 egoitz Modules => Core
2015-05-12 12:05 egoitz Triggers an Emergency Pack => No
2015-05-13 08:25 alostale Relationship added related to 0027244
2015-05-13 13:40 alostale Assigned To platform => alostale
2015-05-13 13:51 alostale Review Assigned To => AugustoMauch
2015-05-13 13:52 hgbot Checkin
2015-05-13 13:52 hgbot Note Added: 0077381
2015-05-13 13:52 hgbot Status new => resolved
2015-05-13 13:52 hgbot Resolution open => fixed
2015-05-13 13:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d142537185dc7a9164b96d860f4529c027dc6afa [^]
2015-05-14 17:48 hudsonbot Checkin
2015-05-14 17:48 hudsonbot Note Added: 0077456
2015-05-21 09:19 AugustoMauch Note Added: 0077608
2015-05-21 09:19 AugustoMauch Status resolved => closed
2015-05-21 09:19 AugustoMauch Fixed in Version => 3.0PR15Q3
2016-02-26 14:15 alostale Relationship added related to 0032189
2017-06-07 13:59 maite Relationship added related to 0036192


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker