Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029838
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajorhave not tried2015-05-11 09:312015-05-15 11:25
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2.1
StatusclosedFix in branchFixed in SCM revisionf1124f44f626
ProjectionnoneETAnoneTarget Version3.0PR15Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-11-19
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/3221fd5a8661d7f9dfbfd6d4255bace9834e6535 [^]
Triggers an Emergency PackNo
Summary

0029838: Unlimited grid datasource request under certain circumstances

DescriptionIf the user scrolls down a grid till reaching the second page, and then performs a filter that returns less than a page, the filtered records will be shown but an unlimited amoutn of grid requests will be done until the user closes the window.
Steps To Reproduce- Open the Country and Region window
- Scroll down until you see Iraq
- Open the browser developer tools and select the Network tab
- Enter Q in the name filter editor
- The names that contain Q will be displayed, but the grid will show empty lines for more rows. Also, unlimited requests to the Country datasource will be done, you can check it in the developer tools
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0029835 closedAugustoMauch Unlimited grid datasource request under certain circumstances 

-  Notes
(0077360)
hgbot (developer)
2015-05-12 22:34

Repository: erp/backports/3.0PR15Q2.1
Changeset: f1124f44f6260ed08f8b07b26fe839ddd3a5a274
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon May 11 10:53:02 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.1/rev/f1124f44f6260ed08f8b07b26fe839ddd3a5a274 [^]

Fixes bug 29838: Prevents unlimited datasource requests when filtering the grid

The problem was that the logic to check that if a datasource request was triggered by scrolling up in a grid that did not have its initial rows loaded (see [1]) did not work well when the user filtered the grid after having scrolled down the grid till loading its second page. This caused the totalRows property of the grid to be miscalculated, and this triggered the undefinite amount of datasource requests.

The logic to check if the request was triggered by scrolling up has been changed. Now, instead of checking low-level smartclient properties like lastScrollTop, we check if there are rows loaded in the positions just after the page that was just received. Only in that case we want to prevent resetting the totalRows property of the ResultSet with the value returned by the datasource.

[1] https://code.openbravo.com/erp/devel/pi/rev/c51dce7e9fd3c47915464ab4f565a9d1cee60e3b [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0077484)
alostale (developer)
2015-05-15 11:25

code reviewed + tested

- Issue History
Date Modified Username Field Change
2015-05-11 10:19 AugustoMauch Type defect => backport
2015-05-11 10:19 AugustoMauch Target Version => 3.0PR15Q2.1
2015-05-11 11:27 dmitry_mezentsev Tag Attached: Approved
2015-05-12 22:33 AugustoMauch Issue Monitored: alostale
2015-05-12 22:33 AugustoMauch Review Assigned To => alostale
2015-05-12 22:34 hgbot Checkin
2015-05-12 22:34 hgbot Note Added: 0077360
2015-05-12 22:34 hgbot Status scheduled => resolved
2015-05-12 22:34 hgbot Resolution open => fixed
2015-05-12 22:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.1/rev/f1124f44f6260ed08f8b07b26fe839ddd3a5a274 [^]
2015-05-13 17:28 alostale Assigned To platform => AugustoMauch
2015-05-15 11:25 alostale Note Added: 0077484
2015-05-15 11:25 alostale Status resolved => closed
2015-05-15 11:25 alostale Fixed in Version => 3.0PR15Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker