Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029836
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 04. Warehouse managementmajoralways2015-05-08 09:422015-05-11 13:28
ReporterumartirenaView Statuspublic 
Assigned Toumartirena 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q2.1
StatusclosedFix in branchFixed in SCM revisiona76de5445a7f
ProjectionnoneETAnoneTarget Version3.0PR15Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029836: [Cost Adjustments] Unnecessary backdated adjustments are created under certain circumstances

Description[Cost Adjustments] Unnecessary backdated adjustments are created under certain circumstances
Steps To ReproduceIn live builds as System Admin:

 * Go to Currency window:
 * Search EUR currency and set Costing Precision to 4.

In live builds as QA Testing Admin:

 * It is necessary to have a validated costing rule:
   - Starting Date: Before than today
   - Costing Algorithm: Average Algorithm
   - Fix Backdated: Yes
   - Warehouse dimension: Yes

 * Create a product for Spain org

 * Assign Net Price and List Price of 12.45

 * Add a manual Costing record
   - Starting Date: Today
   - Ending Date: 31-12-9999
   - Cost Type: Average
   - Cost: 12.45
   - Warehouse: Spain Warehouse
   - Currency: EUR

 * Create a Goods movement header with movement date tomorrow.
 
 * Add a line for the created product of 15.25 from a Storage Bin of Spain Warehouse to a storage bin of a different warehouse. If there is no different warehouse, create it

 * Process the Goods Movement.

 * Go to Goods receipt window and create a header with movement date of today(backdated)

 * Add a line of 15.25

 * Process the Goods Receipt.

 * Run Costing Background process.

 * Go to Cost Adjustments window and check that 2 new Cost Adjustments have been created:

    - "Negative Stock Correction" with one line. That is correct.
    - "Backdated Transaction" with 3 lines.
       * The first one pointing to V+ -> This is correct
       * The second one pointing to M- -> This is NOT correct
       * The second one pointing to M+-> This is NOT correct

 * The last two adjustment lines are not necessary, they were being created due to precision rounding issues.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0029822 closedumartirena [Cost Adjustments] Unnecessary backdated adjustments are created under certain circumstances 

-  Notes
(0077281)
hgbot (developer)
2015-05-11 13:27

Repository: erp/backports/3.0PR15Q2.1
Changeset: a76de5445a7f626cf9abd7fdb7ddcb49091c11f7
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Mon May 11 10:15:38 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.1/rev/a76de5445a7f626cf9abd7fdb7ddcb49091c11f7 [^]

Fixes bug 29836: Avoid creating unnecessary backdated adjustments.

The problem was happening when costing precision was different from standard precision. When calculating the expected cost of a transaction to know if an adjustment is necessary to be created, it has to be rounded to standard precision because the amounts always have to be created in standard precision. In this case, while comparing expected cost with actual cost from database, as in database values are rounded to standard precision, and expected cost was being rounded to cost precission, an adjustment was being created with the difference, that corresponds just to the precision lost, and finally an adjustment of Zero amount was being created.

---
M src/org/openbravo/costing/AverageCostAdjustment.java
---
(0077282)
aferraz (developer)
2015-05-11 13:28

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2015-05-11 10:12 umartirena Type defect => backport
2015-05-11 10:12 umartirena Target Version => 3.0PR15Q2.1
2015-05-11 11:54 aferraz Assigned To Triage Finance => umartirena
2015-05-11 13:27 hgbot Checkin
2015-05-11 13:27 hgbot Note Added: 0077281
2015-05-11 13:27 hgbot Status scheduled => resolved
2015-05-11 13:27 hgbot Resolution open => fixed
2015-05-11 13:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.1/rev/a76de5445a7f626cf9abd7fdb7ddcb49091c11f7 [^]
2015-05-11 13:28 aferraz Review Assigned To => aferraz
2015-05-11 13:28 aferraz Note Added: 0077282
2015-05-11 13:28 aferraz Status resolved => closed
2015-05-11 13:28 aferraz Fixed in Version => 3.0PR15Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker