Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029834
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajorhave not tried2015-05-11 08:582015-05-22 12:19
ReporteralostaleView Statuspublic 
Assigned Tomalsasua 
PriorityimmediateResolutionfixedFixed in VersionRR15Q3
StatusclosedFix in branchFixed in SCM revision56d256345d7d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaaroncalero
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029834: Discount rules for Retail by total module 1.0.1 is not compatible with PR15Q2

DescriptionDiscount rules for Retail by total module version 1.0.1 cannot be installed in PR15Q2 because it makes use of a core element that has been removed.
Steps To Reproduce* In PR15Q1 install Discount rules for Retail by total module version 1.0.1 (latest version)
* Update to PR15Q2
  -> update database fails because of this missing ad_element
Proposed SolutionThere is already a changeset in that module's reposotory fixing this problem: https://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts.bytotal/rev/ad00af4ef331 [^]

But a new version has never been published.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029506 closedmalsasua Compilation fails when the modules org.openbravo.retail.discounts and org.openbravo.retail.discounts.bytotal are instaled 

-  Notes
(0077269)
hgbot (developer)
2015-05-11 11:09

Repository: erp/pmods/org.openbravo.retail.discounts.bytotal
Changeset: 56d256345d7d1593ab6bc051cc346bdde71340c1
Author: Miguel A. Alsasua <miguel.alsasua <at> openbravo.com>
Date: Mon May 11 11:08:44 2015 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts.bytotal/rev/56d256345d7d1593ab6bc051cc346bdde71340c1 [^]

fixed issue 29834: updated the module dependency

---
M src-db/database/sourcedata/AD_MODULE.xml
M src-db/database/sourcedata/AD_MODULE_DEPENDENCY.xml
---
(0077658)
aaroncalero (developer)
2015-05-22 12:19

Tested and reviewed

- Issue History
Date Modified Username Field Change
2015-05-11 08:58 alostale New Issue
2015-05-11 08:58 alostale Assigned To => Retail
2015-05-11 08:58 alostale Triggers an Emergency Pack => No
2015-05-11 10:55 malsasua Assigned To Retail => malsasua
2015-05-11 10:57 alostale Relationship added related to 0029506
2015-05-11 11:09 hgbot Checkin
2015-05-11 11:09 hgbot Note Added: 0077269
2015-05-11 11:09 hgbot Status new => resolved
2015-05-11 11:09 hgbot Resolution open => fixed
2015-05-11 11:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts.bytotal/rev/56d256345d7d1593ab6bc051cc346bdde71340c1 [^]
2015-05-21 12:27 aaroncalero Review Assigned To => aaroncalero
2015-05-22 12:19 aaroncalero Note Added: 0077658
2015-05-22 12:19 aaroncalero Status resolved => closed
2015-05-22 12:19 aaroncalero Fixed in Version => RR15Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker