Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029594
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-04-15 12:562015-05-07 22:16
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision308ecc3849a8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029594: Cannot open a window if ShowAcct preference is set to Y and the Accounting tab is defined alone on the 2nd level

DescriptionCannot open a window if ShowAcct preference is set to Y and the Accounting tab is defined alone on the 2nd level
Steps To ReproduceAs group admin role:
   Remove all the preferences defined with attribute = ShowAcct
   Create a preference visible for all with
      attribute: ShowAcct
      value: N
   Create a preference visible for Openbravo user, F&B International Admin role and Business partner window with:
      attribute: ShowAcct
      value: Y
   Log out and log in again
   Try to open the Business Partner window and check it remains loading
   Check the following exception is raised:
      Uncaught TypeError: Cannot read property 'pane' of undefined
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0076706)
hgbot (developer)
2015-04-22 20:05

Repository: erp/devel/pi
Changeset: 308ecc3849a80b4acc1afe177ecffc40f9e45204
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Apr 22 20:04:43 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/308ecc3849a80b4acc1afe177ecffc40f9e45204 [^]

fixes issue 29594: ShowAcct preference not working on 2nd level accounting tabs

The ShowAcct preference value was not being retrieved properly in child tabs in the addChildView method, because the windowId was undefined.
This is because windowId is only set for the top view in the hierarchy. Now the problem is solved because the windowId value is retrieved using the reference to the standard window.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0076768)
alostale (developer)
2015-04-27 08:45

code reviewed + tested
(0077145)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-15 12:56 ngarcia New Issue
2015-04-15 12:56 ngarcia Assigned To => platform
2015-04-15 12:56 ngarcia Modules => Core
2015-04-15 12:56 ngarcia Triggers an Emergency Pack => No
2015-04-15 12:57 ngarcia Issue Monitored: networkb
2015-04-15 16:04 xabiermerino Issue Monitored: xabiermerino
2015-04-16 08:31 alostale Status new => acknowledged
2015-04-20 09:16 alostale Status acknowledged => scheduled
2015-04-20 09:16 alostale Assigned To platform => caristu
2015-04-22 20:05 hgbot Checkin
2015-04-22 20:05 hgbot Note Added: 0076706
2015-04-22 20:05 hgbot Status scheduled => resolved
2015-04-22 20:05 hgbot Resolution open => fixed
2015-04-22 20:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/308ecc3849a80b4acc1afe177ecffc40f9e45204 [^]
2015-04-22 20:06 caristu Review Assigned To => alostale
2015-04-22 20:06 caristu Issue Monitored: alostale
2015-04-27 08:45 alostale Note Added: 0076768
2015-04-27 08:45 alostale Status resolved => closed
2015-04-27 08:45 alostale Fixed in Version => 3.0PR15Q3
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077145


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker