Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029533
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-04-08 20:142015-05-07 22:16
ReporterumartirenaView Statuspublic 
Assigned Toeduardo_Argal 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision759e05643a7f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-09-23
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
Triggers an Emergency PackNo
Summary

0029533: Transaction cannot be created from Match Statement for financial accounts of orgs not in natural tree of session org

DescriptionWhen trying to create a transaction from Match Statement window, if the financial account belongs to an org not in natural tree of Organization in session, it fails. This only happens for transactions of type Bank Fee.
Steps To ReproduceIn live builds as Group Admin role:
* Go to Financial Account window. Select "Bank - Account 1".
* Go to Imported Bank Statements tab. Create a Header.
* Create a Bank Statement Line. Amount Out 10. Process it.
* Click on Match Statement. Press cancel in the displayed popup.
* Select the previously created line and click on Add Transaction.
* Set as Transaction Type "Bank Fee" and press Done.

Realize that the following error is raised:

"Error
Entity 20 (FIN_BankStatementLine) with organization F&B US, Inc. references an entity Bank - Account 1 - USD - - 0 through its property financialAccountTransaction but this referenced entity belongs to an organization F&B España - Región Norte which is not part of the natural tree of F&B US, Inc."
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00295353.0PR15Q2 closededuardo_Argal Transaction cannot be created from Match Statement for financial accounts of orgs not in natural tree of session org 
depends on backport 00295363.0PR15Q1.3 closededuardo_Argal Transaction cannot be created from Match Statement for financial accounts of orgs not in natural tree of session org 
caused by feature request 00293903.0PR14Q4 closedSandrahuguet Reconciliation refactor project 

-  Notes
(0076434)
hgbot (developer)
2015-04-10 08:16

Repository: erp/devel/pi
Changeset: 759e05643a7fb242063e1d41cf647133ea96db40
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Fri Apr 10 08:15:50 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/759e05643a7fb242063e1d41cf647133ea96db40 [^]

Fixes bug 29533: Transaction can be created from Add transaction for Bank Fee

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/AddTransactionActionHandler.java
---
(0076435)
umartirena (developer)
2015-04-10 08:17

Code Review + Testing OK

Issue fixed by Eduardo Argal
(0077112)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-08 20:14 umartirena New Issue
2015-04-08 20:14 umartirena Assigned To => umartirena
2015-04-08 20:14 umartirena Modules => Core
2015-04-08 20:14 umartirena Regression level => Production - QA Approved
2015-04-08 20:14 umartirena Regression introduced in release => 3.0PR14Q4
2015-04-08 20:14 umartirena Triggers an Emergency Pack => No
2015-04-08 20:16 umartirena Priority normal => immediate
2015-04-08 20:24 umartirena Status new => scheduled
2015-04-08 23:36 umartirena Relationship added caused by 0029390
2015-04-08 23:37 umartirena Regression date => 2014-09-23
2015-04-08 23:37 umartirena Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
2015-04-10 08:16 hgbot Checkin
2015-04-10 08:16 hgbot Note Added: 0076434
2015-04-10 08:16 hgbot Status scheduled => resolved
2015-04-10 08:16 hgbot Resolution open => fixed
2015-04-10 08:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/759e05643a7fb242063e1d41cf647133ea96db40 [^]
2015-04-10 08:17 umartirena Review Assigned To => umartirena
2015-04-10 08:17 umartirena Note Added: 0076435
2015-04-10 08:17 umartirena Status resolved => closed
2015-04-10 08:17 umartirena Fixed in Version => pi
2015-04-10 08:17 umartirena Assigned To umartirena => eduardo_Argal
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077112


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker