Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029505
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementcriticalalways2015-04-07 11:112015-05-07 22:16
ReportermaiteView Statuspublic 
Assigned Toeduardo_Argal 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision5ba79fd31ade
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-06-09
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/57ae71ea5865 [^]
Triggers an Emergency PackYes
Summary

0029505: Wrong invoice posting when it has related payment in/out in Void status

DescriptionWrong invoice posting when it has related payment in/out in Void status
Steps To Reproduce1. Register Sales Invoice for any Org and BP. Add any line and process
2. Configure Payment Method as "Automatic", "Simple execution process" and "Deferred=yes"
3. Register Payment In and VOID it
4. Register new Payment In related to that invoice and process it
5. Post invoice and realize that "Cuenta de cuadre/Currency balancing" is used
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00295103.0PR15Q2 closededuardo_Argal Wrong invoice posting when it has related payment in/out in Void status 
depends on backport 00295113.0PR15Q1.3 closededuardo_Argal Wrong invoice posting when it has related payment in/out in Void status 
caused by feature request 0029391 closedSandrahuguet Add Payment refactor project 

-  Notes
(0076503)
hgbot (developer)
2015-04-13 18:28

Repository: erp/devel/pi
Changeset: 5ba79fd31ade2aa5ca890b23c014cc04f115f59d
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Mon Apr 13 18:28:02 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5ba79fd31ade2aa5ca890b23c014cc04f115f59d [^]

Fixes issue 29505: Duplicated amount when cancelled payment

Removes canceled payment schedule details when posting.

---
M src/org/openbravo/erpCommon/ad_forms/DocInvoice_data.xsql
---
(0076504)
umartirena (developer)
2015-04-13 18:29

Code Review + Testing OK

Issue fixed by Eduardo Argal
(0077122)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-07 11:11 maite New Issue
2015-04-07 11:11 maite Assigned To => Sandrahuguet
2015-04-07 11:11 maite Modules => Core
2015-04-07 11:11 maite Triggers an Emergency Pack => No
2015-04-07 11:12 maite Issue Monitored: networkb
2015-04-07 13:15 umartirena Regression level => Production - Confirmed Stable
2015-04-07 13:15 umartirena Regression date => 2014-06-09
2015-04-07 13:15 umartirena Regression introduced in release => 3.0PR14Q3
2015-04-07 13:15 umartirena Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/57ae71ea5865 [^]
2015-04-07 13:15 umartirena Triggers an Emergency Pack No => Yes
2015-04-07 13:15 umartirena Assigned To Sandrahuguet => umartirena
2015-04-07 13:18 umartirena Status new => scheduled
2015-04-07 13:54 umartirena Target Version 3.0PR15Q2 => 3.0PR15Q3
2015-04-13 18:28 hgbot Checkin
2015-04-13 18:28 hgbot Note Added: 0076503
2015-04-13 18:28 hgbot Status scheduled => resolved
2015-04-13 18:28 hgbot Resolution open => fixed
2015-04-13 18:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5ba79fd31ade2aa5ca890b23c014cc04f115f59d [^]
2015-04-13 18:29 umartirena Assigned To umartirena => eduardo_Argal
2015-04-13 18:29 umartirena Review Assigned To => umartirena
2015-04-13 18:29 umartirena Note Added: 0076504
2015-04-13 18:29 umartirena Status resolved => closed
2015-04-13 18:29 umartirena Fixed in Version => pi
2015-04-22 10:11 dmitry_mezentsev Relationship added caused by 0029391
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077122


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker