Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029464
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminoralways2015-03-30 18:242015-05-07 22:16
ReportermaiteView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision58b1503188be
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-10-02
Regression introduced in release3.0PR14Q4
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029464: NullPointerException error when Adding Payment from Match Statement process and working with Automatic Payment Method

DescriptionNullPointerException error when Adding Payment from Match Statement process and working with Automatic Payment Method
Steps To Reproduce1. Access "Cuenta de Banco" financial account and create new Bank Statement. Add line with IN amount=50
2. Access "Execution process" window and add parameter to "Simple Execution Process" as "Parameter type= IN", "Input type= Checkbox", "Default value for flag= yes", "Mandatory= yes"
3. Access Financial Account | Payment method tab and configure Transferencia as "Automatic", Execution process= "Simple Execution Process" and Deferred= NO
4. Run "Match Statement" process and "Add transaction" process. Realize that IN amount is set to 50
5. Run "Add Payment" process, choose any invoice and press Done. Realize that IN amount is empty

Following NullPointerException error appears in openbravo.log:
java.lang.NullPointerException
    at org.openbravo.advpaymentmngt.process.FIN_ExecutePayment.init(FIN_ExecutePayment.java:83)
Proposed SolutionProblem is that "parameters" variable is null in line 83 of FIN_ExecutePayment.java file
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00294973.0PR15Q2 closedvmromanos NullPointerException error when Adding Payment from Match Statement process and working with Automatic Payment Method 
depends on backport 00294983.0PR15Q1.3 closedvmromanos NullPointerException error when Adding Payment from Match Statement process and working with Automatic Payment Method 
caused by feature request 00293903.0PR14Q4 closedSandrahuguet Reconciliation refactor project 
causes defect 00302063.0PR15Q3 closedaferraz Wrong payment status under some circumstancies 

-  Notes
(0076179)
vmromanos (developer)
2015-03-31 17:37

"Regression introduced by commit" not filled because there is no a concrete changeset that created the regression, but the match statement refactor project in general
(0076318)
vmromanos (developer)
2015-04-01 16:05

I have found 3 bugs that I will fix at the same time:
1. Wrong management of default parameters in automatic execution process (not a regression but an old bug)
2. NPE when working with default parameters in execution process (not a regression but an old bug)
3. Impossible to create a new payment from transaction when the payment method has an automatic execution process and automatic deposit/withdrawn (this is the real regression)
(0076351)
hgbot (developer)
2015-04-07 09:55

Repository: erp/devel/pi
Changeset: 58b1503188be73811b4885798fae1d31bd337076
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Tue Apr 07 09:53:06 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/58b1503188be73811b4885798fae1d31bd337076 [^]

Fixed bug 29464: Several issues in Match Statement

1) Wrong management of default parameters in automatic execution process:
ParameterType was used where InputType was expected (and the opposite)

2) NPE when working with default parameters in execution process
constantParameters attribute wasn't initialized before being used. Fixed also parameters attribute with the same potential issue

3) Impossible to create a new payment from transaction when the payment method has an automatic execution process and automatic deposit/withdrawn
We now pass an internal parameter comingFrom to know if we come from a transaction. In this case we don't create automatically the transaction (regardless the payment method is automatic deposit/withdrawn) to avoid breaking the unique constraint FIN_FINACC_TRANSACTION_UN inside FIN_FINACC_TRANSACTION table

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_ExecutePayment.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
---
(0076360)
umartirena (developer)
2015-04-07 10:22
edited on: 2015-04-07 10:23

Issue fixed by vmromanos

Code Review + Testing OK

(0077110)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-30 18:24 maite New Issue
2015-03-30 18:24 maite Assigned To => Sandrahuguet
2015-03-30 18:24 maite Modules => Core
2015-03-30 18:24 maite Triggers an Emergency Pack => No
2015-03-30 18:24 maite Issue Monitored: networkb
2015-03-31 17:37 vmromanos Regression level => Production - QA Approved
2015-03-31 17:37 vmromanos Regression date => 2014-10-02
2015-03-31 17:37 vmromanos Regression introduced in release => 3.0PR14Q4
2015-03-31 17:37 vmromanos Note Added: 0076179
2015-04-01 16:05 vmromanos Note Added: 0076318
2015-04-01 16:05 vmromanos Assigned To Sandrahuguet => vmromanos
2015-04-01 16:49 dmitry_mezentsev Relationship added caused by 0029390
2015-04-01 17:26 vmromanos Status new => scheduled
2015-04-07 09:55 hgbot Checkin
2015-04-07 09:55 hgbot Note Added: 0076351
2015-04-07 09:55 hgbot Status scheduled => resolved
2015-04-07 09:55 hgbot Resolution open => fixed
2015-04-07 09:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/58b1503188be73811b4885798fae1d31bd337076 [^]
2015-04-07 10:22 umartirena Review Assigned To => umartirena
2015-04-07 10:22 umartirena Note Added: 0076360
2015-04-07 10:22 umartirena Status resolved => closed
2015-04-07 10:22 umartirena Fixed in Version => pi
2015-04-07 10:23 umartirena Note Edited: 0076360 View Revisions
2015-04-07 10:23 umartirena Note Edited: 0076360 View Revisions
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077110
2015-06-23 12:54 aferraz Relationship added causes 0030206


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker