Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029458
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-03-30 15:182015-05-07 22:16
ReporterngarciaView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisionba12c1680f35
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2015-03-25
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4f00f31f65e1 [^]
Triggers an Emergency PackYes
Summary

0029458: More than available stock can be reserved from Sales Order screen

DescriptionMore than available stock can be reserved from Sales Order screen
Steps To ReproduceAs group admin role:
   Configure the Enable Stock Reservations preference
   Log out and log in again
   Create a Sales Order for a product and a quantity higher than the stocked quantity
   Click on Manage Reservation button and check the Available Quantity is lower than the Quantity. This is incorrect
   Try to change the quantity to a value between the Available Quantity and the Quantity and check the following message is shown:
      "Reserved quantity exceeds the available quantity (30000) considering the quantity reserved in other reservations (0). Please, enter a valid number."
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00294743.0PR15Q2 closedaferraz More than available stock can be reserved from Sales Order screen 
depends on backport 00295473.0PR15Q1.3 closedaferraz More than available stock can be reserved from Sales Order screen 
caused by defect 00289073.0PR15Q3 closedreinaldoguerra Cannot filter the Manage Reservation Stock pop-up of Sales Order window 

-  Notes
(0076439)
hgbot (developer)
2015-04-10 11:06

Repository: erp/devel/pi
Changeset: ba12c1680f35ada90e285415e3ea8ba723f2963a
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Fri Apr 10 11:05:06 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ba12c1680f35ada90e285415e3ea8ba723f2963a [^]

Fixes bug 29458: Cannot be reserved more than available Stock.

Few more issues have been fixed also:

1) Prereservation lines will never have Warehouse field filled until they are received.

2) Filter of Purchase Order Line now is working having reservation completed or in draft status.

---
M src/org/openbravo/common/datasource/StockReservationPickAndEditDataSource.java
---
(0076440)
umartirena (developer)
2015-04-10 11:07

Code Review + Testing OK

Issue fixed by Eduardo Argal
(0077113)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-30 15:18 ngarcia New Issue
2015-03-30 15:18 ngarcia Assigned To => Sandrahuguet
2015-03-30 15:18 ngarcia Modules => Core
2015-03-30 15:18 ngarcia Regression level => Pre packaging ( pi )
2015-03-30 15:18 ngarcia Triggers an Emergency Pack => No
2015-03-30 15:22 ngarcia Issue Monitored: networkb
2015-03-30 17:02 aferraz Assigned To Sandrahuguet => aferraz
2015-03-30 18:56 umartirena Regression date => 2015-03-25
2015-03-30 18:56 umartirena Regression introduced in release => pi
2015-03-30 18:56 umartirena Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/4f00f31f65e1 [^]
2015-03-30 18:56 umartirena Triggers an Emergency Pack No => Yes
2015-03-31 13:28 aferraz Relationship added caused by 0028907
2015-03-31 14:26 aferraz Status new => scheduled
2015-04-09 10:56 umartirena Status scheduled => acknowledged
2015-04-09 10:56 umartirena Status acknowledged => scheduled
2015-04-10 11:06 hgbot Checkin
2015-04-10 11:06 hgbot Note Added: 0076439
2015-04-10 11:06 hgbot Status scheduled => resolved
2015-04-10 11:06 hgbot Resolution open => fixed
2015-04-10 11:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ba12c1680f35ada90e285415e3ea8ba723f2963a [^]
2015-04-10 11:07 umartirena Review Assigned To => umartirena
2015-04-10 11:07 umartirena Note Added: 0076440
2015-04-10 11:07 umartirena Status resolved => closed
2015-04-10 11:07 umartirena Fixed in Version => pi
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077113


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker