Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029374
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-03-23 13:432015-03-24 08:59
ReporteraferrazView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision3da15b275c37
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelCoding ( Testing )
Regression date2015-03-16
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/8e0a9e1ef5c3 [^]
Triggers an Emergency PackNo
Summary

0029374: Warehouse column is showing a wrong value in Manage Stock popup

DescriptionWarehouse column is showing a wrong value in Manage Stock popup
Steps To ReproduceAs group admin role:
   Set the Enable Stock Reservation preference to 'Y'

Logout and login again.
   Create a Goods Receipt for "España Norte" warehouse, "Cola de Cereza 0,5L product" and quantity 100. Complete it.
   Create a Goods Receipt for "España Sur" warehouse, "Cola de Cereza 0,5L product" and quantity 200. Complete it.

   Create a Sales Order for "España S.A." organization, "Cola de Cereza 0,5L product" and quantity 30. Book it.

   Go to the line and open the Manage Reservation pop-up
   Click on the record of "España Sur" warehouse. Realize the warehouse name is changed into "España Norte". Click on the record of "España Sur" warehouse again. Realize the warehouse name is changed into an id number.
TagsNo tags attached.
Attached Filespng file icon 0.png [^] (118,685 bytes) 2015-03-23 13:45


png file icon 1.png [^] (119,985 bytes) 2015-03-23 13:45


png file icon 2.png [^] (120,125 bytes) 2015-03-23 13:45

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00293793.0PR15Q1.2 closedAugustoMauch Warehouse column is showing a wrong value in Manage Stock popup 
depends on backport 00293803.0PR14Q3.8 closedAugustoMauch Warehouse column is showing a wrong value in Manage Stock popup 
caused by defect 00287273.0PR15Q3 closedAugustoMauch Payment Method info should be maintained when using "Modify Payment Plan" functionality 
related to defect 0029381 closedplatform Wrong value returned by the FIC in Manage Reservation P&E 

-  Notes
(0075890)
hgbot (developer)
2015-03-23 17:17

Repository: erp/devel/pi
Changeset: 3da15b275c3749878f00ee39214ad719e078f343
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 23 17:14:45 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3da15b275c3749878f00ee39214ad719e078f343 [^]

Fixes bug 29374: Warehouse field of Manage Reservation P&E shows a proper value

The is a bug in that P&E, reported here [1], that makes the FIC return the wrong value for the warehouse field of the Manage Reservation P&E window. Before [2] was fixed, [1] did not have any consequences, as the value returned by the FIC was not set to the row being edited.

To fix this, the values returned by the FIC are only set if the field is editable. [1] will have to be fixed anyway, because even if now it does not crete problems in this flow, it could be causing problems in others.

[1] https://issues.openbravo.com/view.php?id=29381 [^]
[2] https://issues.openbravo.com/view.php?id=28727 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0075910)
hudsonbot (developer)
2015-03-24 03:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/63f9617f42fb [^]
Maturity status: Test
(0075916)
alostale (developer)
2015-03-24 08:59

code reviewed

tested:
-Following steps to reproduce
-In Return to vendor P&E

- Issue History
Date Modified Username Field Change
2015-03-23 13:43 aferraz New Issue
2015-03-23 13:43 aferraz Assigned To => platform
2015-03-23 13:43 aferraz Modules => Core
2015-03-23 13:43 aferraz Triggers an Emergency Pack => No
2015-03-23 13:45 aferraz File Added: 0.png
2015-03-23 13:45 aferraz File Added: 1.png
2015-03-23 13:45 aferraz File Added: 2.png
2015-03-23 14:10 aferraz Steps to Reproduce Updated View Revisions
2015-03-23 14:20 aferraz Steps to Reproduce Updated View Revisions
2015-03-23 16:48 AugustoMauch Assigned To platform => AugustoMauch
2015-03-23 16:49 AugustoMauch Status new => scheduled
2015-03-23 16:49 AugustoMauch Regression level => Coding ( Testing )
2015-03-23 16:49 AugustoMauch Regression date => 2015-03-16
2015-03-23 16:49 AugustoMauch Regression introduced in release => pi
2015-03-23 16:49 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/8e0a9e1ef5c3 [^]
2015-03-23 16:57 AugustoMauch Relationship added caused by 0028727
2015-03-23 17:12 AugustoMauch Relationship added related to 0029381
2015-03-23 17:16 AugustoMauch Issue Monitored: alostale
2015-03-23 17:16 AugustoMauch Review Assigned To => alostale
2015-03-23 17:17 hgbot Checkin
2015-03-23 17:17 hgbot Note Added: 0075890
2015-03-23 17:17 hgbot Status scheduled => resolved
2015-03-23 17:17 hgbot Resolution open => fixed
2015-03-23 17:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3da15b275c3749878f00ee39214ad719e078f343 [^]
2015-03-24 03:44 hudsonbot Checkin
2015-03-24 03:44 hudsonbot Note Added: 0075910
2015-03-24 08:59 alostale Note Added: 0075916
2015-03-24 08:59 alostale Status resolved => closed
2015-03-24 08:59 alostale Fixed in Version => 3.0PR15Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker