Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029325
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2015-03-17 12:552015-03-19 13:52
ReporterjonalegriaesarteView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision44e6f470507a
ProjectionnoneETAnoneTarget Version3.0PR14Q3.8
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-07-11
Regression introduced in release3.0MP26
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/bed326b6ddf6f08b10cf22cd7403aff84c0e3750 [^]
Triggers an Emergency PackNo
Summary

0029325: Download attachments seleting several records is not working fine

DescriptionDownload attachments seleting several records is not working fine. This functionality was working fine in old releases (tested in MP20)
Steps To Reproduce- Sales invoice window, select one invoice, add an attachement
- Select a different invoice and add a new attachement
- In grid mode, select both invoices and download the attachments, using the attachment button.
- The zip file downloaded can not be opened. It is corrupted.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00293133.0PR15Q2 closedalostale Download attachments selecting several records is not working fine 

-  Notes
(0075721)
hgbot (developer)
2015-03-18 09:44

Repository: erp/backports/3.0PR14Q3.8
Changeset: 44e6f470507a59b27725439ba7e460d905b9bba2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Mar 18 09:08:59 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/44e6f470507a59b27725439ba7e460d905b9bba2 [^]

fixed bug 29325: attachment download of different records at once fails

  It generated an invalid zip file.

  The problem was it tried to find the attachment directory based on the whole
  list of ids to download instead of splitting it.

---
M src/org/openbravo/erpCommon/businessUtility/TabAttachments.java
---
(0075770)
AugustoMauch (developer)
2015-03-19 13:52

Code reviewed and verified in PR14Q3.8@44e6f470507a

- Issue History
Date Modified Username Field Change
2015-03-18 08:55 alostale Type defect => backport
2015-03-18 08:55 alostale Target Version 3.0PR15Q2 => 3.0PR14Q3.8
2015-03-18 09:44 hgbot Checkin
2015-03-18 09:44 hgbot Note Added: 0075721
2015-03-18 09:44 hgbot Status scheduled => resolved
2015-03-18 09:44 hgbot Resolution open => fixed
2015-03-18 09:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/44e6f470507a59b27725439ba7e460d905b9bba2 [^]
2015-03-19 13:52 AugustoMauch Note Added: 0075770
2015-03-19 13:52 AugustoMauch Status resolved => closed
2015-03-19 13:52 AugustoMauch Fixed in Version => 3.0PR15Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker