Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029197
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-03-09 11:012015-03-20 19:23
ReportermaiteView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision14b642262f27
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029197: Payment Out is registered as "BP Deposit" transaction type in financial account

DescriptionPayment Out is registered as "BP Deposit" transaction type in financial account
Steps To Reproduce1. Register Purchase Invoice for any org and bp. Add any line and process
2. Run Add payment process and register related payment out and withdrawn it
3. Navigate to Financial Account and realize that it has been registered as "BP Deposit" transaction type

Problem is also reproducible when registering document directly from Payment Out screen
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00292073.0PR15Q1.2 closedSandrahuguet Payment Out is registered as "BP Deposit" transaction type in financial account 
related to defect 0029338 closedaferraz Payment navigation from Financial Account Transaction tab is working wrong 
related to defect 00291623.0PR15Q3 closedreinaldoguerra Add Transaction process inside Match statement process, does not consider amount of 0.00 equals to 0 

-  Notes
(0075495)
dmitry_mezentsev (developer)
2015-03-12 16:47

Not a regression but an issue in the new field-functionality.
(0075506)
hgbot (developer)
2015-03-12 19:17

Repository: erp/devel/pi
Changeset: 5c3aeebd4d494d694bf5fb4733fee0509c470768
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Thu Mar 12 16:00:40 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5c3aeebd4d494d694bf5fb4733fee0509c470768 [^]

Fixed bug 29197 Payment Out is registered as "BP Deposit" transaction

In FIN_TransactionProcess.java set the correct value depending on
the type of transaction

---
M modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/UpdateTransactionTypeTransactionTab.class
M modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/UpdateTransactionTypeTransactionTabData.class
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/UpdateTransactionTypeTransactionTab.java
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/UpdateTransactionTypeTransactionTab_data.xsql
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/src/org/openbravo/advpaymentmngt/modulescript/UpdateTransactionTypeTransactionTabData.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_TransactionProcess.java
---
(0075507)
hgbot (developer)
2015-03-12 19:17

Repository: erp/devel/pi
Changeset: e2cc40f75e69d26e763801f2a128424fcd4404a5
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Thu Mar 12 16:06:00 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e2cc40f75e69d26e763801f2a128424fcd4404a5 [^]

related to issue 29197 update Copyright

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_TransactionProcess.java
---
(0075509)
aferraz (developer)
2015-03-12 19:25

Code review + Testing OK
(0075521)
Sandrahuguet (developer)
2015-03-13 10:08

reopen because we need to define the behaviour with EAR
(0075578)
hudsonbot (developer)
2015-03-13 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3019166d6076 [^]
Maturity status: Test
(0075579)
hudsonbot (developer)
2015-03-13 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3019166d6076 [^]
Maturity status: Test
(0075755)
hgbot (developer)
2015-03-18 19:04

Repository: erp/devel/pi
Changeset: 14b642262f275c5b7fe1517e8211b181b64735c8
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Wed Mar 18 12:29:45 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/14b642262f275c5b7fe1517e8211b181b64735c8 [^]

Fixed bug 29197 Payment Out is registered as "BP Deposit" transaction

In FIN_TransactionProcess.java set the correct value depending on
the type of transaction
Fix aprm_gen_paymentschedule_inv function in order to have the
same behavior on all automatic processes

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_TransactionProcess.java
---
(0075756)
aferraz (developer)
2015-03-18 19:05

Code review + Testing OK
(0075832)
hudsonbot (developer)
2015-03-20 19:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a670497786d1 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-09 11:01 maite New Issue
2015-03-09 11:01 maite Assigned To => Sandrahuguet
2015-03-09 11:01 maite Modules => Core
2015-03-09 11:01 maite Triggers an Emergency Pack => No
2015-03-09 11:01 maite Issue Monitored: networkb
2015-03-09 15:32 heccam Issue Monitored: heccam
2015-03-09 19:05 Sandrahuguet Status new => scheduled
2015-03-10 12:04 Sandrahuguet Regression level => Production - QA Approved
2015-03-10 12:04 Sandrahuguet Regression date => 2014-09-23
2015-03-10 12:04 Sandrahuguet Regression introduced in release => 3.0PR14Q4
2015-03-10 12:04 Sandrahuguet Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
2015-03-12 16:47 dmitry_mezentsev Regression level Production - QA Approved =>
2015-03-12 16:47 dmitry_mezentsev Regression date 2014-09-23 =>
2015-03-12 16:47 dmitry_mezentsev Regression introduced in release 3.0PR14Q4 =>
2015-03-12 16:47 dmitry_mezentsev Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^] =>
2015-03-12 16:47 dmitry_mezentsev Note Added: 0075495
2015-03-12 19:17 hgbot Checkin
2015-03-12 19:17 hgbot Note Added: 0075506
2015-03-12 19:17 hgbot Status scheduled => resolved
2015-03-12 19:17 hgbot Resolution open => fixed
2015-03-12 19:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5c3aeebd4d494d694bf5fb4733fee0509c470768 [^]
2015-03-12 19:17 hgbot Checkin
2015-03-12 19:17 hgbot Note Added: 0075507
2015-03-12 19:25 aferraz Review Assigned To => aferraz
2015-03-12 19:25 aferraz Note Added: 0075509
2015-03-12 19:25 aferraz Status resolved => closed
2015-03-13 10:08 Sandrahuguet Note Added: 0075521
2015-03-13 10:08 Sandrahuguet Status closed => new
2015-03-13 10:08 Sandrahuguet Resolution fixed => open
2015-03-13 18:40 hudsonbot Checkin
2015-03-13 18:40 hudsonbot Note Added: 0075578
2015-03-13 18:40 hudsonbot Checkin
2015-03-13 18:40 hudsonbot Note Added: 0075579
2015-03-18 17:18 aferraz Relationship added related to 0029338
2015-03-18 19:04 hgbot Checkin
2015-03-18 19:04 hgbot Note Added: 0075755
2015-03-18 19:04 hgbot Status new => resolved
2015-03-18 19:04 hgbot Resolution open => fixed
2015-03-18 19:04 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/5c3aeebd4d494d694bf5fb4733fee0509c470768 [^] => http://code.openbravo.com/erp/devel/pi/rev/14b642262f275c5b7fe1517e8211b181b64735c8 [^]
2015-03-18 19:05 aferraz Note Added: 0075756
2015-03-18 19:05 aferraz Status resolved => closed
2015-03-20 19:23 hudsonbot Checkin
2015-03-20 19:23 hudsonbot Note Added: 0075832
2015-03-23 17:41 aferraz Relationship added related to 0029162


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker