Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029150
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementmajoralways2015-02-04 13:032015-03-17 19:29
ReporteregoitzView Statuspublic 
Assigned ToSandrahuguet 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q3.8
StatusclosedFix in branchFixed in SCM revisiona970b9f8bc93
ProjectionnoneETAnoneTarget Version3.0PR14Q3.8
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029150: UpdatePaymentPlan modulscript takes long when updating from a version lower than q3 to q3.

DescriptionUpdatePaymentPlan modulscript takes long when updating from a version lower than q3 to q3.
Steps To ReproduceON an environment with big amount of data on q2 release or lower update to the last confirmed stable release.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00288603.0PR15Q2 closedSandrahuguet UpdatePaymentPlan modulscript takes long when updating from a version lower than q3 to q3. 

-  Notes
(0075649)
hgbot (developer)
2015-03-16 18:26

Repository: erp/backports/3.0PR14Q3.8
Changeset: a970b9f8bc930875c8b495d856ea739ca333df4a
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Thu Mar 12 10:54:39 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/a970b9f8bc930875c8b495d856ea739ca333df4a [^]

Fixed bug 29150 improve performance in UpdatePaymentPlan modulescript

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdatePaymentPlan.class
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdatePaymentPlanData.class
M src-util/modulescript/build/javasqlc/src/org/openbravo/modulescript/UpdatePaymentPlanData.java
M src-util/modulescript/src/org/openbravo/modulescript/UpdatePaymentPlan.java
M src-util/modulescript/src/org/openbravo/modulescript/UpdatePaymentPlan_data.xsql
---
(0075650)
umartirena (developer)
2015-03-16 18:28

Code Review + Testing OK
(0075677)
umartirena (developer)
2015-03-17 09:14

Reopened due to an scenario is not covered so the modulescript is not completely correct
(0075703)
umartirena (developer)
2015-03-17 19:29

Code Review + Testing OK

- Issue History
Date Modified Username Field Change
2015-03-05 16:55 Sandrahuguet Type defect => backport
2015-03-05 16:55 Sandrahuguet Target Version 3.0PR15Q3 => 3.0PR14Q3.8
2015-03-16 18:26 hgbot Checkin
2015-03-16 18:26 hgbot Note Added: 0075649
2015-03-16 18:26 hgbot Status scheduled => resolved
2015-03-16 18:26 hgbot Resolution open => fixed
2015-03-16 18:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/a970b9f8bc930875c8b495d856ea739ca333df4a [^]
2015-03-16 18:28 umartirena Review Assigned To => umartirena
2015-03-16 18:28 umartirena Note Added: 0075650
2015-03-16 18:28 umartirena Status resolved => closed
2015-03-16 18:28 umartirena Fixed in Version => 3.0PR14Q3.8
2015-03-17 09:14 umartirena Note Added: 0075677
2015-03-17 09:14 umartirena Status closed => new
2015-03-17 09:14 umartirena Resolution fixed => open
2015-03-17 09:14 umartirena Fixed in Version 3.0PR14Q3.8 =>
2015-03-17 19:28 umartirena Status new => scheduled
2015-03-17 19:29 umartirena Status scheduled => resolved
2015-03-17 19:29 umartirena Fixed in Version => 3.0PR14Q3.8
2015-03-17 19:29 umartirena Resolution open => fixed
2015-03-17 19:29 umartirena Note Added: 0075703
2015-03-17 19:29 umartirena Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker