Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029110
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminorhave not tried2015-03-03 12:252015-03-13 19:49
ReporterSandrahuguetView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionbb7b3752a14d
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date2013-12-31
Regression introduced in release3.0MP31
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/fcb87e990fcd [^]
Triggers an Emergency PackNo
Summary

0029110: It is not possible to change currency in header tab in G/L Journal

DescriptionIt is not possible to change currency in header tab in G/L Journal working in oracle.
Steps To Reproduce-Go to G/L Journal and create new record to "F&B España" Organization
-Navigate to header and create new record:
  ·Organization: F&B España
  ·Currency: EUR
-Navigate to lines and create a new line
-Return to the header and try to change currency to USD, the following error is shown:

Error
Saving failed. ORA-04091: table ERP_PI_ORACLE.GL_JOURNAL is mutating, trigger/function may not see it ORA-06512: at "ERP_PI_ORACLE.GL_JOURNALLINE2_TRG", line 41 ORA-04088: error during execution of trigger 'ERP_PI_ORACLE.GL_JOURNALLINE2_TRG' ORA-06512: at "ERP_PI_ORACLE.GL_JOURNAL_TRG", line 35 ORA-04088: error during execution of trigger 'ERP_PI_ORACLE.GL_JOURNAL_TRG'
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00290923.0PR15Q2 closedAugustoMauch Data is not refreshed in form view after changing it with a trigger 
depends on backport 00292503.0PR15Q1.2 closedAtulOpenbravo It is not possible to change currency in header tab in G/L Journal 
depends on backport 00292513.0PR14Q3.8 closedAtulOpenbravo It is not possible to change currency in header tab in G/L Journal 
caused by defect 0025414 closedjecharri Wrong currency rate is applied when posting a GL Journal line 

-  Notes
(0075230)
AtulOpenbravo (developer)
2015-03-06 10:07

Test Plan
- Go to G/L Journal and create new record to "F&B España" Organization.
- Navigate to header and create new record.
   - Organization: F&B España
   - Currency: EUR
- Navigate to lines and create a new line.
- Return to the header and try to change currency to USD.
- Check that Journal Lines get updated properly as per conversion rate and there is no error as earlier.
(0075469)
hgbot (developer)
2015-03-12 10:30

Repository: erp/devel/pi
Changeset: bb7b3752a14dcddad480dbbacb94fa64c3b31e63
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Wed Mar 11 11:48:22 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/bb7b3752a14dcddad480dbbacb94fa64c3b31e63 [^]

Fixes Issue 29110:It is not possible to change currency in header tab in G/L
Journal

As there is trigger mutating error, updation of gl journal line currency and
currency rate is moved to a event handler from gl_journal_trg trigger.

---
M src-db/database/model/triggers/GL_JOURNAL_TRG.xml
A src/org/openbravo/event/GLJournalEventHandler.java
---
(0075470)
hgbot (developer)
2015-03-12 10:30

Repository: erp/devel/pi
Changeset: ac9670b7bfddfbe3831839948a7b70ce2d3e82e1
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Mar 11 13:23:31 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ac9670b7bfddfbe3831839948a7b70ce2d3e82e1 [^]

Related to issue 29110: Added a clear inside the loop

Added a clear inside the loop to avoid performance problems

---
M src/org/openbravo/event/GLJournalEventHandler.java
---
(0075471)
aferraz (developer)
2015-03-12 10:31

Code review + Testing ok
(0075499)
hudsonbot (developer)
2015-03-12 17:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4f8a4e2f76d2 [^]
Maturity status: Test
(0075500)
hudsonbot (developer)
2015-03-12 17:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4f8a4e2f76d2 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-03 12:25 Sandrahuguet New Issue
2015-03-03 12:25 Sandrahuguet Assigned To => AtulOpenbravo
2015-03-03 12:25 Sandrahuguet Modules => Core
2015-03-03 12:25 Sandrahuguet Triggers an Emergency Pack => No
2015-03-03 12:28 Sandrahuguet Description Updated View Revisions
2015-03-04 05:07 AtulOpenbravo Status new => scheduled
2015-03-04 05:07 AtulOpenbravo fix_in_branch => pi
2015-03-06 10:07 AtulOpenbravo Note Added: 0075230
2015-03-10 14:38 aferraz Regression date => 2013-12-31
2015-03-10 14:38 aferraz Regression introduced in release => 3.0MP31
2015-03-10 14:38 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/fcb87e990fcd [^]
2015-03-10 14:38 aferraz fix_in_branch pi =>
2015-03-12 09:38 aferraz Relationship added related to 0029092
2015-03-12 10:08 aferraz Status scheduled => acknowledged
2015-03-12 10:08 aferraz Status acknowledged => scheduled
2015-03-12 10:30 hgbot Checkin
2015-03-12 10:30 hgbot Note Added: 0075469
2015-03-12 10:30 hgbot Status scheduled => resolved
2015-03-12 10:30 hgbot Resolution open => fixed
2015-03-12 10:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bb7b3752a14dcddad480dbbacb94fa64c3b31e63 [^]
2015-03-12 10:30 hgbot Checkin
2015-03-12 10:30 hgbot Note Added: 0075470
2015-03-12 10:31 aferraz Review Assigned To => aferraz
2015-03-12 10:31 aferraz Note Added: 0075471
2015-03-12 10:31 aferraz Status resolved => closed
2015-03-12 17:10 hudsonbot Checkin
2015-03-12 17:10 hudsonbot Note Added: 0075499
2015-03-12 17:10 hudsonbot Checkin
2015-03-12 17:10 hudsonbot Note Added: 0075500
2015-03-13 19:49 dmitry_mezentsev Relationship added caused by 0025414


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker