Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029097
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-03-02 12:292015-04-01 11:52
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision2b06105e638c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-03-05
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/1ea574e6513ced497aaa66952a0eb3ff48525669 [^]
Triggers an Emergency PackNo
Summary

0029097: Not possible to move a menu entry on the tree if you not have the module indevelpment

DescriptionA menu entry of a core element only can be moved on the tree structure defining core as indevelopment.
Steps To Reproduce-Define a template as indevelopment
-Go to menu window
-click on tree button
-Try to move a entry on the tree structure.
*an error is raised:

The node must belong to a module that is in development in order to be reparented.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 00259063.0PR14Q2 closedAugustoMauch Tree Extension Project 

-  Notes
(0075074)
AugustoMauch (developer)
2015-03-02 12:40

The MenuTreeOperationManager class should be updated to allow moving menu tree nodes if there is a template in development, even if the module owner of the tree node being moved is not in development
(0075086)
hgbot (developer)
2015-03-02 13:47

Repository: erp/devel/pi
Changeset: f1360ce4b3d1861653f726626296ea743e16c52f
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 02 13:45:56 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f1360ce4b3d1861653f726626296ea743e16c52f [^]

Fixes bug 29097: A menu tree node can be moved with a template in development

When the Openbravo Trees were reimplemented [1], there was a problem reimplementing the logic done when a Menu tree item is moved. Before the reimplementation, it was possible to move a menu tree item if the module it belonged to was in development or if there was any template module in development. The reimplementation did not take into account the templates, so from then on it has not been possible to moved menu tree nodes having a template in development.

To fix this, templates are taken into accout in the MenuTreeOperationManager class.

[1] https://issues.openbravo.com/view.php?id=25906 [^]

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/treeChecks/MenuTreeOperationManager.java
---
(0075087)
AugustoMauch (developer)
2015-03-02 13:51

A test has been defined in testlink [1]

[1] http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8056 [^]
(0075122)
hudsonbot (developer)
2015-03-03 16:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f4fc528722d4 [^]
Maturity status: Test
(0075294)
alostale (developer)
2015-03-09 09:39

Code reviewed

Tested with and without templates in dev
(0075762)
hgbot (developer)
2015-03-19 07:17

Repository: erp/backports/3.0PR14Q3.8
Changeset: 17972a6e9e7ba9bb11b3e702c817cc839feacef4
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 02 13:45:56 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/17972a6e9e7ba9bb11b3e702c817cc839feacef4 [^]

Fixes bug 29097: A menu tree node can be moved with a template in development

When the Openbravo Trees were reimplemented [1], there was a problem reimplementing the logic done when a Menu tree item is moved. Before the reimplementation, it was possible to move a menu tree item if the module it belonged to was in development or if there was any template module in development. The reimplementation did not take into account the templates, so from then on it has not been possible to moved menu tree nodes having a template in development.

To fix this, templates are taken into accout in the MenuTreeOperationManager class.

[1] https://issues.openbravo.com/view.php?id=25906 [^]

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/treeChecks/MenuTreeOperationManager.java
---
(0075763)
priyam (administrator)
2015-03-19 07:22

closing the issue, as the status changed to resolved when changeset transplanted to Q3
(0076303)
hgbot (developer)
2015-04-01 11:51

Repository: erp/backports/3.0PR15Q1.3
Changeset: 2b06105e638c31e50f3e68103f90aa1b5d5427bc
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 02 13:45:56 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/2b06105e638c31e50f3e68103f90aa1b5d5427bc [^]

Fixes bug 29097: A menu tree node can be moved with a template in development

When the Openbravo Trees were reimplemented [1], there was a problem reimplementing the logic done when a Menu tree item is moved. Before the reimplementation, it was possible to move a menu tree item if the module it belonged to was in development or if there was any template module in development. The reimplementation did not take into account the templates, so from then on it has not been possible to moved menu tree nodes having a template in development.

To fix this, templates are taken into accout in the MenuTreeOperationManager class.

[1] https://issues.openbravo.com/view.php?id=25906 [^]

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/treeChecks/MenuTreeOperationManager.java
---
(0076304)
priyam (administrator)
2015-04-01 11:52

closing the issue, as the status changed to resolved when changeset transplanted to 15Q1

- Issue History
Date Modified Username Field Change
2015-03-02 12:29 egoitz New Issue
2015-03-02 12:29 egoitz Assigned To => AugustoMauch
2015-03-02 12:29 egoitz Modules => Core
2015-03-02 12:29 egoitz Regression level => Production - Confirmed Stable
2015-03-02 12:29 egoitz Triggers an Emergency Pack => No
2015-03-02 12:38 AugustoMauch Regression date => 2014-03-05
2015-03-02 12:38 AugustoMauch Regression introduced in release => 3.0PR14Q2
2015-03-02 12:38 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/1ea574e6513ced497aaa66952a0eb3ff48525669 [^]
2015-03-02 12:39 AugustoMauch Relationship added caused by 0025906
2015-03-02 12:40 AugustoMauch Note Added: 0075074
2015-03-02 13:32 rafaroda Issue Monitored: rafaroda
2015-03-02 13:38 egoitz Severity major => minor
2015-03-02 13:42 AugustoMauch Issue Monitored: alostale
2015-03-02 13:42 AugustoMauch Review Assigned To => alostale
2015-03-02 13:47 hgbot Checkin
2015-03-02 13:47 hgbot Note Added: 0075086
2015-03-02 13:47 hgbot Status new => resolved
2015-03-02 13:47 hgbot Resolution open => fixed
2015-03-02 13:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f1360ce4b3d1861653f726626296ea743e16c52f [^]
2015-03-02 13:51 AugustoMauch Note Added: 0075087
2015-03-03 16:09 hudsonbot Checkin
2015-03-03 16:09 hudsonbot Note Added: 0075122
2015-03-09 09:39 alostale Note Added: 0075294
2015-03-09 09:39 alostale Status resolved => closed
2015-03-09 09:39 alostale Fixed in Version => 3.0PR15Q2
2015-03-19 07:17 hgbot Checkin
2015-03-19 07:17 hgbot Note Added: 0075762
2015-03-19 07:17 hgbot Status closed => resolved
2015-03-19 07:17 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/f1360ce4b3d1861653f726626296ea743e16c52f [^] => http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/17972a6e9e7ba9bb11b3e702c817cc839feacef4 [^]
2015-03-19 07:22 priyam Note Added: 0075763
2015-03-19 07:22 priyam Status resolved => closed
2015-04-01 11:51 hgbot Checkin
2015-04-01 11:51 hgbot Note Added: 0076303
2015-04-01 11:51 hgbot Status closed => resolved
2015-04-01 11:51 hgbot Fixed in SCM revision http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/17972a6e9e7ba9bb11b3e702c817cc839feacef4 [^] => http://code.openbravo.com/erp/backports/3.0PR15Q1.3/rev/2b06105e638c31e50f3e68103f90aa1b5d5427bc [^]
2015-04-01 11:52 priyam Note Added: 0076304
2015-04-01 11:52 priyam Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker