Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028980
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajorhave not tried2015-02-18 13:202015-02-23 05:11
ReporterjonalegriaesarteView Statuspublic 
Assigned Toumartirena 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision2bd79c1724d3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR15Q1SCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-10-07
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/2eb38d0f5418963af34d3ab7a5dbfec140cc662c [^]
Triggers an Emergency PackNo
Summary

0028980: Good receipt without a purchase order associated do not appear in create lines from functionality in purchase invoice

DescriptionGood receipt without a purchase order associated do not appear in create lines from functionality in purchase invoice. Due to that, the receipt can not be invoiced using create lines from functionality.
Steps To Reproduce- Create a good receipt with one line
- Complete it
- Create a purchase invoice header using the same vendor used in the good receipt
- Create lines from
- Good receipt created do not appear
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00275743.0PR15Q1 closedreinaldoguerra Invoice rule - Do not invoice not working in create lines from in purchase flow 

-  Notes
(0074651)
hgbot (developer)
2015-02-19 12:10

Repository: erp/devel/pi
Changeset: 2bd79c1724d32488421d6d98b9bb6a3599be7144
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Feb 18 16:44:45 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2bd79c1724d32488421d6d98b9bb6a3599be7144 [^]

Fixes bug 28980:Goods receipt without PO now appears in CreateLines in Purc. Inv

selectFromShipmentCombo method in Purchase Invoice window has been modified to exclude shipments coming from orders with Invoice Terms as Do not invoice. This is only done if a Purchase Order exits. AND o.InvoiceRule <> 'N' condition has been moved from where clause to left join clause

---
M src/org/openbravo/erpCommon/ad_actionButton/CreateFrom_Invoice_data.xsql
---
(0074652)
Sandrahuguet (developer)
2015-02-19 12:11

Code review + testing OK
(0074732)
umartirena (developer)
2015-02-20 14:32

Test Case has been added in testlink that covers this case:

http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8033 [^]
(0074789)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-18 13:20 jonalegriaesarte New Issue
2015-02-18 13:20 jonalegriaesarte Assigned To => Sandrahuguet
2015-02-18 13:20 jonalegriaesarte Modules => Core
2015-02-18 13:20 jonalegriaesarte Triggers an Emergency Pack => No
2015-02-18 13:38 heccam Issue Monitored: heccam
2015-02-18 16:35 umartirena Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/2eb38d0f5418963af34d3ab7a5dbfec140cc662c [^]
2015-02-18 17:28 Sandrahuguet Assigned To Sandrahuguet => umartirena
2015-02-18 17:31 Sandrahuguet Regression level => Production - QA Approved
2015-02-18 17:31 Sandrahuguet Regression date => 2014-10-07
2015-02-18 17:31 Sandrahuguet Regression introduced in release => 3.0PR15Q1
2015-02-18 17:32 Sandrahuguet Review Assigned To => Sandrahuguet
2015-02-19 12:10 hgbot Checkin
2015-02-19 12:10 hgbot Note Added: 0074651
2015-02-19 12:10 hgbot Status new => resolved
2015-02-19 12:10 hgbot Resolution open => fixed
2015-02-19 12:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2bd79c1724d32488421d6d98b9bb6a3599be7144 [^]
2015-02-19 12:10 Sandrahuguet Relationship added caused by 0027574
2015-02-19 12:11 Sandrahuguet Note Added: 0074652
2015-02-19 12:11 Sandrahuguet Status resolved => closed
2015-02-19 12:11 Sandrahuguet Fixed in Version => 3.0PR15Q2
2015-02-20 14:32 umartirena Note Added: 0074732
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074789


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker