Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028949
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-02-16 10:512015-02-23 05:11
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision19d74e4921d0
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-09-04
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/052f7ae68918 [^]
Triggers an Emergency PackNo
Summary

0028949: Business objects with document number can not be created from background processes

DescriptionBusiness objects with document number can not be created from background processes under some circumstances. When saving this type of entities using DAL, the SetDocumentNoHandler event handler is executed in order to properly set the document number properly.

Inside the handleEvent() method, if the following statement is executed:

String windowId = RequestContext.get().getRequestParameter("windowId");

the following exception is thrown:

java.lang.NullPointerException
    at org.openbravo.client.kernel.RequestContext.getRequestParameter(RequestContext.java:111)

This is because the getRequest() method of the RequestContext class is returning a null object and therefore the getRequest().getParameter(name) throws a null pointer exception
Steps To Reproduce1) Install the attached module, it contains a background process which generates a bank statement line.
2) Go to the [Process Request] window, create a new record for the "Bank Statement Creation" process, with timing "Run Immediately"
3) Schedule the process. Notice that the error is thrown in the log
TagsNo tags attached.
Attached Files? file icon com.openbravo.support.test-1.0.1.obx [^] (25,063 bytes) 2015-02-16 11:31

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028129 closedalostale API break for tomcat 7 support 
related to defect 0028955 closedalostale can't use EntityPersistenceEventObserver in jUnit test cases 
caused by defect 0027244 closedalostale Tomcat 7 is not supported 

-  Notes
(0074524)
hgbot (developer)
2015-02-16 17:40

Repository: erp/devel/pi
Changeset: 19d74e4921d09ee1ad171b98823b34b49ee2c0cc
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 16 17:39:33 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/19d74e4921d09ee1ad171b98823b34b49ee2c0cc [^]

fixed bug 28949: bg process can't insert DAL object having doc no column

  The problem was caused by SetDocumentNoHandler which assumed there was always
  a valid request.

  After changes to support tomcat 7, this was not the case of bg processes.

  The fix return null in this case rather than throwing a NPE.

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/RequestContext.java
---
(0074525)
alostale (developer)
2015-02-16 17:45

can't execute written test case till 0028955 is not fixed
(0074533)
AugustoMauch (developer)
2015-02-16 18:55

Code reviewed and verified in pi@19d74e4921d0
(0074765)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-16 10:51 caristu New Issue
2015-02-16 10:51 caristu Assigned To => AugustoMauch
2015-02-16 10:51 caristu Modules => Core
2015-02-16 10:51 caristu Triggers an Emergency Pack => No
2015-02-16 10:52 caristu Regression level => Production - QA Approved
2015-02-16 10:52 caristu Regression introduced in release => 3.0PR15Q1
2015-02-16 10:52 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/052f7ae68918 [^]
2015-02-16 10:53 caristu Description Updated View Revisions
2015-02-16 10:54 caristu Description Updated View Revisions
2015-02-16 10:57 caristu File Added: com.openbravo.support.test.tar.gz
2015-02-16 10:58 caristu Issue Monitored: networkb
2015-02-16 11:31 caristu File Deleted: com.openbravo.support.test.tar.gz
2015-02-16 11:31 caristu File Added: com.openbravo.support.test-1.0.1.obx
2015-02-16 15:24 alostale Relationship added related to 0028129
2015-02-16 15:32 alostale Assigned To AugustoMauch => alostale
2015-02-16 15:33 alostale Review Assigned To => AugustoMauch
2015-02-16 15:33 alostale Regression date => 2014-09-04
2015-02-16 17:40 hgbot Checkin
2015-02-16 17:40 hgbot Note Added: 0074524
2015-02-16 17:40 hgbot Status new => resolved
2015-02-16 17:40 hgbot Resolution open => fixed
2015-02-16 17:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/19d74e4921d09ee1ad171b98823b34b49ee2c0cc [^]
2015-02-16 17:41 alostale Relationship added caused by 0027244
2015-02-16 17:45 alostale Relationship added related to 0028955
2015-02-16 17:45 alostale Note Added: 0074525
2015-02-16 18:55 AugustoMauch Note Added: 0074533
2015-02-16 18:55 AugustoMauch Status resolved => closed
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074765


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker