Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028913
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-02-11 11:042015-02-23 05:11
ReporterngarciaView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision79cd62e8a4a4
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028913: Scale changes in numeric columns exported to Templates are not taken into account by ant update.database

DescriptionScale changes in numeric columns exported to Templates are not taken into account by ant update.database
Steps To ReproduceCreate a new template and set it as In Development
Change the size of the LINE column of C_COMMISSIONLINE table

ALTER TABLE c_commissionline ALTER COLUMN line type numeric(10,2)

Launch ant export.database and ant export.config.script
Check the change has been exported correctly to configscript.xml file
Launch ant update.database and check the column is changed to numeric(10,0) in DB
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
causes defect 0028960 closedAugustoMauch Change in dbsourcemanager has broken the int-upgrade-pgsql test 

-  Notes
(0074504)
hgbot (developer)
2015-02-16 12:50

Repository: erp/devel/dbsm-main
Changeset: b270758b1204f6c09ea1410ac93836e2c73462bd
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 16 12:45:58 2015 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/b270758b1204f6c09ea1410ac93836e2c73462bd [^]

fixed bug 28913: scale changes exported to configScript are not applied

  The problem was due to incorrect types in ColumnSizeChange, the type of the
  scale is determined by the parser based on the getter type, which was Integer,
  the setter was String so it was not found and therefore never set.

  Changed types to be consistent.

---
M src/org/apache/ddlutils/alteration/ColumnSizeChange.java
---
(0074505)
hgbot (developer)
2015-02-16 12:50

Repository: erp/devel/dbsm-main
Changeset: bbd42adccbc38d049c1ba23124c08354a7336c14
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 16 12:47:17 2015 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/bbd42adccbc38d049c1ba23124c08354a7336c14 [^]

related to bug 28913: added utility method to base test

---
M src-test/src/org/openbravo/dbsm/test/base/DbsmTest.java
---
(0074506)
hgbot (developer)
2015-02-16 12:50

Repository: erp/devel/dbsm-main
Changeset: 8f79c98f1a3fe2635d468780283c7f0fe2f69bc3
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 16 12:48:35 2015 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/8f79c98f1a3fe2635d468780283c7f0fe2f69bc3 [^]

related to bug 28913: added test cases

---
M src-test/src/org/openbravo/dbsm/test/model/ModelSuite.java
A src-test/model/scaleChanges/TEST.xml
A src-test/model/scaleChanges/TEST2.xml
A src-test/model/scaleChanges/configScript.xml
A src-test/src/org/openbravo/dbsm/test/model/NumericScaleChanges.java
---
(0074507)
hgbot (developer)
2015-02-16 12:52

Repository: erp/devel/pi
Changeset: e36c7483346a77b53c0b4349d53630aa46f536a6
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 16 12:52:25 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e36c7483346a77b53c0b4349d53630aa46f536a6 [^]

fixed bug 28913: scale changes exported to configScript are not applied

  The problem was due to incorrect types in ColumnSizeChange, the type of the
  scale is determined by the parser based on the getter type, which was Integer,
  the setter was String so it was not found and therefore never set.

  Changed types to be consistent.

---
M src-db/database/lib/dbsourcemanager.jar
---
(0074534)
AugustoMauch (developer)
2015-02-16 18:56

Reopened as it causes https://issues.openbravo.com/view.php?id=28960 [^]
(0074538)
hgbot (developer)
2015-02-17 08:02

Repository: erp/devel/dbsm-main
Changeset: bb40a338c4e8944cd471cd15d22ed5f2e74c8f00
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Feb 17 07:59:21 2015 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/bb40a338c4e8944cd471cd15d22ed5f2e74c8f00 [^]

fixed bug 28913: change type of scale from int to Integer

  To accept scale to be null

---
M src/org/apache/ddlutils/alteration/ColumnSizeChange.java
---
(0074539)
hgbot (developer)
2015-02-17 08:02

Repository: erp/devel/dbsm-main
Changeset: 6d065e08e906a998f82347db91649a0507948271
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Feb 17 08:00:34 2015 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/6d065e08e906a998f82347db91649a0507948271 [^]

related to bug 28913: test case covering NPE in try caused by previous change

---
M src-test/model/scaleChanges/TEST.xml
M src-test/model/scaleChanges/TEST2.xml
M src-test/src/org/openbravo/dbsm/test/model/NumericScaleChanges.java
---
(0074552)
hgbot (developer)
2015-02-17 13:21

Repository: erp/devel/pi
Changeset: 79cd62e8a4a4de4cfe39baf7128d81f0a5d9f266
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Feb 17 08:01:35 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/79cd62e8a4a4de4cfe39baf7128d81f0a5d9f266 [^]

fixed bug 28913: change type of scale from int to Integer

  To accept scale to be null

---
M src-db/database/lib/dbsourcemanager.jar
---
(0074610)
AugustoMauch (developer)
2015-02-18 16:47

Code reviewed and verified in pi@b5ce661abc2d
(0074762)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0074771)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-11 11:04 ngarcia New Issue
2015-02-11 11:04 ngarcia Assigned To => AugustoMauch
2015-02-11 11:04 ngarcia Modules => Core
2015-02-11 11:04 ngarcia Triggers an Emergency Pack => No
2015-02-11 11:05 ngarcia Issue Monitored: networkb
2015-02-11 11:08 ngarcia Target Version => 3.0PR15Q2
2015-02-16 09:55 alostale Assigned To AugustoMauch => alostale
2015-02-16 09:55 alostale Status new => scheduled
2015-02-16 09:55 alostale fix_in_branch => pi
2015-02-16 12:50 alostale Review Assigned To => AugustoMauch
2015-02-16 12:50 alostale fix_in_branch pi =>
2015-02-16 12:50 hgbot Checkin
2015-02-16 12:50 hgbot Note Added: 0074504
2015-02-16 12:50 hgbot Status scheduled => resolved
2015-02-16 12:50 hgbot Resolution open => fixed
2015-02-16 12:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/dbsm-main/rev/b270758b1204f6c09ea1410ac93836e2c73462bd [^]
2015-02-16 12:50 hgbot Checkin
2015-02-16 12:50 hgbot Note Added: 0074505
2015-02-16 12:50 hgbot Checkin
2015-02-16 12:50 hgbot Note Added: 0074506
2015-02-16 12:52 hgbot Checkin
2015-02-16 12:52 hgbot Note Added: 0074507
2015-02-16 12:52 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/dbsm-main/rev/b270758b1204f6c09ea1410ac93836e2c73462bd [^] => http://code.openbravo.com/erp/devel/pi/rev/e36c7483346a77b53c0b4349d53630aa46f536a6 [^]
2015-02-16 18:56 AugustoMauch Note Added: 0074534
2015-02-16 18:56 AugustoMauch Status resolved => new
2015-02-16 18:56 AugustoMauch Resolution fixed => open
2015-02-16 18:56 AugustoMauch Relationship added causes 0028960
2015-02-17 08:02 hgbot Checkin
2015-02-17 08:02 hgbot Note Added: 0074538
2015-02-17 08:02 hgbot Status new => resolved
2015-02-17 08:02 hgbot Resolution open => fixed
2015-02-17 08:02 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/e36c7483346a77b53c0b4349d53630aa46f536a6 [^] => http://code.openbravo.com/erp/devel/dbsm-main/rev/bb40a338c4e8944cd471cd15d22ed5f2e74c8f00 [^]
2015-02-17 08:02 hgbot Checkin
2015-02-17 08:02 hgbot Note Added: 0074539
2015-02-17 13:21 hgbot Checkin
2015-02-17 13:21 hgbot Note Added: 0074552
2015-02-17 13:21 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/dbsm-main/rev/bb40a338c4e8944cd471cd15d22ed5f2e74c8f00 [^] => http://code.openbravo.com/erp/devel/pi/rev/79cd62e8a4a4de4cfe39baf7128d81f0a5d9f266 [^]
2015-02-18 16:47 AugustoMauch Note Added: 0074610
2015-02-18 16:47 AugustoMauch Status resolved => closed
2015-02-18 16:47 AugustoMauch Fixed in Version => 3.0PR15Q2
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074762
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074771


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker