Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028896
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminoralways2015-02-09 16:112016-02-02 09:36
ReporterngarciaView Statuspublic 
Assigned Toumartirena 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revisionf0e8afa3c9fa
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - Confirmed Stable
Regression date2014-06-19
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^]
Triggers an Emergency PackNo
Summary

0028896: Purchase Invoices Supplier reference is not shown in the Payment Out Add Details pop-up

DescriptionPurchase Invoices Supplier reference is not shown in the Payment Out Add Details pop-up
Steps To ReproduceAs group admin role:
   Change the Purchase Invoice's Reference for Payment Description to Supplier Reference to F&B España - Región Norte (Organization - Information tab)
   Create a Purchase Invoice for that Organization
   Add a supplier reference to it and complete it
   Create a new Payment Out and check when adding details that the document no is shown in the Invoice No. column instead of the supplier reference
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0021802 closeddmiguelez Ability to show the supplier ref in manual window: “Add Payment Out” pop-up (matching statement for the financial account transa 
caused by feature request 0029391 closedSandrahuguet Add Payment refactor project 

-  Notes
(0074365)
hgbot (developer)
2015-02-12 08:52

Repository: erp/devel/pi
Changeset: f0e8afa3c9fa1780010f619e55612feb904d92ee
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Feb 11 19:01:27 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f0e8afa3c9fa1780010f619e55612feb904d92ee [^]

Fixes bug 28896: Purchase Invoices Supplier reference is shown in add payment.

A case has been added in AddPaymentOrderInvoicesTransformer to display the Supplier Reference instead of Invoice Number when is configured like that in Organization Info tab, only for Purchase Invoices

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/hqlinjections/AddPaymentOrderInvoicesTransformer.java
---
(0074451)
hgbot (developer)
2015-02-13 14:02

Repository: erp/devel/pi
Changeset: 77ed398f859c28516b002a26015685a50c6ea7c8
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Feb 12 13:35:34 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/77ed398f859c28516b002a26015685a50c6ea7c8 [^]

Related to bug 28896: Missing entry on group by clause

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/hqlinjections/AddPaymentOrderInvoicesTransformer.java
---
(0074540)
Sandrahuguet (developer)
2015-02-17 09:25

Code review + testing OK
(0074750)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0074755)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0075437)
umartirena (developer)
2015-03-11 09:13

The following test has been added in testlink:

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8131 [^]
(0083816)
hgbot (developer)
2016-02-02 09:36

Repository: tools/automation/int
Changeset: 88b524026c1904501bf52c280f40effb345c96f9
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Sep 30 17:34:04 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/88b524026c1904501bf52c280f40effb345c96f9 [^]

Related to issue 28896: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/data/generalsetup/enterprise/organization/InformationData.java
M src-test/com/openbravo/test/integration/erp/gui/financial/receivablespayables/transactions/AddPaymentProcess.java
M src-test/com/openbravo/test/integration/erp/gui/general/enterprise/organization/OrganizationTab.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/generalsetup/enterprise/Organization.java
A src-test/com/openbravo/test/integration/erp/gui/general/enterprise/organization/InformationTab.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression28896In.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression28896Out.java
---

- Issue History
Date Modified Username Field Change
2015-02-09 16:11 ngarcia New Issue
2015-02-09 16:11 ngarcia Assigned To => Sandrahuguet
2015-02-09 16:11 ngarcia Modules => Core
2015-02-09 16:11 ngarcia Triggers an Emergency Pack => No
2015-02-09 16:11 ngarcia Regression introduced in release => 3.0PR14Q3
2015-02-09 16:11 ngarcia Issue Monitored: networkb
2015-02-09 16:13 ngarcia Modules Core => Advanced Payables and Receivables Mngmt
2015-02-09 17:40 ngarcia Relationship added related to 0021802
2015-02-12 08:52 hgbot Checkin
2015-02-12 08:52 hgbot Note Added: 0074365
2015-02-12 08:52 hgbot Status new => resolved
2015-02-12 08:52 hgbot Resolution open => fixed
2015-02-12 08:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f0e8afa3c9fa1780010f619e55612feb904d92ee [^]
2015-02-12 08:53 Sandrahuguet Assigned To Sandrahuguet => umartirena
2015-02-13 14:02 hgbot Checkin
2015-02-13 14:02 hgbot Note Added: 0074451
2015-02-17 09:25 Sandrahuguet Review Assigned To => Sandrahuguet
2015-02-17 09:25 Sandrahuguet Note Added: 0074540
2015-02-17 09:25 Sandrahuguet Status resolved => closed
2015-02-17 09:25 Sandrahuguet Fixed in Version => 3.0PR15Q2
2015-02-17 11:10 Sandrahuguet Regression level => Production - Confirmed Stable
2015-02-17 11:10 Sandrahuguet Regression date => 2014-06-19
2015-02-17 11:10 Sandrahuguet Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^]
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074750
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074755
2015-03-11 09:13 umartirena Note Added: 0075437
2015-03-24 17:39 aferraz Relationship added caused by 0029391
2016-02-02 09:36 hgbot Checkin
2016-02-02 09:36 hgbot Note Added: 0083816


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker