Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028890
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-02-06 15:352015-02-23 05:11
ReporterVictorVillarView Statuspublic 
Assigned Toumartirena 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision3eb4cc225283
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-10-28
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c58e4664c86607f5de979a3dc177b70751d2044f [^]
Triggers an Emergency PackNo
Summary

0028890: Valued stock report is showing wrong qty after a manual cost adjustment

DescriptionValued stock report is showing wrong qty after a manual cost adjustment
Steps To ReproduceAs group admin role,
Create a new product
Introduce a new Costing register: EspaƱa - Cost: 5, warehouse: blank


Go to Goods REceipt:
select the product created before.
qty: 100
Complete it.

Go to Transactions tab of the Product window:
  select the transaction created before.
  Click on Manual Cost Adjustment button
Accounting date: today + 20 days
transaction cost: 550

Realise that the Costing background finishes succesfully.

Go to Valued Stock Report:
date: today
the values are correct

Launch again the Valued stock report:
date: Today+20days+1 day

Realise that the qty is 200, and it is wrong. It should be 100
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0027995 closeddmiguelez Valued Stock Report filtered by Transaction Cost Dates 
causes defect 0029111 closedumartirena Valued Stock Report does not display data while filtering by Product Category 

-  Notes
(0074350)
hgbot (developer)
2015-02-11 10:25

Repository: erp/devel/pi
Changeset: 3eb4cc22528301c45de404f17e32ad1bbd741cfe
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Feb 11 10:24:41 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3eb4cc22528301c45de404f17e32ad1bbd741cfe [^]

Fixes bug 28890: Valued Stock Report shows correct qty with cost adjustments.

---
M src/org/openbravo/erpCommon/ad_reports/ReportValuationStock_data.xsql
---
(0074351)
umartirena (developer)
2015-02-11 13:11

The previous changeset has been backed out because the query was failing in Oracle:

https://code.openbravo.com/erp/devel/pi/rev/5c0fb19ddc23 [^]
(0074450)
hgbot (developer)
2015-02-13 14:02

Repository: erp/devel/pi
Changeset: c3acd6c8dc33ba02445f373a0c0a03d054931f3c
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Feb 12 09:06:42 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c3acd6c8dc33ba02445f373a0c0a03d054931f3c [^]

Related to Bug 28890: Valued Stock Report shows correct qty with Cost Adjusments

The query is working in Postgres and in Oracle

---
M src/org/openbravo/erpCommon/ad_reports/ReportValuationStock_data.xsql
---
(0074577)
Sandrahuguet (developer)
2015-02-18 09:52

Code review + testing OK
(0074747)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0074754)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-06 15:35 VictorVillar New Issue
2015-02-06 15:35 VictorVillar Assigned To => Sandrahuguet
2015-02-06 15:35 VictorVillar Modules => Core
2015-02-06 15:35 VictorVillar Regression level => Production - QA Approved
2015-02-06 15:35 VictorVillar Regression date => 2014-10-28
2015-02-06 15:35 VictorVillar Regression introduced in release => 3.0PR14Q4
2015-02-06 15:35 VictorVillar Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/c58e4664c86607f5de979a3dc177b70751d2044f [^]
2015-02-06 15:35 VictorVillar Triggers an Emergency Pack => No
2015-02-06 15:35 VictorVillar Issue Monitored: networkb
2015-02-08 10:33 eintelau Issue Monitored: eintelau
2015-02-09 08:48 Sandrahuguet Assigned To Sandrahuguet => umartirena
2015-02-11 10:25 hgbot Checkin
2015-02-11 10:25 hgbot Note Added: 0074350
2015-02-11 10:25 hgbot Status new => resolved
2015-02-11 10:25 hgbot Resolution open => fixed
2015-02-11 10:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3eb4cc22528301c45de404f17e32ad1bbd741cfe [^]
2015-02-11 13:11 umartirena Note Added: 0074351
2015-02-13 14:02 hgbot Checkin
2015-02-13 14:02 hgbot Note Added: 0074450
2015-02-18 08:41 Sandrahuguet Review Assigned To => Sandrahuguet
2015-02-18 09:51 Sandrahuguet Note Added: 0074576
2015-02-18 09:51 Sandrahuguet Status resolved => closed
2015-02-18 09:51 Sandrahuguet Fixed in Version => 3.0PR15Q2
2015-02-18 09:52 Sandrahuguet Note Added: 0074577
2015-02-18 09:52 Sandrahuguet Note Deleted: 0074576
2015-02-18 13:07 dmitry_mezentsev Relationship added caused by 0027995
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074747
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074754
2015-03-03 16:06 dmitry_mezentsev Relationship added causes 0029111


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker