Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028870
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-02-05 12:272015-03-05 23:45
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision50e5345f5a57
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028870: Callouts are not executed when using a keyboard shortcut to create a new record under some circumnstances

DescriptionCallouts are not executed when using a keyboard shortcut to create a new record
Steps To Reproduce1) Go to the [Sales Invoice] window and create a new record in the header
2) Go to the [Lines] tab, create a new record in grid view, select a product and press Ctrl+F2 to open the record in form view
3) In form view, change the Invoiced Quantity field and move to another field. Notice that the callout is not executed (the LineNet Amount is not modified) and therefore is possible to save the record with wrong values
4) Notice that if you create now another record, following the same steps, the problem does not happen
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00283093.0PR15Q2 closedAugustoMauch Wrong behavior with Create One link and Switch to form view shortcut 

-  Notes
(0075044)
hgbot (developer)
2015-02-27 14:32

Repository: erp/devel/pi
Changeset: 50e5345f5a57b8c118800544ba6d9e239648fa9f
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Feb 27 14:30:15 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/50e5345f5a57b8c118800544ba6d9e239648fa9f [^]

Fixes bug 28870: Callouts are run when moving from grid to form with a shortcut

When a dynamic column is modified, a call is done to the FIC to run the callouts. The list of dynamic columns is stored in the form (in the view form and also in the grid edit form), and is loaded from the
 FIC response. For instance, when a record is created (either or grid or form view), a call is done to the FIC in NEW mode, and the dynamicCols list is initialized.

The cause of this issue is that it was possible to open a record in form view in an inconsistent state, having the form's dynamicCols list not set. In this state the callouts are not run. To get to this in
consistent state, the following steps should take place:
- The user creates a record in the grid (a call to the FIC in NEW mode is done, and the dynamicCols list of the grid edit form is initialized)
- Without saving, the user presses Ctrl+F2 to edit the record in form view. No FIC call is done (there is no need for it), so even though the record is shown in the form view, its dynamicCols list is not s
et. The callouts will not run until a call to the FIC is done (for instance by refreshing the record).

To fix this, the list of dynamicCols of the grid edit form is copied to the form view. This is done in the ksAction_EditInForm function, which is the function executed when the user presses Ctrl+F2 to move
 from the grid view to the form view.

The list of dynamic columns returned from the FIC to the grid view is the same as the one returned from the FIC to the form view, so it is not a problem is a dynamic columns is shown in the form view but n
ot in the grid view.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0075057)
alostale (developer)
2015-03-02 09:41

code reviewed

tested
(0075106)
hudsonbot (developer)
2015-03-02 20:31

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9d659cacae03 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-05 12:27 caristu New Issue
2015-02-05 12:27 caristu Assigned To => AugustoMauch
2015-02-05 12:27 caristu Modules => Core
2015-02-05 12:27 caristu Triggers an Emergency Pack => No
2015-02-05 12:29 caristu Summary Callouts are not executed when using a keyboard shortcut to create a new record => Callouts are not executed when using a keyboard shortcut to create a new record under some circumnstances
2015-02-05 12:29 caristu Relationship added related to 0028309
2015-02-05 12:37 caristu Issue Monitored: networkb
2015-02-09 10:10 alostale Status new => acknowledged
2015-02-18 10:29 alostale Assigned To AugustoMauch => dbaz
2015-02-18 10:29 alostale Status acknowledged => scheduled
2015-02-18 10:29 alostale fix_in_branch => pi
2015-02-23 13:30 jonalegriaesarte Target Version 3.0PR15Q2 => 3.0PR15Q3
2015-02-27 12:48 AugustoMauch Assigned To dbaz => AugustoMauch
2015-02-27 14:31 AugustoMauch Issue Monitored: alostale
2015-02-27 14:31 AugustoMauch Review Assigned To => alostale
2015-02-27 14:31 AugustoMauch fix_in_branch pi =>
2015-02-27 14:32 hgbot Checkin
2015-02-27 14:32 hgbot Note Added: 0075044
2015-02-27 14:32 hgbot Status scheduled => resolved
2015-02-27 14:32 hgbot Resolution open => fixed
2015-02-27 14:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/50e5345f5a57b8c118800544ba6d9e239648fa9f [^]
2015-03-02 09:41 alostale Note Added: 0075057
2015-03-02 09:41 alostale Status resolved => closed
2015-03-02 09:41 alostale Fixed in Version => 3.0PR15Q2
2015-03-02 20:31 hudsonbot Checkin
2015-03-02 20:31 hudsonbot Note Added: 0075106
2015-03-05 23:45 eugeni Issue Monitored: eugeni


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker