Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028859
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementminorhave not tried2015-02-04 12:592016-02-02 09:36
ReporterSandrahuguetView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision15b7c23eed15
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-06-19
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^]
Triggers an Emergency PackNo
Summary

0028859: Distribute amount in add payment does not work correctly with more than one negative invoice

DescriptionDistribute amount in add payment window does not work correctly with more than one negative invoice
Steps To ReproduceGo to Sales invoice and create one with this data:
  -Organization: F&B US, Inc.
  -Transaction Document: Reversed Sales Invoice
  -Business Partner: Healthy Food Supermarkets, Co.
  -Lines: Pear Juice, Qty: -80
Create another sales invoice
  -Organization: F&B US, Inc.
  -Transaction Document: Reversed Sales Invoice
  -Business Partner: Healthy Food Supermarkets, Co.
  -Lines: Energy Drink, Qty: -100
Select the first invoice created and click on Add Payment
Notice that both invoices have been selected and the expected payment is wrong
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0029391 closedSandrahuguet Add Payment refactor project 

-  Notes
(0074222)
hgbot (developer)
2015-02-05 11:49

Repository: erp/devel/pi
Changeset: 15b7c23eed157e9db9a612523876213396121266
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Wed Feb 04 18:10:21 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/15b7c23eed157e9db9a612523876213396121266 [^]

Fixed issue 28859: Distribute amount in add payment does not work properly

Distribute amount in add payment window does not work
correctly with more than one negative invoice

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0074225)
hgbot (developer)
2015-02-05 12:55

Repository: erp/devel/pi
Changeset: c4f2df763a97eb97bf083ab44b0bfd7c5e5c5b3c
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Thu Feb 05 12:51:09 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c4f2df763a97eb97bf083ab44b0bfd7c5e5c5b3c [^]

related to issue 28859 applied jsbeautifier

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0074227)
aferraz (developer)
2015-02-05 12:58

Code review + Testing ok
(0074256)
hudsonbot (developer)
2015-02-06 15:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/354f8004acc8 [^]
Maturity status: Test
(0074257)
hudsonbot (developer)
2015-02-06 15:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/354f8004acc8 [^]
Maturity status: Test
(0074348)
Sandrahuguet (developer)
2015-02-11 09:42

Test case added to testlink:

http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8039 [^]
(0083817)
hgbot (developer)
2016-02-02 09:36

Repository: tools/automation/int
Changeset: a71c3d48c41c755aeb4c0a1b9878e1f95c07d545
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Sep 30 20:34:49 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/a71c3d48c41c755aeb4c0a1b9878e1f95c07d545 [^]

Related to issue 28859: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/build.xml
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression28859In.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression28859Out.java
---

- Issue History
Date Modified Username Field Change
2015-02-04 12:59 Sandrahuguet New Issue
2015-02-04 12:59 Sandrahuguet Assigned To => Sandrahuguet
2015-02-04 12:59 Sandrahuguet Modules => Core
2015-02-04 12:59 Sandrahuguet Regression level => Production - Confirmed Stable
2015-02-04 12:59 Sandrahuguet Regression date => 2014-06-19
2015-02-04 12:59 Sandrahuguet Regression introduced in release => 3.0PR14Q3
2015-02-04 12:59 Sandrahuguet Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/f94f08e02e3a [^]
2015-02-04 12:59 Sandrahuguet Triggers an Emergency Pack => No
2015-02-05 11:49 hgbot Checkin
2015-02-05 11:49 hgbot Note Added: 0074222
2015-02-05 11:49 hgbot Status new => resolved
2015-02-05 11:49 hgbot Resolution open => fixed
2015-02-05 11:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/15b7c23eed157e9db9a612523876213396121266 [^]
2015-02-05 12:55 hgbot Checkin
2015-02-05 12:55 hgbot Note Added: 0074225
2015-02-05 12:58 aferraz Review Assigned To => aferraz
2015-02-05 12:58 aferraz Note Added: 0074227
2015-02-05 12:58 aferraz Status resolved => closed
2015-02-06 15:42 hudsonbot Checkin
2015-02-06 15:42 hudsonbot Note Added: 0074256
2015-02-06 15:42 hudsonbot Checkin
2015-02-06 15:42 hudsonbot Note Added: 0074257
2015-02-11 09:42 Sandrahuguet Note Added: 0074348
2015-03-24 17:40 aferraz Relationship added caused by 0029391
2016-02-02 09:36 hgbot Checkin
2016-02-02 09:36 hgbot Note Added: 0083817


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker