Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028823
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementminorhave not tried2015-01-30 13:152015-02-02 16:36
ReporterSandrahuguetView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision0ebb2a3181e5
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028823: API Change Request on performance c_order_post

DescriptionRelated to issue 27160: C_Order_Post poor performance

* API Break due to AD_EXTENSION_POINTS.DESCRIPTION column size changed from 255 to 2000

* API Break due to in table: M_STOCK_PROPOSED removed Foreign Key: AD_PINSTANCE_MSTOCKPROPOSED

Risk api-changes:
AD_PINSTANCE_MSTOCKPROPOSED column can store items that are not pinstance column, modules that use this column should be reviewed and updated. For example retail and pickinglist.
Steps To ReproduceLook at:
https://ci.openbravo.com/job/try-api/1235/consoleFull [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0073952)
dmitry_mezentsev (developer)
2015-01-30 14:29

Accepted.

Sandra,
Could you explain in the API change description in the wiki the reason we decided to go for it instead of "workarounding" it please.
(0073982)
hgbot (developer)
2015-02-02 12:30

Repository: erp/devel/api-checks
Changeset: 0ebb2a3181e5569dcd8149c94d43c417e63a36e2
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Mon Feb 02 12:27:30 2015 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/0ebb2a3181e5569dcd8149c94d43c417e63a36e2 [^]

Fixes issue 28823: API Change Request on performance c_order_post

---
M java/reference/java.japi.gz
M model/src-db/database/model/tables/AD_EXTENSION_POINTS.xml
M model/src-db/database/model/tables/M_STOCK_PROPOSED.xml
---
(0073992)
umartirena (developer)
2015-02-02 16:36

Code Review OK

- Issue History
Date Modified Username Field Change
2015-01-30 13:15 Sandrahuguet New Issue
2015-01-30 13:15 Sandrahuguet Assigned To => dmitry_mezentsev
2015-01-30 13:15 Sandrahuguet Modules => Core
2015-01-30 13:15 Sandrahuguet Triggers an Emergency Pack => No
2015-01-30 14:29 dmitry_mezentsev Note Added: 0073952
2015-01-30 14:30 dmitry_mezentsev Assigned To dmitry_mezentsev => Sandrahuguet
2015-02-02 12:30 hgbot Checkin
2015-02-02 12:30 hgbot Note Added: 0073982
2015-02-02 12:30 hgbot Status new => resolved
2015-02-02 12:30 hgbot Resolution open => fixed
2015-02-02 12:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/0ebb2a3181e5569dcd8149c94d43c417e63a36e2 [^]
2015-02-02 12:49 Sandrahuguet Description Updated View Revisions
2015-02-02 16:36 umartirena Review Assigned To => umartirena
2015-02-02 16:36 umartirena Note Added: 0073992
2015-02-02 16:36 umartirena Status resolved => closed
2015-02-02 16:36 umartirena Fixed in Version => pi


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker