Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028530
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-01-07 12:552015-02-04 20:33
ReporterpsanjuanView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision66dda4d779f9
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned Toumartirena
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028530: Not possible to enter a matched amount while clicking on second landed cost line in "Match LC Costs" window.

DescriptionNot possible to enter a matched amount while clicking on second landed cost line in "Match LC Costs" window.
Steps To ReproduceIn QA Testing Client navigate to Landed Cost window, create a new one for "Spain" organization dated on 07/01/2015.

Go to "Cost" tab and create a new record.
Select a landed cost type (of "Product" type), for instance "Transportation Cost", enter an Amount of 140.00
Create a new record, select same landed cost type and enter a new amount for instance of 50.00
Repeat above step 2 times more.

Go to "Receipt" tab and create a new record. Select a receipt in the field "Goods Receipt". Save.

Go back to the Landed Cost header and process and post landed cost document. For doing so costing background process should have been executed.

Go to Purchase Invoice window and create a new one. Select the product set as product landed cost type and enter an invoiced quatity = 1, Net Unit Price = 290. Complete the invoice.

In the line click on "Match LC Cost" process button. Filter by Landed Cost document number in the new window "Match LC Costs". Realize that 4 lines are shown.
Select first one and enter a matched amount. Go down and select second line.
Realize that it is not possible to enter a matched amount as that field is not editable.

Besides that once two lines have been selected and a matched amount entered if end-user press "Cancel" button to navigate somewhere else, it is not possible to re-open this window.

See also step by step process in the link attached below:

http://screencast.com/t/rPJuYgrRnEj0 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028565 closedumartirena not possible to filter by LineNo field in Match LC Cost 

-  Notes
(0073448)
hgbot (developer)
2015-01-13 09:59

Repository: erp/devel/pi
Changeset: 66dda4d779f9d895344bf074a35d82a3012e0607
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jan 13 09:58:54 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/66dda4d779f9d895344bf074a35d82a3012e0607 [^]

fixed bug 28530: can't enter 2nd matched amount in Match LC Costs

  When trying to edit the 2nd line in Match LC Costs, UI didn't allow to enter
  then matched amount field. After this failure it was needed to reload the
  whole page in order make it work again.

  The problem was in this situation validation for amount fields is triggered for
  all selected records including the new one where the amount is '', it was tried
  to be converted to BigDecimal resulting on a JavaScript exception thrown.

  Fix check if the amount has a value (or 0) to only sum it in this case.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/costing/ob-lc-matchfrominvoice.js
---
(0073465)
umartirena (developer)
2015-01-13 16:34

Code Review + Testing OK
(0074139)
hudsonbot (developer)
2015-02-04 20:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-01-07 12:55 psanjuan New Issue
2015-01-07 12:55 psanjuan Assigned To => dmiguelez
2015-01-07 12:55 psanjuan Web browser => Google Chrome
2015-01-07 12:55 psanjuan Modules => Core
2015-01-07 12:55 psanjuan Triggers an Emergency Pack => No
2015-01-07 13:17 psanjuan Web browser Google Chrome => Google Chrome
2015-01-07 13:17 psanjuan Steps to Reproduce Updated View Revisions
2015-01-07 13:53 jonalegriaesarte Web browser Google Chrome => Google Chrome
2015-01-07 14:16 psanjuan Web browser Google Chrome => Google Chrome
2015-01-07 14:16 psanjuan Assigned To dmiguelez => umartirena
2015-01-07 15:02 psanjuan Web browser Google Chrome => Google Chrome
2015-01-08 17:29 umartirena Web browser Google Chrome => Google Chrome
2015-01-08 17:29 umartirena Assigned To umartirena => AugustoMauch
2015-01-08 17:29 umartirena Category 04. Warehouse management => A. Platform
2015-01-08 17:29 umartirena Steps to Reproduce Updated View Revisions
2015-01-12 13:29 alostale Relationship added related to 0028565
2015-01-12 16:39 ngarcia Issue Monitored: ngarcia
2015-01-13 09:35 alostale Web browser Google Chrome => Google Chrome
2015-01-13 09:35 alostale Steps to Reproduce Updated View Revisions
2015-01-13 09:45 psanjuan Web browser Google Chrome => Google Chrome
2015-01-13 09:45 psanjuan Steps to Reproduce Updated View Revisions
2015-01-13 09:54 alostale Issue Monitored: dbaz
2015-01-13 09:54 alostale Review Assigned To => dbaz
2015-01-13 09:54 alostale Web browser Google Chrome => Google Chrome
2015-01-13 09:59 hgbot Checkin
2015-01-13 09:59 hgbot Note Added: 0073448
2015-01-13 09:59 hgbot Status new => resolved
2015-01-13 09:59 hgbot Resolution open => fixed
2015-01-13 09:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/66dda4d779f9d895344bf074a35d82a3012e0607 [^]
2015-01-13 09:59 alostale Assigned To AugustoMauch => alostale
2015-01-13 10:58 alostale Issue End Monitor: dbaz
2015-01-13 10:58 alostale Review Assigned To dbaz => umartirena
2015-01-13 10:58 alostale Web browser Google Chrome => Google Chrome
2015-01-13 16:34 umartirena Note Added: 0073465
2015-01-13 16:34 umartirena Status resolved => closed
2015-01-13 16:34 umartirena Fixed in Version => pi
2015-02-04 20:33 hudsonbot Checkin
2015-02-04 20:33 hudsonbot Note Added: 0074139


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker