Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028491
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminoralways2014-12-26 12:302015-01-22 18:34
ReporterjecharriView Statuspublic 
Assigned Tomarvintm 
PriorityimmediateResolutionfixedFixed in VersionRR15Q1
StatusclosedFix in branchFixed in SCM revisionfb8958661e2e
ProjectionnoneETAnoneTarget VersionRR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaaroncalero
Regression levelProduction - Confirmed Stable
Regression date2013-11-21
Regression introduced in releaseRR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0aa9ef48b337 [^]
Triggers an Emergency PackNo
Summary

0028491: Cash up report is not showing the correct numbers in withdrawal section

DescriptionCash up report is not showing the correct numbers in withdrawal section
Steps To Reproduce-Go to Web POS
-Create a ticket with total is 1200 and pay with cash
-Do a cash management and withdrawal 1000
-Do a return which amount is 100 in another payment method (this is only to see the error more clear)
-Finally do the cash up and check section "Total Withdrawals"

You will see that the cash management is positive 1000 but the return is with negative value, so total withdrawals is 900 instead of 1100.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028181 closedmarvintm In the Web POS cashup report, Withdrawals are added instead of subtracted to the expected amount 
causes defect 0028714 closedOrekaria Verified returns incorrectly update the cash balance 

-  Notes
(0072858)
hgbot (developer)
2014-12-29 17:19

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: fb8958661e2e4d21c9cee79de5c601a710f12ecb
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Dec 29 17:19:04 2014 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fb8958661e2e4d21c9cee79de5c601a710f12ecb [^]

Fixed issue 28491. Now totalReturns will be a positive amount, and therefore can now be summed correctly with cash management withdrawal amounts.

---
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---
(0072871)
hgbot (developer)
2014-12-30 10:11

Repository: tools/automation/pi-mobile
Changeset: cb332b6024af4da022c1119191212ef2efa54782
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Tue Dec 30 10:11:15 2014 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/cb332b6024af4da022c1119191212ef2efa54782 [^]

Related to issue 28491. Fixed automated test.

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I26806_CashupTotalNotShown.java
---
(0072872)
hgbot (developer)
2014-12-30 10:44

Repository: tools/automation/pi-mobile
Changeset: baa97e210dbf3ad1662be4324275137deecd1cb3
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Tue Dec 30 10:44:00 2014 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/baa97e210dbf3ad1662be4324275137deecd1cb3 [^]

Related to issue 28491. Fixed imports.

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I26806_CashupTotalNotShown.java
---
(0072885)
aaroncalero (developer)
2014-12-30 18:17

Tested and reviewed
(0073455)
hgbot (developer)
2015-01-13 12:44

Repository: tools/automation/pi-mobile
Changeset: b25a080146a29e758c316e8ec7b8f9be486d7701
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Tue Jan 13 11:51:40 2015 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/b25a080146a29e758c316e8ec7b8f9be486d7701 [^]

Related to issue 28491: Added new test 'I28491_WrongWithdrawalSection' to verify cashup withdrawals

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/suites/CashupSuite.java
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I28491_WrongWithdrawalSection.java
---
(0073709)
hgbot (developer)
2015-01-21 23:57

Repository: tools/automation/pi-mobile
Changeset: f7225b1285b2d821a5afbfb5050f5a916f178a14
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Wed Jan 21 21:52:17 2015 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/f7225b1285b2d821a5afbfb5050f5a916f178a14 [^]

Related to issue 28181 and issue 28491: Added the 'I28181_CashupWrongWithdrawalSummary' test

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/suites/CashupSuite.java
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I28181_CashupWrongWithdrawalSummary.java
---
(0073734)
hgbot (developer)
2015-01-22 18:34

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: bcc4856b6e9902dcabe3396aad449580a32b878a
Author: Rafa Alonso <rafael.alonso <at> openbravo.com>
Date: Thu Jan 22 17:09:16 2015 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/bcc4856b6e9902dcabe3396aad449580a32b878a [^]

Fixes issue 28714: The amount to be returned is substracted instead of added

The problem was that the fix for the issue 28491 inverted the sign of the return variable

---
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---

- Issue History
Date Modified Username Field Change
2014-12-26 12:30 jecharri New Issue
2014-12-26 12:30 jecharri Assigned To => marvintm
2014-12-26 12:30 jecharri Resolution time => 1420326000
2014-12-26 12:30 jecharri Triggers an Emergency Pack => No
2014-12-26 12:34 jecharri Priority urgent => immediate
2014-12-26 14:41 dmitry_mezentsev Severity major => minor
2014-12-29 17:03 marvintm Regression level => Production - Confirmed Stable
2014-12-29 17:03 marvintm Regression date => 2013-11-21
2014-12-29 17:03 marvintm Regression introduced in release => RR14Q2
2014-12-29 17:03 marvintm Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0aa9ef48b337 [^]
2014-12-29 17:19 hgbot Checkin
2014-12-29 17:19 hgbot Note Added: 0072858
2014-12-29 17:19 hgbot Status new => resolved
2014-12-29 17:19 hgbot Resolution open => fixed
2014-12-29 17:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fb8958661e2e4d21c9cee79de5c601a710f12ecb [^]
2014-12-30 10:11 hgbot Checkin
2014-12-30 10:11 hgbot Note Added: 0072871
2014-12-30 10:44 hgbot Checkin
2014-12-30 10:44 hgbot Note Added: 0072872
2014-12-30 18:16 aaroncalero Review Assigned To => aaroncalero
2014-12-30 18:17 aaroncalero Note Added: 0072885
2014-12-30 18:17 aaroncalero Status resolved => closed
2014-12-30 18:17 aaroncalero Fixed in Version => RR15Q1
2015-01-13 12:44 hgbot Checkin
2015-01-13 12:44 hgbot Note Added: 0073455
2015-01-21 15:58 Orekaria Relationship added related to 0028181
2015-01-21 23:57 hgbot Checkin
2015-01-21 23:57 hgbot Note Added: 0073709
2015-01-22 16:22 Orekaria Relationship added causes 0028714
2015-01-22 18:34 hgbot Checkin
2015-01-22 18:34 hgbot Note Added: 0073734


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker