Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028456
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2014-12-18 19:012015-02-04 20:34
ReportermaiteView Statuspublic 
Assigned ToSandrahuguet 
PriorityurgentResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision3bcb735ce063
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028456: Return orders does not appear in Create Invoices From Orders form

DescriptionReturn orders does not appear in Create Invoices From Orders form
Steps To Reproduce1. Register 'Return from Customer' document for any BP and Invoice Terms= immediate. Add line and process
2. Access Create Invoices From Orders form and realize that return order does not appear
3. If you navigate to RFC Order document type and unmark "return" checkbox you will be able to see your order in form
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
causes defect 0031376 closedRetail Retail Modules Return receipts created in WEBPOS are displayed in "Create Invoices from Orders" process 

-  Notes
(0073748)
hgbot (developer)
2015-01-23 12:04

Repository: erp/devel/pi
Changeset: 3bcb735ce063d4e431544f75f8c4ff68fe3d0736
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Fri Jan 23 12:02:44 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3bcb735ce063d4e431544f75f8c4ff68fe3d0736 [^]

Fixed bug 28456 Return orders does not appear in Create Invoices From Orders

It has been deleted return= 'N' filter in the query because the filter
it is not necessary.

---
M src/org/openbravo/erpCommon/ad_forms/GenerateInvoicesmanual_data.xsql
---
(0073749)
Sandrahuguet (developer)
2015-01-23 12:08

Test Plan:
1. Register 'Return from Customer' document for any BP and Invoice Terms= immediate. Add line and process
2. Access Create Invoices From Orders form and realize that return order appears
(0073751)
umartirena (developer)
2015-01-23 12:54

Code Review + Testing OK
(0074176)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-12-18 19:01 maite New Issue
2014-12-18 19:01 maite Assigned To => dmiguelez
2014-12-18 19:01 maite Modules => Core
2014-12-18 19:01 maite Triggers an Emergency Pack => No
2014-12-18 19:02 maite Assigned To dmiguelez => Sandrahuguet
2014-12-18 19:03 maite Issue Monitored: networkb
2014-12-18 20:16 heccam Issue Monitored: heccam
2015-01-22 01:10 reinaldoguerra Assigned To Sandrahuguet => reinaldoguerra
2015-01-22 01:10 reinaldoguerra Status new => scheduled
2015-01-23 11:53 Sandrahuguet Assigned To reinaldoguerra => Sandrahuguet
2015-01-23 12:04 hgbot Checkin
2015-01-23 12:04 hgbot Note Added: 0073748
2015-01-23 12:04 hgbot Status scheduled => resolved
2015-01-23 12:04 hgbot Resolution open => fixed
2015-01-23 12:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3bcb735ce063d4e431544f75f8c4ff68fe3d0736 [^]
2015-01-23 12:08 Sandrahuguet Note Added: 0073749
2015-01-23 12:54 umartirena Review Assigned To => umartirena
2015-01-23 12:54 umartirena Note Added: 0073751
2015-01-23 12:54 umartirena Status resolved => closed
2015-01-23 12:54 umartirena Fixed in Version => pi
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074176
2015-11-05 17:17 Orekaria Relationship added causes 0031376


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker