Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028426
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2014-12-16 18:262016-02-02 09:38
ReporterngarciaView Statuspublic 
Assigned Toumartirena 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision2ab32dc8dcea
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2012-03-26
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/cb5cc787ce23462f96bff2aa4780993597440bbb [^]
Triggers an Emergency PackNo
Summary

0028426: Cannot add a product to a commission if it doesn't have a sales price defined

DescriptionCannot add a product to a commission if it doesn't have a sales price defined
Steps To ReproduceAs group admin role:
   Create a product
   Add a purchase price to it
   Create a record in the Commission window
   Try to select the product in the Invoiced Product field and check it is not there.It should appear
   Add a sales price to it
   Check the product could be selected now
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00200893.0MP10 closedjecharri It is possible select a purchase price list in the product selector of sales invoice 
related to defect 0031396 scheduledmarkmm82 Wrong product selector is defined for Invoice Product field of Commission window 

-  Notes
(0073720)
AtulOpenbravo (developer)
2015-01-22 13:09

Test Plan
- Login as Group Admin role
- Create a product.
- Add a purchase price to it
- Create a record in the Commission window
- Try to select the product in the Invoiced Product field and check it appears.
(0073874)
hgbot (developer)
2015-01-28 19:17

Repository: erp/devel/pi
Changeset: 2ab32dc8dcea7381253e9fb94f66f8e5560b2e11
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Jan 28 09:31:53 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2ab32dc8dcea7381253e9fb94f66f8e5560b2e11 [^]

Fixes bug 28426: A product without sales price can be added to a commision

Filter expression of Product Selector has been changed for Commission window, to not to filter by Sales flag, displaying in this way Purchase and Sales Products.

---
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
---
(0073889)
Sandrahuguet (developer)
2015-01-29 11:27

Code review + testing OK
(0074193)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test
(0083821)
hgbot (developer)
2016-02-02 09:38

Repository: tools/automation/int
Changeset: 3fcc617d349718bb85607ea05d48eb98b62b0f9b
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Oct 07 10:24:45 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/3fcc617d349718bb85607ea05d48eb98b62b0f9b [^]

Related to issue 28426: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/modules/client/application/navigationbarcomponents/gui/Menu.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/PRO_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/sales/testsuites/SAL_Regressions/SAL_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/sales/testsuites/SAL_Regressions/build.xml
A src-test/com/openbravo/test/integration/erp/gui/sales/setup/CommissionTab.java
A src-test/com/openbravo/test/integration/erp/gui/sales/setup/CommissionWindow.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/PRORegression28426.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/sales/testsuites/SAL_Regressions/SALRegression28426.java
A src-test/com/openbravo/test/integration/erp/testscripts/sales/setup/Commission.java
A src-test/com/openbravo/test/integration/erp/testscripts/sales/setup/CommissionClassicScript.java
A src-test/com/openbravo/test/integration/erp/testscripts/sales/setup/CommissionScript.java
---

- Issue History
Date Modified Username Field Change
2014-12-16 18:26 ngarcia New Issue
2014-12-16 18:26 ngarcia Assigned To => AtulOpenbravo
2014-12-16 18:26 ngarcia Modules => Core
2014-12-16 18:26 ngarcia Triggers an Emergency Pack => No
2014-12-16 18:27 ngarcia Relationship added caused by 0020168
2014-12-16 18:31 ngarcia Issue Monitored: networkb
2015-01-05 10:33 ngarcia Regression level => Production - Confirmed Stable
2015-01-05 10:33 ngarcia Regression introduced in release => 3.0MP11
2015-01-05 10:36 ngarcia Regression introduced in release 3.0MP11 =>
2015-01-22 03:03 AtulOpenbravo Status new => scheduled
2015-01-22 03:03 AtulOpenbravo fix_in_branch => pi
2015-01-22 13:09 AtulOpenbravo Review Assigned To => Sandrahuguet
2015-01-22 13:09 AtulOpenbravo Regression date => 2012-03-26
2015-01-22 13:09 AtulOpenbravo Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/cb5cc787ce23462f96bff2aa4780993597440bbb [^]
2015-01-22 13:09 AtulOpenbravo Note Added: 0073720
2015-01-22 13:09 AtulOpenbravo fix_in_branch pi =>
2015-01-22 13:09 AtulOpenbravo Relationship added caused by 0020089
2015-01-22 13:10 AtulOpenbravo Relationship deleted caused by 0020168
2015-01-28 19:17 hgbot Checkin
2015-01-28 19:17 hgbot Note Added: 0073874
2015-01-28 19:17 hgbot Status scheduled => resolved
2015-01-28 19:17 hgbot Resolution open => fixed
2015-01-28 19:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2ab32dc8dcea7381253e9fb94f66f8e5560b2e11 [^]
2015-01-29 11:27 Sandrahuguet Note Added: 0073889
2015-01-29 11:27 Sandrahuguet Status resolved => closed
2015-01-29 11:27 Sandrahuguet Fixed in Version => 3.0PR15Q2
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074193
2015-02-11 09:16 Sandrahuguet Assigned To AtulOpenbravo => umartirena
2015-11-06 15:12 ngarcia Relationship added related to 0031396
2016-02-02 09:38 hgbot Checkin
2016-02-02 09:38 hgbot Note Added: 0083821


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker