Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028423
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2014-12-16 15:202014-12-19 11:29
ReporterumartirenaView Statuspublic 
Assigned Toumartirena 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionffe4c941c96f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028423: API Break on Cost Adjustments Project (try-api 985)

DescriptionAPI Break due to the following data has been removed from Application Dictionary:
 * Report and Process: "Validate Costing Rule"
 * AD Implementation Mapping: "org.openbravo.costing.CostingRuleProcess" classname

This process has been re-implemented in the Cost Adjustments project, and it has been defined in "Process Definition" window, in order to use all new capabilities that this processes offer. The name of the new process is also "Validate Costing Rule".

The risk of this change is low.
Steps To ReproduceLook at: https://ci.openbravo.com/job/try-api/996/consoleFull [^]

[checkAPI] 11955 ERROR -
 [checkAPI]
 [checkAPI] 11957 ERROR - +++++++++++++++++++++++++++++++++++++++++++++++++++
 [checkAPI] 11958 ERROR - Errors in API data validation
 [checkAPI] 11959 ERROR - +++++++++++++++++++++++++++++++++++++++++++++++++++
 [checkAPI] 11960 ERROR - Removed row from table AD_MODEL_OBJECT - ID: 6E4B444F00A742AD86F4C8E013884933
 [checkAPI] 11961 ERROR - Removed row from table AD_PROCESS - ID: A269DCA4DE114E438695B66E166999B4
 [checkAPI] 11962 ERROR -
 [checkAPI]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028289 closedumartirena [Costing] No cost calculated in case costing rule does not have a starting date nor a fix backdated from date 
related to defect 0029127 closedalostale PR14Q3 -> PR14Q4 update can fail activating FKs 

-  Notes
(0072597)
dmitry_mezentsev (developer)
2014-12-17 10:17

Unai,

Could you explain a bit "The risk of this change is low.".
Thanks.
(0072601)
umartirena (developer)
2014-12-17 10:25
edited on: 2014-12-17 13:36

Dmitry,

I mean that the risk of the API Change is low because the process that is executed behind is still the same, so if somebody is using it in its own module, it should be OK. The new process definition (because process definition implements different class) just calls the old one.

(0072613)
dmitry_mezentsev (developer)
2014-12-17 11:26

Approved.
(0072676)
hgbot (developer)
2014-12-17 20:25

Repository: erp/devel/api-checks
Changeset: ffe4c941c96f81433469575ee7ff629445827567
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Dec 17 20:24:08 2014 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/ffe4c941c96f81433469575ee7ff629445827567 [^]

Fixes Issue 28423: API Break on Cost Adjustments Project (try-api 985)

---
M java/reference/java.japi.gz
M model/src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M model/src-db/database/sourcedata/AD_PROCESS.xml
---
(0072726)
Sandrahuguet (developer)
2014-12-19 11:29

Verified

- Issue History
Date Modified Username Field Change
2014-12-16 15:20 umartirena New Issue
2014-12-16 15:20 umartirena Assigned To => dmiguelez
2014-12-16 15:20 umartirena Modules => Core
2014-12-16 15:20 umartirena Triggers an Emergency Pack => No
2014-12-17 10:17 dmitry_mezentsev Note Added: 0072597
2014-12-17 10:25 umartirena Note Added: 0072601
2014-12-17 10:48 dmitry_mezentsev Relationship added related to 0028289
2014-12-17 11:26 dmitry_mezentsev Note Added: 0072613
2014-12-17 11:26 dmitry_mezentsev Assigned To dmiguelez => umartirena
2014-12-17 13:36 umartirena Note Edited: 0072601 View Revisions
2014-12-17 20:17 umartirena Steps to Reproduce Updated View Revisions
2014-12-17 20:25 hgbot Checkin
2014-12-17 20:25 hgbot Note Added: 0072676
2014-12-17 20:25 hgbot Status new => resolved
2014-12-17 20:25 hgbot Resolution open => fixed
2014-12-17 20:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/ffe4c941c96f81433469575ee7ff629445827567 [^]
2014-12-19 11:29 Sandrahuguet Review Assigned To => Sandrahuguet
2014-12-19 11:29 Sandrahuguet Note Added: 0072726
2014-12-19 11:29 Sandrahuguet Status resolved => closed
2015-03-05 13:14 alostale Relationship added related to 0029127


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker