Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028386
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-12-11 13:432014-12-30 23:28
ReporterinigosanchezView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision41237421d072
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2014-07-14
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb [^]
Triggers an Emergency PackNo
Summary

0028386: FK filter dropdown show only previously selected elements when it is reopened

DescriptionSelectors are not filtering properly when collapsed and reopen the dropdown.
Steps To Reproduce1) Go to the Sales order window and clear filters.
2) Open dropdown and select filter: F&B Spain - Region Sur.
3) Then, collapsed and reopen dropdown. Realize that you can not see the other organizations to filtering.
4) Now, blur the filter and select "Document No" and realize that a reload is done. No select any filter.
5) Reopen organization dropdown and you can see all the organizations.

http://screencast.com/t/39zGXqjaKGUH [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0026700 closedshankarb Wrong request after filtering in a field with combo and do blur in other field in pick and edit windows 
caused by design defect 0025211 closedAugustoMauch Filter by selected value in FK uses identifier instead of ID 
related to defect 0028388 closedalostale Unexpected behavior after reopen "Transaction Document" dropdown selector with selected filter. 

-  Notes
(0072458)
alostale (developer)
2014-12-12 15:29
edited on: 2014-12-16 10:08

In the reload of step 4, filter criteria is changed from filtering by ID to identifier iEquals

(0072553)
hgbot (developer)
2014-12-16 14:58

Repository: erp/devel/pi
Changeset: c6764c78201bd1efd5bcf503561460b3bdf12e40
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Dec 16 14:57:28 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c6764c78201bd1efd5bcf503561460b3bdf12e40 [^]

fixed bug 28386: FK filter dropdown hides elements when it's reopened

  When a FK filter drop down was reopened after having selected an element, it
  only displayed that element in the list.

  Few things have been fixed:
    * When requesting datasource for FK drop down, the same criteria used in the
      grid is used, but removing that drop down criterion. This was not properly
      done for direct FK selection
    * == element before the identifier was some times removed
    * When reopening a drop down having an element selected, the criteria was changed
      from equals with FK value to iEquals with identifier value

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---
(0072555)
alostale (developer)
2014-12-16 15:00

Tested with different filter combinations: single item selected, multiple items, in one or many FK filters both in standard and P&E windows
(0072635)
dbaz (developer)
2014-12-17 13:19

In "Sales Order" window using the mouse:
* Open the "Business Partner" dropdown list
* Select "F&B España - Región Sur"
* Close the combo
* Open the combo again. Notice that the "F&B España - Región Sur" item is selected (that's ok)
* Close the combo
* Open the combo again. Notice that the "F&B España - Región Sur" item is NOT selected (that's wrong)

Tested with Chrome and Firefox
(0072660)
hgbot (developer)
2014-12-17 17:15

Repository: erp/devel/pi
Changeset: 41237421d0722987b59c0b22193f363fa6c4ae44
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Dec 17 17:14:25 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/41237421d0722987b59c0b22193f363fa6c4ae44 [^]

fixed bug 28386: keep selected item when reopening FK drop down

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---
(0072757)
dbaz (developer)
2014-12-22 10:40

Fixed at reviewed @ changeset 25583 - bd07f4b5032c
(0072812)
hgbot (developer)
2014-12-24 11:09

Repository: tools/automation/int
Changeset: 335263f89e3e4b98cfea556c6de332082322ec42
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Dec 19 15:27:46 2014 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/335263f89e3e4b98cfea556c6de332082322ec42 [^]

related to bug 28386: FK filter dropdown show only previously selected elements

  added selenium test case

---
M src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/GridSuite.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/build.xml
A src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/GRD0210_ReopenFilterDropDown.java
---
(0073222)
hudsonbot (developer)
2014-12-30 23:27

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0073237)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-12-11 13:43 inigosanchez New Issue
2014-12-11 13:43 inigosanchez Assigned To => alostale
2014-12-11 13:43 inigosanchez Modules => Core
2014-12-11 13:43 inigosanchez Regression date => 2014-07-14
2014-12-11 13:43 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/fab9b7248bbb [^]
2014-12-11 13:43 inigosanchez Triggers an Emergency Pack => No
2014-12-12 15:28 alostale Steps to Reproduce Updated View Revisions
2014-12-12 15:29 alostale Note Added: 0072458
2014-12-12 15:40 alostale Relationship added related to 0028388
2014-12-16 08:23 alostale Relationship added caused by 0025211
2014-12-16 08:24 alostale Regression level => Packaging and release
2014-12-16 08:24 alostale Regression introduced in release => pi
2014-12-16 10:05 alostale Relationship added related to 0026700
2014-12-16 10:08 alostale Note Edited: 0072458 View Revisions
2014-12-16 14:51 alostale Review Assigned To => dbaz
2014-12-16 14:51 alostale Summary Selectors are not filtering properly when collapsed and reopen the dropdown. => FK filter dropdown show only previously selected elements when it is reopened
2014-12-16 14:58 hgbot Checkin
2014-12-16 14:58 hgbot Note Added: 0072553
2014-12-16 14:58 hgbot Status new => resolved
2014-12-16 14:58 hgbot Resolution open => fixed
2014-12-16 14:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c6764c78201bd1efd5bcf503561460b3bdf12e40 [^]
2014-12-16 15:00 alostale Note Added: 0072555
2014-12-17 13:19 dbaz Note Added: 0072635
2014-12-17 13:19 dbaz Status resolved => new
2014-12-17 13:19 dbaz Resolution fixed => open
2014-12-17 17:15 hgbot Checkin
2014-12-17 17:15 hgbot Note Added: 0072660
2014-12-17 17:15 hgbot Status new => resolved
2014-12-17 17:15 hgbot Resolution open => fixed
2014-12-17 17:15 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/c6764c78201bd1efd5bcf503561460b3bdf12e40 [^] => http://code.openbravo.com/erp/devel/pi/rev/41237421d0722987b59c0b22193f363fa6c4ae44 [^]
2014-12-22 10:40 dbaz Note Added: 0072757
2014-12-22 10:40 dbaz Status resolved => closed
2014-12-22 10:40 dbaz Fixed in Version => 3.0PR15Q4
2014-12-23 15:53 dbaz Fixed in Version 3.0PR15Q4 => 3.0PR15Q1
2014-12-24 11:09 hgbot Checkin
2014-12-24 11:09 hgbot Note Added: 0072812
2014-12-30 23:27 hudsonbot Checkin
2014-12-30 23:27 hudsonbot Note Added: 0073222
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073237


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker