Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028283
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupminoralways2014-11-26 06:562015-03-09 16:15
ReporterpramakrishnanView Statuspublic 
Assigned Toaferraz 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revisionbd976701a17f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028283: API Change Request : Change DUNS field in Organization Information to Non Mandatory

DescriptionRelated to issue 0027313, D-U-N-S number should not be mandatory, because is something that is not used in all the goberments/companies. Now we are adding (in demo data, F&B) ? character when the number is not needed, but this does not make sense. If the field is not needed, it should be empty.

Risk Analysis:
The risk is minor because by default in trigger, the value for DUNS field is set as '?'. So in case some project is still using this, it will not be affected.
Steps To ReproduceD-U-N-S number should not be mandatory, because is something that is not used in all the goberments/companies. Now we are adding (in demo data, F&B) ? character when the number is not needed, but this does not make sense. If the field is not needed, it should be empty.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00273133.0PR15Q2 closedreinaldoguerra D-U-N-S number should not be mandatory 

-  Notes
(0072019)
dmitry_mezentsev (developer)
2014-11-26 10:58

Pandee,

>Risk Analysis:
>The risk is minor because by default in trigger, the value for DUNS field is >set as '?'. So in case some project is still using this, it will not be >affected.

Do we need this trigger then? I mean if we make this field not mandatory why to have a trigger that creates "useless" data. Only for backward compatibility? I would prefer to check if we use this field inside Openbravo and if we do not use it - most probably others won´t or at least should rise proper warning. Could you check it out please?

Btw you are talking about DUNS field but should we do the same for Tax ID? Could you explore it inside the team please?
(0075189)
aferraz (developer)
2015-03-05 11:18

Trigger will be modified to avoid set '?' to DUNS field.

We have reviewed all modules from the forge and there is no risk from any one.

TaxID field change will be more risky because it is used in models of "Professional Localization pack Spain".
(0075234)
dmitry_mezentsev (developer)
2015-03-06 10:57

>Trigger will be modified to avoid set '?' to DUNS field.
>We have reviewed all modules from the forge and there is no risk from any one.
OK, thanks, Approved.

>TaxID field change will be more risky because it is used in models of "Professional Localization pack Spain".
I still think that it makes sense to do it but because it is a different issue I reported it for the future, https://issues.openbravo.com/view.php?id=29167 [^]
(0075304)
hgbot (developer)
2015-03-09 11:11

Repository: erp/devel/api-checks
Changeset: bd976701a17f073d6d324aeac2450e7dfea2d18b
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Mar 09 11:02:27 2015 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/bd976701a17f073d6d324aeac2450e7dfea2d18b [^]

Fixes issue 28283: API Change Request DUNS field in AD_ORGINFO to non mandatory

---
M model/src-db/database/model/tables/AD_ORGINFO.xml
M model/src-db/database/sourcedata/AD_COLUMN.xml
---
(0075320)
Sandrahuguet (developer)
2015-03-09 16:15

Verified

- Issue History
Date Modified Username Field Change
2014-11-26 06:56 pramakrishnan New Issue
2014-11-26 06:56 pramakrishnan Assigned To => dmitry_mezentsev
2014-11-26 06:56 pramakrishnan Modules => Core
2014-11-26 06:56 pramakrishnan Triggers an Emergency Pack => No
2014-11-26 06:57 pramakrishnan Relationship added blocks 0027313
2014-11-26 10:58 dmitry_mezentsev Note Added: 0072019
2015-03-05 11:18 aferraz Note Added: 0075189
2015-03-06 10:57 dmitry_mezentsev Note Added: 0075234
2015-03-06 10:58 dmitry_mezentsev Assigned To dmitry_mezentsev => pramakrishnan
2015-03-09 11:11 hgbot Checkin
2015-03-09 11:11 hgbot Note Added: 0075304
2015-03-09 11:11 hgbot Status new => resolved
2015-03-09 11:11 hgbot Resolution open => fixed
2015-03-09 11:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/bd976701a17f073d6d324aeac2450e7dfea2d18b [^]
2015-03-09 16:13 Sandrahuguet Assigned To pramakrishnan => aferraz
2015-03-09 16:15 Sandrahuguet Review Assigned To => Sandrahuguet
2015-03-09 16:15 Sandrahuguet Note Added: 0075320
2015-03-09 16:15 Sandrahuguet Status resolved => closed
2015-03-09 16:15 Sandrahuguet Fixed in Version => 3.0PR15Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker