Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028226
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2014-11-19 16:592016-02-02 09:40
ReportermaiteView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision9f90ea7d41b0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Topramakrishnan
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-01-08
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d7f5fe16e7480baf9258c2d5bb6caf5e33bafcf9 [^]
Triggers an Emergency PackNo
Summary

0028226: Is not possible to Void a shipment related with an order and containing a negative line

DescriptionIs not possible to Void a shipment related with an order and containing a negative line
Steps To Reproduce1. Register Sales Order. Add one positive line for one product and another negative line for another product. Process Order
2. Register Goods Shipment using Create Lines FRom process and selecting previous lines. Process
3. Try to Void shipment and following error will be raised referencing your negative line "Error:
Movement Quantity is greater than the Ordered Quantity In lines 20"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00254003.0PR14Q2 closedAtulOpenbravo More quantity than the ordered can be shipped 

-  Notes
(0071839)
AtulOpenbravo (developer)
2014-11-20 06:55

Test Plan
- Create Sales Order. Add one positive quantity line for one product and another negative quantity line for another product. Book the Order.
- Create Goods Shipment using Create Lines From process and selecting previous lines. Process the Shipment.
- Void shipment created in last previous step.
Reversed Shipment document is created successfully.
(0071874)
hgbot (developer)
2014-11-21 11:07

Repository: erp/devel/pi
Changeset: 9f90ea7d41b03a2a966d454d16d8055aaac0a652
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Nov 20 11:48:06 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/9f90ea7d41b03a2a966d454d16d8055aaac0a652 [^]

Fixes Issue 28226:Is not possible to Void a shipment related with an order
and containing a negative line

A check to avoid MovementQtyCheck for Reversed Document is provided.

---
M src-db/database/model/functions/M_INOUT_POST.xml
---
(0071877)
pramakrishnan (developer)
2014-11-21 11:23

Code Review + Testing - OK.
(0073121)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0083826)
hgbot (developer)
2016-02-02 09:40

Repository: tools/automation/int
Changeset: a944561bd049e7c9c5707a703edbe03e2c6f6c77
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Nov 19 11:15:01 2015 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/a944561bd049e7c9c5707a703edbe03e2c6f6c77 [^]

Related to issue 28226: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/gui/procurement/transactions/goodsreceipt/CreateLinesFromPopUp.java
M src-test/com/openbravo/test/integration/erp/gui/procurement/transactions/goodsreceipt/GoodsReceiptHeaderTab.java
M src-test/com/openbravo/test/integration/erp/gui/sales/transactions/goodsshipment/CreateLinesFromPopUp.java
M src-test/com/openbravo/test/integration/erp/gui/sales/transactions/goodsshipment/GoodsShipmentHeaderTab.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/PRO_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/sales/testsuites/SAL_Regressions/SAL_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/sales/testsuites/SAL_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/SmokeTabScript.java
M src-test/com/openbravo/test/integration/erp/testscripts/procurement/transactions/GoodsReceipt.java
M src-test/com/openbravo/test/integration/erp/testscripts/sales/transactions/GoodsShipment.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/PRORegression28226.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/sales/testsuites/SAL_Regressions/SALRegression28226.java
---

- Issue History
Date Modified Username Field Change
2014-11-19 16:59 maite New Issue
2014-11-19 16:59 maite Assigned To => dmiguelez
2014-11-19 16:59 maite Modules => Core
2014-11-19 16:59 maite Triggers an Emergency Pack => No
2014-11-19 16:59 maite Issue Monitored: networkb
2014-11-19 17:11 heccam Issue Monitored: heccam
2014-11-19 17:29 Sandrahuguet Assigned To dmiguelez => AtulOpenbravo
2014-11-20 06:55 AtulOpenbravo Status new => scheduled
2014-11-20 06:55 AtulOpenbravo Note Added: 0071839
2014-11-20 06:55 AtulOpenbravo fix_in_branch => pi
2014-11-20 10:08 AtulOpenbravo Review Assigned To => pramakrishnan
2014-11-20 10:08 AtulOpenbravo Regression date => 2014-01-08
2014-11-20 10:08 AtulOpenbravo Regression introduced in release => 3.0PR14Q2
2014-11-20 10:08 AtulOpenbravo Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d7f5fe16e7480baf9258c2d5bb6caf5e33bafcf9 [^]
2014-11-20 10:08 AtulOpenbravo fix_in_branch pi =>
2014-11-20 10:09 AtulOpenbravo Regression level => Production - Confirmed Stable
2014-11-20 16:27 dmitry_mezentsev Relationship added caused by 0025400
2014-11-21 11:07 hgbot Checkin
2014-11-21 11:07 hgbot Note Added: 0071874
2014-11-21 11:07 hgbot Status scheduled => resolved
2014-11-21 11:07 hgbot Resolution open => fixed
2014-11-21 11:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9f90ea7d41b03a2a966d454d16d8055aaac0a652 [^]
2014-11-21 11:23 pramakrishnan Note Added: 0071877
2014-11-21 11:23 pramakrishnan Status resolved => closed
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073121
2016-02-02 09:40 hgbot Checkin
2016-02-02 09:40 hgbot Note Added: 0083826


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker