Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028169
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-11-13 18:362014-12-30 23:26
ReporterjecharriView Statuspublic 
Assigned ToNaroaIriarte 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision46e4ef62c015
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028169: Read only logic does not work with Image reference columns

DescriptionRead only logic does not work with Image reference columns
Steps To Reproduce-Login as system
-Go to "Windows, tabs and fields"
-Select the Product windiow
-Select the Header tab
-Mark image field as read only
-Login as Admin role
-Go to product window and verify that you can delete and insert new images
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028170 closedAugustoMauch Images are not deleted when you delete from the UI 

-  Notes
(0071918)
hgbot (developer)
2014-11-24 09:42

Repository: erp/devel/pi
Changeset: 46e4ef62c01509bf71ef74d0338704f013e9e609
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Mon Nov 24 08:56:16 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/46e4ef62c01509bf71ef74d0338704f013e9e609 [^]

Fixed issue 28169: readOnly and readOnly logic fails in images.

In image fields it did not work readOnly property nor readOnly logic. When readOnly was chosen in the image field, it was possible
to delete or upload it. When readOnly logic was active it was possible to do both things too.
The problem was in the ob-formitem-image.js.
For fixing the first problem I have changed the word "readOnly" for "disabled" in a condition, because the logic was not taken well before.
Now, when the checkbox readOnly is chosen, it is not possible to delete nor upload an image, as expected.
For fixing the second problem I have overwritten the "setDisbaled" function in this subclass. Now, when an obect is set as disabled, the delete and upload
buttons will be hidden, so, when an image is set as readOnly whit a readOnly logic condition, now those buttons are not visible.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-image.js
---
(0071919)
alostale (developer)
2014-11-24 09:43

code reviewed

tested:
-Field is set as read only
-Read only logic on the field
-Tab is set as read only
(0073126)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-13 18:36 jecharri New Issue
2014-11-13 18:36 jecharri Assigned To => AugustoMauch
2014-11-13 18:36 jecharri Web browser => Google Chrome
2014-11-13 18:36 jecharri Modules => Core
2014-11-13 18:36 jecharri Triggers an Emergency Pack => No
2014-11-13 18:38 jecharri Issue cloned 0028170
2014-11-13 18:38 jecharri Relationship added related to 0028170
2014-11-20 09:32 alostale Assigned To AugustoMauch => inigosanchez
2014-11-20 10:15 AugustoMauch Assigned To inigosanchez => NaroaIriarte
2014-11-20 10:16 AugustoMauch Web browser Google Chrome => Google Chrome
2014-11-20 10:16 AugustoMauch Steps to Reproduce Updated View Revisions
2014-11-24 09:42 hgbot Checkin
2014-11-24 09:42 hgbot Note Added: 0071918
2014-11-24 09:42 hgbot Status new => resolved
2014-11-24 09:42 hgbot Resolution open => fixed
2014-11-24 09:42 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/46e4ef62c01509bf71ef74d0338704f013e9e609 [^]
2014-11-24 09:43 alostale Review Assigned To => alostale
2014-11-24 09:43 alostale Note Added: 0071919
2014-11-24 09:43 alostale Status resolved => closed
2014-11-24 09:43 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073126


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker