Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027921
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POScriticalalways2014-10-20 20:322014-11-04 13:38
ReporterjecharriView Statuspublic 
Assigned Tomigueldejuana 
PriorityimmediateResolutionfixedFixed in VersionRR15Q1
StatusclosedFix in branchpiFixed in SCM revision0be6bec9c7c8
ProjectionnoneETAnoneTarget VersionRR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in releaseRR14Q2
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027921: Layaways are not being invoiced since Q2 cash up oflline change

DescriptionLayaways are not being invoiced since Q2 cash up oflline change
Steps To Reproduce-go to Web POS
-create a layaway and pay partially
-do the cash up
-verify that transaction is reconciled
-login again and pay pending amount
-do the cash up
-verify that layaway is not invoiced and also the transaction is not reconciled
Proposed SolutionEvery time that you upgrade the layaway, update the order cash up id.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0071070)
hgbot (developer)
2014-10-21 10:11

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 0be6bec9c7c84c4002a34a82e3119423e3b233c3
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Tue Oct 21 10:10:15 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0be6bec9c7c84c4002a34a82e3119423e3b233c3 [^]

Fixed issue 0027921: Layaways are not being invoiced since Q2 cash up oflline change

When a layaway is created we assign a cashupid, but if we payfull or partially again this layaway in another cashup, this transactions will not be reconciliated and invoice will not be created. We need to update the layaway with the new cashupid.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0071397)
mtaal (manager)
2014-11-04 13:38

Reviewed and tested

- Issue History
Date Modified Username Field Change
2014-10-20 20:32 jecharri New Issue
2014-10-20 20:32 jecharri Assigned To => marvintm
2014-10-20 20:32 jecharri Regression level => Production - Confirmed Stable
2014-10-20 20:32 jecharri Regression introduced in release => RR14Q2
2014-10-20 20:32 jecharri Triggers an Emergency Pack => No
2014-10-21 10:11 hgbot Checkin
2014-10-21 10:11 hgbot Note Added: 0071070
2014-10-21 10:11 hgbot Status new => resolved
2014-10-21 10:11 hgbot Resolution open => fixed
2014-10-21 10:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0be6bec9c7c84c4002a34a82e3119423e3b233c3 [^]
2014-10-21 10:51 marvintm Review Assigned To => marvintm
2014-10-21 10:51 marvintm Status resolved => closed
2014-10-27 15:04 migueldejuana Assigned To marvintm => migueldejuana
2014-10-27 15:04 migueldejuana Status closed => new
2014-10-27 15:04 migueldejuana Resolution fixed => open
2014-10-27 15:04 migueldejuana Status new => scheduled
2014-10-27 15:04 migueldejuana fix_in_branch => pi
2014-10-27 15:04 migueldejuana Status scheduled => resolved
2014-10-27 15:04 migueldejuana Resolution open => fixed
2014-11-04 13:38 mtaal Note Added: 0071397
2014-11-04 13:38 mtaal Status resolved => closed
2014-11-04 13:38 mtaal Fixed in Version => RR15Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker