Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027847
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2014-10-13 10:052014-12-30 23:23
ReporterpsanjuanView Statuspublic 
Assigned Toumartirena 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionf107db775c71
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027847: Error - It is not possible to match more amount than the invoice's Line Net Amount.

DescriptionError - It is not possible to match more amount than the invoice's Line Net Amount.

This error is shown whenever landed cost is created for "main" organization and then is matched against a purchase invoice created for any organization rather than main.
Steps To ReproduceGo to profile and select "QA Testing Admin" role and (*) as Organization. Set as default. Apply.

Navigate to Landed Cost window and create a new one for Organization Main (by mistake).

Go to Cost tab and select a landed cost type. Enter an amount of 875 by example.
Go to Receipt tab and select a receipt.
Process landed cost.

In our example landed cost number is 1000013

Go to purchase invoice window and create a new one for Spain organization. Enter a financial invoice by selecting same account (G/L item) than the landed cost type
Enter an amount of 875
Complete the invoice.

From lines press the button Match LC Cost, realize that landed cost with number 1000013 is shown and can be selected. Select it. Enter an amount of 500.
Select also checks "is matching adjusted"
Realize that below error is shown:
It is not possible to match more amount than the invoice's Line Net Amount (0).

See image attached.

Proposed SolutionIt should not be possible to create landed cost for organizations that do not allow transactions as it is not possible to create purchase invoices to match landed cost against
TagsNo tags attached.
Attached Filespng file icon issue_27847.png [^] (86,031 bytes) 2014-10-13 10:06

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0071257)
hgbot (developer)
2014-10-29 18:39

Repository: erp/devel/pi
Changeset: f107db775c714dc733cc75d4a8714a5dea222953
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Oct 29 17:39:58 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f107db775c714dc733cc75d4a8714a5dea222953 [^]

Fixes bug 27847: Dont allow the creation of Landed Cost for not Legal Entity org

The Window Type of Landed Cost window has been changed from 'Maintain' to 'Transaction'. So this window only could be used for transactional organizations.

---
M src-db/database/sourcedata/AD_WINDOW.xml
---
(0071258)
umartirena (developer)
2014-10-29 18:41

The error shown in the image is not a bug, is an error displayed when Line Net Amount of the Invoice Line is 0.00. The Line Net Amount should be different to 0.00 in order to be able to Match with a Landed Cost.
(0071274)
psanjuan (manager)
2014-10-30 14:48

Verified. landed Cost documents can now be created only for organizations (legal entities and generic) that allows transactions entering.
(0073002)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-13 10:05 psanjuan New Issue
2014-10-13 10:05 psanjuan Assigned To => dmiguelez
2014-10-13 10:05 psanjuan Modules => Core
2014-10-13 10:05 psanjuan Triggers an Emergency Pack => No
2014-10-13 10:06 psanjuan File Added: issue_27847.png
2014-10-13 10:07 psanjuan Proposed Solution updated
2014-10-13 10:08 psanjuan Assigned To dmiguelez => eduardo_Argal
2014-10-28 13:43 psanjuan Assigned To eduardo_Argal => umartirena
2014-10-29 18:39 hgbot Checkin
2014-10-29 18:39 hgbot Note Added: 0071257
2014-10-29 18:39 hgbot Status new => resolved
2014-10-29 18:39 hgbot Resolution open => fixed
2014-10-29 18:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f107db775c714dc733cc75d4a8714a5dea222953 [^]
2014-10-29 18:41 umartirena Note Added: 0071258
2014-10-30 14:48 psanjuan Note Added: 0071274
2014-10-30 14:48 psanjuan Proposed Solution updated
2014-10-30 14:48 psanjuan Status resolved => closed
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0073002


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker