Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027752
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2014-10-03 12:092014-12-30 23:22
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision8c58f8ee82a3
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-01-08
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d7f5fe16e7480baf9258c2d5bb6caf5e33bafcf9 [^]
Triggers an Emergency PackNo
Summary

0027752: Cannot ship more than the ordered quantity when Is Quantity Variable checkbox is selected for the product

DescriptionCannot ship more than the ordered quantity when Is Quantity Variable checkbox is selected for the product
Steps To ReproduceAs system admin role:
   Set the Is Quantity Variable field as Displayed in Product - Product tab
As group admin role:
   Set a product as Is Quantity Variable
   Create a Sales Order for that product and book it
   Create a Goods Shipment from that order
   Increase the movement quantity
   Try to complete it
   An error message shows that movement quantity is greater than ordered quantity
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00254003.0PR14Q2 closedAtulOpenbravo Openbravo ERP More quantity than the ordered can be shipped 
related to defect 0028175 closedvmromanos Modules Warehouse picking list is not taking into account the Product definition: Is quantity variable 

-  Notes
(0070917)
AtulOpenbravo (developer)
2014-10-14 11:44

Test Plan
- Login as System administrator
- Set the Is Quantity Variable field as Displayed in Product - Product tab
- Login as F&B International Group Admin.
- Set a product as Is Quantity Variable for any record.
- Create a Sales Order for that product and book it.
- Create a Goods Shipment from that order.
- In lines increase the movement quantity
- Try to complete it. Shipment gets processed successfully.
(0070918)
hgbot (developer)
2014-10-14 12:36

Repository: erp/devel/pi
Changeset: 8c58f8ee82a3f09e8f5afeb00f490cdf21cbc45b
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Oct 14 15:12:25 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/8c58f8ee82a3f09e8f5afeb00f490cdf21cbc45b [^]

Fixes Issue 27752:Cannot ship more than the ordered quantity when Is Quantity
Variable checkbox is selected for the product

While processing shipment Line wise exceed check for delivered qty against
ordered qty for each order line is skipped when product flag for variable
quantity is set as Yes

---
M src-db/database/model/functions/M_INOUT_POST.xml
---
(0070919)
vmromanos (developer)
2014-10-14 12:37

Code review + testing OK
(0072934)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-03 12:09 ngarcia New Issue
2014-10-03 12:09 ngarcia Assigned To => AtulOpenbravo
2014-10-03 12:09 ngarcia Modules => Core
2014-10-03 12:09 ngarcia Regression level => Production - Confirmed Stable
2014-10-03 12:09 ngarcia Regression date => 2014-01-08
2014-10-03 12:09 ngarcia Regression introduced in release => 3.0PR14Q2
2014-10-03 12:09 ngarcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d7f5fe16e7480baf9258c2d5bb6caf5e33bafcf9 [^]
2014-10-03 12:09 ngarcia Triggers an Emergency Pack => No
2014-10-03 12:10 ngarcia Summary Cannot ship more than the ordered quantity when is quantity variable checkbox selected for the product => Cannot ship more than the ordered quantity when Is Quantity Variable checkbox is selected for the product
2014-10-03 12:10 ngarcia Description Updated View Revisions
2014-10-03 12:10 ngarcia Issue Monitored: networkb
2014-10-03 12:18 ngarcia Relationship added caused by 0025400
2014-10-14 10:29 AtulOpenbravo Status new => scheduled
2014-10-14 10:29 AtulOpenbravo fix_in_branch => pi
2014-10-14 11:44 AtulOpenbravo Note Added: 0070917
2014-10-14 12:36 hgbot Checkin
2014-10-14 12:36 hgbot Note Added: 0070918
2014-10-14 12:36 hgbot Status scheduled => resolved
2014-10-14 12:36 hgbot Resolution open => fixed
2014-10-14 12:36 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8c58f8ee82a3f09e8f5afeb00f490cdf21cbc45b [^]
2014-10-14 12:37 vmromanos Review Assigned To => vmromanos
2014-10-14 12:37 vmromanos Note Added: 0070919
2014-10-14 12:37 vmromanos Status resolved => closed
2014-11-14 08:20 VictorVillar Relationship added related to 0028175
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072934


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker