Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027633
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-09-18 10:182014-09-22 09:15
ReporterjonalegriaesarteView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revisionf593014afc2a
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027633: Tree view keeps showing the loading message when there is no data to show

DescriptionTree view keeps showing the loading message when there is no data to show
Steps To ReproduceAs F&B Admin
- Open the Product Characteristics window
- Create a new record in the header tab
- Go to the Value subtab. It does not have any records.
- Open the tree view. Check that the Loading message is shown and never hidden
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0070196)
hgbot (developer)
2014-09-18 17:23

Repository: erp/devel/pi
Changeset: f593014afc2a2c93dd3b9b504f6118f3d448a865
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Sep 18 17:21:13 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f593014afc2a2c93dd3b9b504f6118f3d448a865 [^]

Fixes issue 27633: Tree view does not show Loading message when it has no data

The problem was that the noDataEmptyMessage attribute, that contains the message to be shown when the grid does not have any data, did not have the proper value. This attribute is reused to also show the Loading message while the datasource request is being processed, but was not being reset to its proper value (OBUIAPP_NoDataInGrid message) when the data arrived to the tree.

Now in the OBTreeViewGrid.dataArrived function the message is properly reset before invoking the resetEmptyMessage function, that will actually display the message if the datasource did not return any records.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-view-grid.js
---
(0070216)
hudsonbot (developer)
2014-09-19 20:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/af234b76a941 [^]
Maturity status: Test
(0070221)
shankarb (developer)
2014-09-22 09:15

Code reviewed and verified in pi changeset 99b060690c1f

- Issue History
Date Modified Username Field Change
2014-09-18 10:18 jonalegriaesarte New Issue
2014-09-18 10:18 jonalegriaesarte Assigned To => AugustoMauch
2014-09-18 10:18 jonalegriaesarte Modules => Core
2014-09-18 10:18 jonalegriaesarte Triggers an Emergency Pack => No
2014-09-18 10:25 AugustoMauch Summary Tree view keeps always loading when there is no data to show => Tree view keeps showing the loading message when there is no data to show
2014-09-18 10:25 AugustoMauch Description Updated View Revisions
2014-09-18 10:25 AugustoMauch Steps to Reproduce Updated View Revisions
2014-09-18 17:21 AugustoMauch Issue Monitored: shankarb
2014-09-18 17:22 AugustoMauch Review Assigned To => shankarb
2014-09-18 17:23 hgbot Checkin
2014-09-18 17:23 hgbot Note Added: 0070196
2014-09-18 17:23 hgbot Status new => resolved
2014-09-18 17:23 hgbot Resolution open => fixed
2014-09-18 17:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f593014afc2a2c93dd3b9b504f6118f3d448a865 [^]
2014-09-19 20:23 hudsonbot Checkin
2014-09-19 20:23 hudsonbot Note Added: 0070216
2014-09-22 09:15 shankarb Note Added: 0070221
2014-09-22 09:15 shankarb Status resolved => closed
2014-09-22 09:15 shankarb Fixed in Version => 3.0PR14Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker