Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027621
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionarycriticalalways2014-09-16 18:502014-09-23 00:26
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revisiond93c32f374f9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027621: If you get a network interruption when clicking on the edit item button , then the button does not work anymore

DescriptionIf you get a network interruption when clicking on the edit item button , then the button does not work anymore.
Steps To ReproduceIssue reproducible in all pick and execute related buttons.


As F&B Admin:
- Open the Return from Customer Window
- Create a header row
- Click on the Pick/Edit lines button. *It works
- Close the Pick/Edit window
-Remove internet connection
- Click on the button again. It does not open, this is expected.
-Restore the connection
- Click again on the button. It does not work. This is wrong.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0019779 closeddbaz [PNE] Clicking twice fastly the "Pick and Execute" button process can open the window with two grids 
related to defect 0035268 closedjarmendariz Request timeout message is not handled properly in the UI 

-  Notes
(0070195)
hgbot (developer)
2014-09-18 16:44

Repository: erp/devel/pi
Changeset: fe985b84dd7f5a86961b5b496854b769ac1a8837
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu Sep 18 20:10:02 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/fe985b84dd7f5a86961b5b496854b769ac1a8837 [^]

Fixes Issue 27621: Button works after interruption by network issues.

The problem was if you get a network interruption when clicking on the edit item button,
then the button does not work anymore.The opening variable was not reset in case of errors.
Now it has been reset.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
---
(0070203)
hudsonbot (developer)
2014-09-19 00:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/fd85fc030a49 [^]
Maturity status: Test
(0070205)
AugustoMauch (developer)
2014-09-19 12:54

Reopened because it was making this issue [1] reproducible.

[1] https://issues.openbravo.com/view.php?id=19779 [^]
(0070206)
hgbot (developer)
2014-09-19 13:00

Repository: erp/devel/pi
Changeset: c6301654f7cff8e8e23abb63c09b43df8c57779e
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 19 12:56:37 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c6301654f7cff8e8e23abb63c09b43df8c57779e [^]

Related with issue 27621: Fix backed out because it was causing a regression

The fix being backed out was making this issue [1] reproducible.

[1] https://issues.openbravo.com/view.php?id=19779 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
---
(0070208)
hgbot (developer)
2014-09-19 13:12

Repository: erp/devel/pi
Changeset: d93c32f374f9514feb6e985e8ce8bee8d210af54
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 19 13:11:16 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d93c32f374f9514feb6e985e8ce8bee8d210af54 [^]

Fixes issue 27621: Button works after having connectivity problems

The problem was that there was in place a mechanism to prevent accidentally opening a process twice, that was not working properly if the button was clicked while having network conectivity problems. In that case a flag (button.opening) was being set to true when the button was clicked, but was never set to false, so the next time the button was clicked the mechanism thought that it was still being opened and canceled all subsequent openings.

To fix this, a new parameter, errorCallback, has been added to the OB.RemoteCallManager.call function. This function, if defined, will be executed when the call returns with a status error.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/toolbar/ob-action-button.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-remote-call-manager.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0070219)
hudsonbot (developer)
2014-09-19 20:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/af234b76a941 [^]
Maturity status: Test
(0070227)
shankarb (developer)
2014-09-22 10:35

Code reviewed and verified in pi changeset 99b060690c1f.
(0070252)
hudsonbot (developer)
2014-09-23 00:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/93190db52ee6 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-09-16 18:50 egoitz New Issue
2014-09-16 18:50 egoitz Assigned To => naiaramartinez
2014-09-16 18:50 egoitz Resolution time => 1410991200
2014-09-16 19:01 egoitz Assigned To naiaramartinez => AugustoMauch
2014-09-17 08:44 jpcalvente Issue Monitored: jpcalvente
2014-09-17 11:21 shankarb Project Modules => Openbravo ERP
2014-09-17 11:22 shankarb Modules => Core
2014-09-17 11:22 shankarb Triggers an Emergency Pack => No
2014-09-17 11:22 shankarb Category Warehouse Picking => 00. Application dictionary
2014-09-17 11:22 shankarb Steps to Reproduce Updated View Revisions
2014-09-18 16:41 shankarb Review Assigned To => AugustoMauch
2014-09-18 16:41 shankarb Assigned To AugustoMauch => shankarb
2014-09-18 16:43 shankarb Issue Monitored: AugustoMauch
2014-09-18 16:44 hgbot Checkin
2014-09-18 16:44 hgbot Note Added: 0070195
2014-09-18 16:44 hgbot Status new => resolved
2014-09-18 16:44 hgbot Resolution open => fixed
2014-09-18 16:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fe985b84dd7f5a86961b5b496854b769ac1a8837 [^]
2014-09-19 00:18 hudsonbot Checkin
2014-09-19 00:18 hudsonbot Note Added: 0070203
2014-09-19 12:54 AugustoMauch Assigned To shankarb => AugustoMauch
2014-09-19 12:54 AugustoMauch Note Added: 0070205
2014-09-19 12:54 AugustoMauch Status resolved => new
2014-09-19 12:54 AugustoMauch Resolution fixed => open
2014-09-19 12:57 AugustoMauch Relationship added related to 0019779
2014-09-19 13:00 hgbot Checkin
2014-09-19 13:00 hgbot Note Added: 0070206
2014-09-19 13:04 AugustoMauch Steps to Reproduce Updated View Revisions
2014-09-19 13:11 AugustoMauch Issue End Monitor: AugustoMauch
2014-09-19 13:11 AugustoMauch Issue Monitored: shankarb
2014-09-19 13:11 AugustoMauch Review Assigned To AugustoMauch => shankarb
2014-09-19 13:12 hgbot Checkin
2014-09-19 13:12 hgbot Note Added: 0070208
2014-09-19 13:12 hgbot Status new => resolved
2014-09-19 13:12 hgbot Resolution open => fixed
2014-09-19 13:12 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/fe985b84dd7f5a86961b5b496854b769ac1a8837 [^] => http://code.openbravo.com/erp/devel/pi/rev/d93c32f374f9514feb6e985e8ce8bee8d210af54 [^]
2014-09-19 20:23 hudsonbot Checkin
2014-09-19 20:23 hudsonbot Note Added: 0070219
2014-09-22 10:35 shankarb Note Added: 0070227
2014-09-22 10:35 shankarb Status resolved => closed
2014-09-22 10:35 shankarb Fixed in Version => 3.0PR14Q4
2014-09-23 00:26 hudsonbot Checkin
2014-09-23 00:26 hudsonbot Note Added: 0070252
2017-02-15 08:51 caristu Relationship added related to 0035268


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker