Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027053
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-07-11 11:482014-10-01 16:07
ReportermaiteView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revisionf5caad158261
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-03-05
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/381047f42270513a9fbfae0c09866e77f835061b [^]
Triggers an Emergency PackYes
Summary

0027053: Error when adding record in grid mode and working with comma as decimal separator

DescriptionError when adding record in grid mode and working with comma as decimal separator
Steps To Reproduce0. Edit Format.xml file to set "comma" as decimal separator for prices reference
1. Compile and restart tomcat
2. Access Sales Invoice header and create record
3. Access Lines tab and "Insert row" in grid mode. Choose any product and change price to set 458,45. Immediately click on "Line Net amount" field (which is a read only field) and realize that saved "Net Unit Price" is 45.845,00 (instead of 458,45)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00255173.0PR14Q3 closedshankarb Wrong calculations on numeric field depending on the formula 
has duplicate defect 00276683.0PR14Q4 closedAugustoMauch Amount change when focus is lost on price fields with comma as decimal separator 

-  Notes
(0070244)
vmromanos (developer)
2014-09-22 16:15

Assigned to Platform team
(0070430)
mirurita (developer)
2014-09-26 10:21

The same behaviour happens in "amount" reference columns such as "amount" in payment in window.
(0070439)
hgbot (developer)
2014-09-26 16:07

Repository: erp/devel/pi
Changeset: f5caad158261168b4347c1f92bbafa301e3304e7
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Sep 26 15:55:41 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f5caad158261168b4347c1f92bbafa301e3304e7 [^]

Fixes issue 27053: Numbers are properly formatted with , as decimal separator

Decimal numbers were not being properly formatted if a comma was used as decimal separator. The problem was caused by using the OBPlainToOBMasked instead of JSToOBMasked to convert a javascript number to a formatted string. OBPlainToOBMasked does not expect a javascript number as an argument, but a non-formatted string representation of a number. The issue has been fixed by replacing OBPlainToOBMasked with JSToOBMasked.

The issue that caused this regression [1] works the same as it worked when it was fixed. It works properly using the '.' as decimal separator, but not when using ','

[1] https://issues.openbravo.com/view.php?id=25517 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0070515)
hudsonbot (developer)
2014-09-29 22:00

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b0bbca1e7e46 [^]
Maturity status: Test
(0070532)
shankarb (developer)
2014-09-30 07:54

Code reviewed and verified in pi changeset 6c864add1905.

- Issue History
Date Modified Username Field Change
2014-07-11 11:48 maite New Issue
2014-07-11 11:48 maite Assigned To => dmiguelez
2014-07-11 11:48 maite Modules => Core
2014-07-11 11:48 maite Triggers an Emergency Pack => No
2014-07-11 11:50 maite Issue Monitored: networkb
2014-07-11 11:52 maite Assigned To dmiguelez => jonalegriaesarte
2014-07-24 13:45 jonalegriaesarte Assigned To jonalegriaesarte => AtulOpenbravo
2014-09-22 16:15 vmromanos Note Added: 0070244
2014-09-22 16:15 vmromanos Assigned To AtulOpenbravo => AugustoMauch
2014-09-22 16:15 vmromanos Category 07. Sales management => A. Platform
2014-09-23 09:54 inigosanchez Assigned To AugustoMauch => inigosanchez
2014-09-24 10:45 caristu Relationship added has duplicate 0027668
2014-09-24 10:47 caristu Issue Monitored: caristu
2014-09-26 10:21 mirurita Note Added: 0070430
2014-09-26 10:40 jonalegriaesarte Priority urgent => immediate
2014-09-26 12:06 inigosanchez Assigned To inigosanchez => AugustoMauch
2014-09-26 12:07 inigosanchez Issue Monitored: inigosanchez
2014-09-26 15:31 AugustoMauch Regression date => 2014-03-05
2014-09-26 15:31 AugustoMauch Regression introduced in release => 3.0PR14Q2
2014-09-26 15:31 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/381047f42270513a9fbfae0c09866e77f835061b [^]
2014-09-26 15:31 AugustoMauch Triggers an Emergency Pack No => Yes
2014-09-26 15:50 AugustoMauch Relationship added caused by 0025517
2014-09-26 16:06 AugustoMauch Issue Monitored: shankarb
2014-09-26 16:06 AugustoMauch Review Assigned To => shankarb
2014-09-26 16:07 hgbot Checkin
2014-09-26 16:07 hgbot Note Added: 0070439
2014-09-26 16:07 hgbot Status new => resolved
2014-09-26 16:07 hgbot Resolution open => fixed
2014-09-26 16:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f5caad158261168b4347c1f92bbafa301e3304e7 [^]
2014-09-29 22:00 hudsonbot Checkin
2014-09-29 22:00 hudsonbot Note Added: 0070515
2014-09-30 07:54 shankarb Note Added: 0070532
2014-09-30 07:54 shankarb Status resolved => closed
2014-09-30 07:54 shankarb Fixed in Version => 3.0PR14Q4
2014-10-01 16:07 plujan Regression level => Production - Confirmed Stable


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker